aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-02-10 15:22:52 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-02-10 15:22:52 +0000
commit679032a2066f13b07f7d4b3f419c0225693ef2f8 (patch)
tree452252a84e3e627cf9157c20ed7fb5e44cd6746b /x11
parente87af08d876fa373a8b697bde4e9b69df3075bf0 (diff)
downloadports-679032a2066f13b07f7d4b3f419c0225693ef2f8.tar.gz
ports-679032a2066f13b07f7d4b3f419c0225693ef2f8.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/kde4-baseapps/Makefile19
-rw-r--r--x11/kde4-runtime/Makefile19
-rw-r--r--x11/kde4-workspace/Makefile19
-rw-r--r--x11/kdebase3/Makefile19
-rw-r--r--x11/kdebase4-runtime/Makefile19
-rw-r--r--x11/kdebase4-workspace/Makefile19
-rw-r--r--x11/kdebase4/Makefile19
7 files changed, 42 insertions, 91 deletions
diff --git a/x11/kde4-baseapps/Makefile b/x11/kde4-baseapps/Makefile
index fa24519d655a..fbc50933f025 100644
--- a/x11/kde4-baseapps/Makefile
+++ b/x11/kde4-baseapps/Makefile
@@ -41,27 +41,20 @@ CONFIGURE_ARGS+=--without-java \
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.pre.mk>
-.if exists(${X11BASE}/include/Xm/Xm.h)
-WITH_MOTIF= yes
-.endif # exists(${X11BASE}/include/Xm/Xm.h)
-
.if defined(WITHOUT_MOTIF)
-.undef WITH_MOTIF
CONFIGURE_ARGS+= --without-motif
-.endif # defined(WITHOUT_MOTIF)
-
-.if defined(WITH_MOTIF)
+.else
USE_MOTIF= yes
PLIST_APPEND+= plist.motif
-.else
+
pre-extract::
@${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with Motif support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_MOTIF=yes\""
+ @${ECHO_MSG} "If you want to compile WITHOUT Motif support, hit"
+ @${ECHO_MSG} "Ctrl-C right now and use \"make WITHOUT_MOTIF=yes\""
@${ECHO_MSG}
- @${ECHO_MSG} "Motif is used for Netscape plugin compatibility."
+ @${ECHO_MSG} "This will DISABLE netscape plugin compatibility."
@${ECHO_MSG}
-.endif # defined(WITH_MOTIF)
+.endif # defined(WITHOUT_MOTIF)
post-extract:
@${ECHO} "#!/bin/sh" > ${WRKSRC}/mkpamserv
diff --git a/x11/kde4-runtime/Makefile b/x11/kde4-runtime/Makefile
index fa24519d655a..fbc50933f025 100644
--- a/x11/kde4-runtime/Makefile
+++ b/x11/kde4-runtime/Makefile
@@ -41,27 +41,20 @@ CONFIGURE_ARGS+=--without-java \
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.pre.mk>
-.if exists(${X11BASE}/include/Xm/Xm.h)
-WITH_MOTIF= yes
-.endif # exists(${X11BASE}/include/Xm/Xm.h)
-
.if defined(WITHOUT_MOTIF)
-.undef WITH_MOTIF
CONFIGURE_ARGS+= --without-motif
-.endif # defined(WITHOUT_MOTIF)
-
-.if defined(WITH_MOTIF)
+.else
USE_MOTIF= yes
PLIST_APPEND+= plist.motif
-.else
+
pre-extract::
@${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with Motif support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_MOTIF=yes\""
+ @${ECHO_MSG} "If you want to compile WITHOUT Motif support, hit"
+ @${ECHO_MSG} "Ctrl-C right now and use \"make WITHOUT_MOTIF=yes\""
@${ECHO_MSG}
- @${ECHO_MSG} "Motif is used for Netscape plugin compatibility."
+ @${ECHO_MSG} "This will DISABLE netscape plugin compatibility."
@${ECHO_MSG}
-.endif # defined(WITH_MOTIF)
+.endif # defined(WITHOUT_MOTIF)
post-extract:
@${ECHO} "#!/bin/sh" > ${WRKSRC}/mkpamserv
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index fa24519d655a..fbc50933f025 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -41,27 +41,20 @@ CONFIGURE_ARGS+=--without-java \
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.pre.mk>
-.if exists(${X11BASE}/include/Xm/Xm.h)
-WITH_MOTIF= yes
-.endif # exists(${X11BASE}/include/Xm/Xm.h)
-
.if defined(WITHOUT_MOTIF)
-.undef WITH_MOTIF
CONFIGURE_ARGS+= --without-motif
-.endif # defined(WITHOUT_MOTIF)
-
-.if defined(WITH_MOTIF)
+.else
USE_MOTIF= yes
PLIST_APPEND+= plist.motif
-.else
+
pre-extract::
@${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with Motif support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_MOTIF=yes\""
+ @${ECHO_MSG} "If you want to compile WITHOUT Motif support, hit"
+ @${ECHO_MSG} "Ctrl-C right now and use \"make WITHOUT_MOTIF=yes\""
@${ECHO_MSG}
- @${ECHO_MSG} "Motif is used for Netscape plugin compatibility."
+ @${ECHO_MSG} "This will DISABLE netscape plugin compatibility."
@${ECHO_MSG}
-.endif # defined(WITH_MOTIF)
+.endif # defined(WITHOUT_MOTIF)
post-extract:
@${ECHO} "#!/bin/sh" > ${WRKSRC}/mkpamserv
diff --git a/x11/kdebase3/Makefile b/x11/kdebase3/Makefile
index fa24519d655a..fbc50933f025 100644
--- a/x11/kdebase3/Makefile
+++ b/x11/kdebase3/Makefile
@@ -41,27 +41,20 @@ CONFIGURE_ARGS+=--without-java \
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.pre.mk>
-.if exists(${X11BASE}/include/Xm/Xm.h)
-WITH_MOTIF= yes
-.endif # exists(${X11BASE}/include/Xm/Xm.h)
-
.if defined(WITHOUT_MOTIF)
-.undef WITH_MOTIF
CONFIGURE_ARGS+= --without-motif
-.endif # defined(WITHOUT_MOTIF)
-
-.if defined(WITH_MOTIF)
+.else
USE_MOTIF= yes
PLIST_APPEND+= plist.motif
-.else
+
pre-extract::
@${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with Motif support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_MOTIF=yes\""
+ @${ECHO_MSG} "If you want to compile WITHOUT Motif support, hit"
+ @${ECHO_MSG} "Ctrl-C right now and use \"make WITHOUT_MOTIF=yes\""
@${ECHO_MSG}
- @${ECHO_MSG} "Motif is used for Netscape plugin compatibility."
+ @${ECHO_MSG} "This will DISABLE netscape plugin compatibility."
@${ECHO_MSG}
-.endif # defined(WITH_MOTIF)
+.endif # defined(WITHOUT_MOTIF)
post-extract:
@${ECHO} "#!/bin/sh" > ${WRKSRC}/mkpamserv
diff --git a/x11/kdebase4-runtime/Makefile b/x11/kdebase4-runtime/Makefile
index fa24519d655a..fbc50933f025 100644
--- a/x11/kdebase4-runtime/Makefile
+++ b/x11/kdebase4-runtime/Makefile
@@ -41,27 +41,20 @@ CONFIGURE_ARGS+=--without-java \
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.pre.mk>
-.if exists(${X11BASE}/include/Xm/Xm.h)
-WITH_MOTIF= yes
-.endif # exists(${X11BASE}/include/Xm/Xm.h)
-
.if defined(WITHOUT_MOTIF)
-.undef WITH_MOTIF
CONFIGURE_ARGS+= --without-motif
-.endif # defined(WITHOUT_MOTIF)
-
-.if defined(WITH_MOTIF)
+.else
USE_MOTIF= yes
PLIST_APPEND+= plist.motif
-.else
+
pre-extract::
@${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with Motif support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_MOTIF=yes\""
+ @${ECHO_MSG} "If you want to compile WITHOUT Motif support, hit"
+ @${ECHO_MSG} "Ctrl-C right now and use \"make WITHOUT_MOTIF=yes\""
@${ECHO_MSG}
- @${ECHO_MSG} "Motif is used for Netscape plugin compatibility."
+ @${ECHO_MSG} "This will DISABLE netscape plugin compatibility."
@${ECHO_MSG}
-.endif # defined(WITH_MOTIF)
+.endif # defined(WITHOUT_MOTIF)
post-extract:
@${ECHO} "#!/bin/sh" > ${WRKSRC}/mkpamserv
diff --git a/x11/kdebase4-workspace/Makefile b/x11/kdebase4-workspace/Makefile
index fa24519d655a..fbc50933f025 100644
--- a/x11/kdebase4-workspace/Makefile
+++ b/x11/kdebase4-workspace/Makefile
@@ -41,27 +41,20 @@ CONFIGURE_ARGS+=--without-java \
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.pre.mk>
-.if exists(${X11BASE}/include/Xm/Xm.h)
-WITH_MOTIF= yes
-.endif # exists(${X11BASE}/include/Xm/Xm.h)
-
.if defined(WITHOUT_MOTIF)
-.undef WITH_MOTIF
CONFIGURE_ARGS+= --without-motif
-.endif # defined(WITHOUT_MOTIF)
-
-.if defined(WITH_MOTIF)
+.else
USE_MOTIF= yes
PLIST_APPEND+= plist.motif
-.else
+
pre-extract::
@${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with Motif support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_MOTIF=yes\""
+ @${ECHO_MSG} "If you want to compile WITHOUT Motif support, hit"
+ @${ECHO_MSG} "Ctrl-C right now and use \"make WITHOUT_MOTIF=yes\""
@${ECHO_MSG}
- @${ECHO_MSG} "Motif is used for Netscape plugin compatibility."
+ @${ECHO_MSG} "This will DISABLE netscape plugin compatibility."
@${ECHO_MSG}
-.endif # defined(WITH_MOTIF)
+.endif # defined(WITHOUT_MOTIF)
post-extract:
@${ECHO} "#!/bin/sh" > ${WRKSRC}/mkpamserv
diff --git a/x11/kdebase4/Makefile b/x11/kdebase4/Makefile
index fa24519d655a..fbc50933f025 100644
--- a/x11/kdebase4/Makefile
+++ b/x11/kdebase4/Makefile
@@ -41,27 +41,20 @@ CONFIGURE_ARGS+=--without-java \
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.pre.mk>
-.if exists(${X11BASE}/include/Xm/Xm.h)
-WITH_MOTIF= yes
-.endif # exists(${X11BASE}/include/Xm/Xm.h)
-
.if defined(WITHOUT_MOTIF)
-.undef WITH_MOTIF
CONFIGURE_ARGS+= --without-motif
-.endif # defined(WITHOUT_MOTIF)
-
-.if defined(WITH_MOTIF)
+.else
USE_MOTIF= yes
PLIST_APPEND+= plist.motif
-.else
+
pre-extract::
@${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with Motif support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_MOTIF=yes\""
+ @${ECHO_MSG} "If you want to compile WITHOUT Motif support, hit"
+ @${ECHO_MSG} "Ctrl-C right now and use \"make WITHOUT_MOTIF=yes\""
@${ECHO_MSG}
- @${ECHO_MSG} "Motif is used for Netscape plugin compatibility."
+ @${ECHO_MSG} "This will DISABLE netscape plugin compatibility."
@${ECHO_MSG}
-.endif # defined(WITH_MOTIF)
+.endif # defined(WITHOUT_MOTIF)
post-extract:
@${ECHO} "#!/bin/sh" > ${WRKSRC}/mkpamserv