aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2020-09-28 20:05:01 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2020-09-28 20:05:01 +0000
commitacd1ae3a870cd3476f3d16f89cac0f335f69fb9a (patch)
tree6aa7d69439a991fdd260e0d369eca05546f7b245 /x11
parenta8d9df7e30557c1906ff7119a287ea9d68f2bcc9 (diff)
downloadports-acd1ae3a870cd3476f3d16f89cac0f335f69fb9a.tar.gz
ports-acd1ae3a870cd3476f3d16f89cac0f335f69fb9a.zip
x11/libinput: Update to 1.6.1
Notes
Notes: svn path=/head/; revision=550444
Diffstat (limited to 'x11')
-rw-r--r--x11/libinput/Makefile6
-rw-r--r--x11/libinput/distinfo6
-rw-r--r--x11/libinput/files/patch-src_evdev.c8
-rw-r--r--x11/libinput/pkg-plist6
4 files changed, 17 insertions, 9 deletions
diff --git a/x11/libinput/Makefile b/x11/libinput/Makefile
index d549de94438f..4a92c8c28c09 100644
--- a/x11/libinput/Makefile
+++ b/x11/libinput/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= libinput
-PORTVERSION= 1.15.6
+PORTVERSION= 1.16.1
CATEGORIES= x11
MASTER_SITES= http://freedesktop.org/software/${PORTNAME}/
@@ -24,9 +24,11 @@ USE_LDCONFIG= yes
MESON_ARGS+= -Ddocumentation=false -Dtests=false
python_OLD_CMD= "/usr/bin/env python3"
-SHEBANG_FILES= tools/libinput-measure-fuzz.py \
+SHEBANG_FILES= tools/libinput-analyze-per-slot-delta.py \
+ tools/libinput-measure-fuzz.py \
tools/libinput-measure-touch-size.py \
tools/libinput-measure-touchpad-pressure.py \
+ tools/libinput-measure-touchpad-size.py \
tools/libinput-measure-touchpad-tap.py \
tools/libinput-replay
diff --git a/x11/libinput/distinfo b/x11/libinput/distinfo
index f06d22965a01..af237a69db3a 100644
--- a/x11/libinput/distinfo
+++ b/x11/libinput/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1593629662
-SHA256 (libinput-1.15.6.tar.xz) = aeedea216a6317ddc6e27c3d54f26b987078780db6a8320cc09e19c25b307f1c
-SIZE (libinput-1.15.6.tar.xz) = 584184
+TIMESTAMP = 1600507648
+SHA256 (libinput-1.16.1.tar.xz) = 7ba7d1aeedd15168bb21d17e9e628aa1c27957963a423a3fea3938a501758539
+SIZE (libinput-1.16.1.tar.xz) = 595548
diff --git a/x11/libinput/files/patch-src_evdev.c b/x11/libinput/files/patch-src_evdev.c
index c2ceddaed68c..df8fe4fd434a 100644
--- a/x11/libinput/files/patch-src_evdev.c
+++ b/x11/libinput/files/patch-src_evdev.c
@@ -6,9 +6,9 @@ libinput reopens devices just to check path equality.
The udev_devices from reopening do have the right properties,
so we just use them instead of the original (enumerated) ones.
---- src/evdev.c.orig 2018-12-18 05:06:18 UTC
+--- src/evdev.c.orig 2020-07-15 01:54:15 UTC
+++ src/evdev.c
-@@ -905,7 +905,7 @@ evdev_sync_device(struct evdev_device *device)
+@@ -1015,7 +1015,7 @@ evdev_sync_device(struct evdev_device *device)
evdev_device_dispatch_one(device, &ev);
} while (rc == LIBEVDEV_READ_STATUS_SYNC);
@@ -16,8 +16,8 @@ so we just use them instead of the original (enumerated) ones.
+ return (rc == -EAGAIN || rc == -EINVAL)? 0 : rc;
}
- static void
-@@ -943,6 +943,17 @@ evdev_device_dispatch(void *data)
+ static inline void
+@@ -1083,6 +1083,17 @@ evdev_device_dispatch(void *data)
if (rc != -EAGAIN && rc != -EINTR) {
libinput_remove_source(libinput, device->source);
diff --git a/x11/libinput/pkg-plist b/x11/libinput/pkg-plist
index 20ee3f645f02..f873ead64853 100644
--- a/x11/libinput/pkg-plist
+++ b/x11/libinput/pkg-plist
@@ -6,16 +6,21 @@ lib/libinput.so.10.13.0
libdata/pkgconfig/libinput.pc
libexec/libinput/libinput-debug-events
%%DEBUG_GUI%%libexec/libinput/libinput-debug-gui
+libexec/libinput/libinput-analyze
+libexec/libinput/libinput-analyze-per-slot-delta
libexec/libinput/libinput-debug-tablet
libexec/libinput/libinput-list-devices
libexec/libinput/libinput-measure
libexec/libinput/libinput-measure-fuzz
libexec/libinput/libinput-measure-touch-size
libexec/libinput/libinput-measure-touchpad-pressure
+libexec/libinput/libinput-measure-touchpad-size
libexec/libinput/libinput-measure-touchpad-tap
libexec/libinput/libinput-quirks
libexec/libinput/libinput-record
libexec/libinput/libinput-replay
+man/man1/libinput-analyze.1.gz
+man/man1/libinput-analyze-per-slot-delta.1.gz
man/man1/libinput-debug-events.1.gz
%%DEBUG_GUI%%man/man1/libinput-debug-gui.1.gz
man/man1/libinput-debug-tablet.1.gz
@@ -23,6 +28,7 @@ man/man1/libinput-list-devices.1.gz
man/man1/libinput-measure-fuzz.1.gz
man/man1/libinput-measure-touch-size.1.gz
man/man1/libinput-measure-touchpad-pressure.1.gz
+man/man1/libinput-measure-touchpad-size.1.gz
man/man1/libinput-measure-touchpad-tap.1.gz
man/man1/libinput-measure.1.gz
man/man1/libinput-quirks-list.1.gz