aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2003-12-03 16:57:36 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2003-12-03 16:57:36 +0000
commitdda5182fe494991355dc0608499acdc2a8014036 (patch)
tree122ae4bbaa1bd755453c02b6e2172b673ce76825 /x11
parentc4816a48cce65dc4d8a4e8bf759c870844f7fef4 (diff)
downloadports-dda5182fe494991355dc0608499acdc2a8014036.tar.gz
ports-dda5182fe494991355dc0608499acdc2a8014036.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/linux-XFree86-libs/Makefile42
1 files changed, 25 insertions, 17 deletions
diff --git a/x11/linux-XFree86-libs/Makefile b/x11/linux-XFree86-libs/Makefile
index dd1bb422b109..f1e64d57095f 100644
--- a/x11/linux-XFree86-libs/Makefile
+++ b/x11/linux-XFree86-libs/Makefile
@@ -11,37 +11,45 @@ PORTREVISION= 1
CATEGORIES= x11 linux
MASTER_SITES= ${MASTER_SITE_REDHAT_LINUX}
MASTER_SITE_SUBDIR= updates/9/en/os/i386
+PKGNAMEPREFIX= linux-
+DISTNAME= XFree86-libs-4.3.0-2.90.43.i386.rpm
+EXTRACT_SUFX=
+DIST_SUBDIR= rpm
+EXTRACT_ONLY=
MAINTAINER= trevor@FreeBSD.org
COMMENT= XFree86 libraries, Linux/i386 binary
-CONFLICTS= linux_base-6* linux_base-7* linux_base-deb* linux_base-gentoo*
-BUILD_DEPENDS= rpm2cpio:${PORTSDIR}/archivers/rpm2cpio
+BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
RUN_DEPENDS=${LINUXBASE}/lib/libc-2.3.2.so:${PORTSDIR}/emulators/linux_base-8
BASEVERSION= 9
+CONFLICTS= linux_base-6* linux_base-7* linux_base-deb* linux_base-gentoo*
+MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
+NO_BUILD= yes
+NO_FILTER_SHLIBS= yes
ONLY_FOR_ARCHS= i386
PLIST= ${WRKDIR}/plist
-RPM_SET= XFree86-libs-4.3.0-2.90.43.i386.rpm
+PREFIX= ${LINUXBASE}
pre-install:
- ${RM} -rf ${WRKSRC}/tmp
- ${MKDIR} ${WRKSRC}/tmp
- cd ${WRKSRC}/tmp; \
- rpm2cpio < ${DISTDIR}/${DIST_SUBDIR}/${RPM_SET} | cpio -id; \
+ @${RM} -rf ${WRKSRC}/tmp
+ @${MKDIR} ${WRKSRC}/tmp
+ @cd ${WRKSRC}/tmp; \
+ rpm2cpio < ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} | cpio -id; \
${FIND} * -type f -o -type l > ${PLIST}
-.for ii in \
- usr/X11R6/lib/X11/locale/lib/common \
- usr/X11R6/lib/X11/locale/lib \
- usr/X11R6/lib/X11/locale \
- usr/X11R6/lib/X11
- ${ECHO_CMD} @dirrm ${ii} >> ${PLIST}
+.for ii in X11/locale/lib/common X11/locale/lib X11/locale X11
+ @${ECHO_CMD} @dirrm usr/X11R6/lib/${ii} >> ${PLIST}
.endfor
post-install:
- ${RM} -f ${LINUXBASE}/etc/ld.so.cache
- ${FIND} ${LINUXBASE} -name lib -type d | ${SED} 's:${LINUXBASE}::g' \
+ @${RM} -f ${LINUXBASE}/etc/ld.so.cache
+ @${FIND} ${LINUXBASE} -name lib -type d | ${SED} 's:${LINUXBASE}::g' \
> ${LINUXBASE}/etc/ld.so.conf
- chroot ${LINUXBASE} sbin/ldconfig
+ @chroot ${LINUXBASE} sbin/ldconfig
+
+do-install:
+ @rpm -U --ignoreos --root ${PREFIX} --dbpath /var/lib/rpm --nodeps \
+ --replacepkgs ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} || ${TRUE}
-.include "../../x11-toolkits/linux-gtk/Makefile"
+.include <bsd.port.mk>