aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-09-13 21:18:32 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-09-13 21:18:32 +0000
commite0d27de67d0fa648a17243eae4eef72958d5089a (patch)
treeace620b3036402f1a5b9e550b54c44d0817553c9 /x11
parent8d735b94dc189eb4b5f5212e0d6ce3543eb9284a (diff)
downloadports-e0d27de67d0fa648a17243eae4eef72958d5089a.tar.gz
ports-e0d27de67d0fa648a17243eae4eef72958d5089a.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/idesk/Makefile20
-rw-r--r--x11/idesk/distinfo4
-rw-r--r--x11/idesk/files/patch-src_DesktopConfig.cpp16
-rw-r--r--x11/idesk/files/patch-src_Timer.cpp10
-rw-r--r--x11/idesk/files/patch-src_XImlib2Background.cpp16
-rw-r--r--x11/idesk/pkg-descr4
-rw-r--r--x11/idesk/pkg-plist1
7 files changed, 57 insertions, 14 deletions
diff --git a/x11/idesk/Makefile b/x11/idesk/Makefile
index 67317dac5b59..5df2afacb184 100644
--- a/x11/idesk/Makefile
+++ b/x11/idesk/Makefile
@@ -6,28 +6,30 @@
#
PORTNAME= idesk
-PORTVERSION= 0.5.6
-PORTREVISION= 4
+PORTVERSION= 0.7.4
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}/
+EXTRACT_SUFX= .tar.bz2
-MAINTAINER= sascha@root-login.org
-COMMENT= Place launch icons directly on your desktop
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Place launch icons and background directly on your desktop
LIB_DEPENDS= Xft.2:${PORTSDIR}/x11-fonts/libXft
+BUILD_DEPENDS= imlib2-config:${PORTSDIR}/graphics/imlib2
USE_X_PREFIX= yes
+USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= imlib librsvg2
+GNU_CONFIGURE= yes
+USE_AUTOCONF_VER= 259
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-NO_WRKSUBDIR= yes
-
-CXXFLAGS+= `imlib-config --cflags` `freetype-config --cflags`
+CXXFLAGS+= `imlib2-config --cflags` `freetype-config --cflags`
MAKE_ARGS= cc="${CXX}" cflags="${CXXFLAGS}"
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/idesk ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/idesk ${PREFIX}/bin
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
diff --git a/x11/idesk/distinfo b/x11/idesk/distinfo
index f9ded003d81f..063b08440ab6 100644
--- a/x11/idesk/distinfo
+++ b/x11/idesk/distinfo
@@ -1,2 +1,2 @@
-MD5 (idesk-0.5.6.tar.gz) = 0a52c8f1d80cbd238edcfd96d937b146
-SIZE (idesk-0.5.6.tar.gz) = 29056
+MD5 (idesk-0.7.4.tar.bz2) = 7e11b0b5cc181e74616e24600b354698
+SIZE (idesk-0.7.4.tar.bz2) = 156141
diff --git a/x11/idesk/files/patch-src_DesktopConfig.cpp b/x11/idesk/files/patch-src_DesktopConfig.cpp
new file mode 100644
index 000000000000..9667990a003a
--- /dev/null
+++ b/x11/idesk/files/patch-src_DesktopConfig.cpp
@@ -0,0 +1,16 @@
+*** src/DesktopConfig.cpp.orig Mon Sep 5 21:03:05 2005
+--- src/DesktopConfig.cpp Mon Sep 12 22:38:55 2005
+***************
+*** 22,31 ****
+--- 22,32 ----
+ * (See the included file COPYING / BSD )
+ */
+
+ #include "DesktopConfig.h"
+ #include "Util.h"
++ #include "sys/stat.h"
+
+ //the initilizer list just sets the program defaults for non-necessary options
+ DesktopConfig::DesktopConfig(Database db, string ideskrcFile) :
+ AbstractConfig(ideskrcFile)
+ {
diff --git a/x11/idesk/files/patch-src_Timer.cpp b/x11/idesk/files/patch-src_Timer.cpp
new file mode 100644
index 000000000000..c6418f440437
--- /dev/null
+++ b/x11/idesk/files/patch-src_Timer.cpp
@@ -0,0 +1,10 @@
+--- src/Timer.cpp.orig Mon Aug 15 07:26:39 2005
++++ src/Timer.cpp Tue Sep 13 23:14:32 2005
+@@ -26,6 +26,7 @@
+ #include "Database.h"
+ #include <X11/Xlib.h>
+ #include "Timer.h"
++#include <sys/time.h>
+
+ vector<TimerControl*> Timer::items;
+
diff --git a/x11/idesk/files/patch-src_XImlib2Background.cpp b/x11/idesk/files/patch-src_XImlib2Background.cpp
new file mode 100644
index 000000000000..f55c49d10aa4
--- /dev/null
+++ b/x11/idesk/files/patch-src_XImlib2Background.cpp
@@ -0,0 +1,16 @@
+*** src/XImlib2Background.cpp.orig Tue Sep 6 01:03:34 2005
+--- src/XImlib2Background.cpp Mon Sep 12 22:39:11 2005
+***************
+*** 23,32 ****
+--- 23,33 ----
+ */
+
+ #include "Database.h"
+ #include "XImlib2Background.h"
+ #include <X11/Xatom.h>
++ #include "sys/stat.h"
+
+ XImlib2Background::XImlib2Background(AbstractContainer * c, AbstractConfig * con): TimerControl(),
+ container(c), config(con),delay(0), mode(0), save(NULL), show(NULL),
+ srctime(0), images(""), directory(""), OneShot(false)
+ {
diff --git a/x11/idesk/pkg-descr b/x11/idesk/pkg-descr
index f42088839773..742c0b35dcdb 100644
--- a/x11/idesk/pkg-descr
+++ b/x11/idesk/pkg-descr
@@ -1,4 +1,4 @@
-iDesk lets you put launch icons directly on the
+iDesk lets you put launch icons and background directly on the
root window of your X.
-WWW: http://idesk.timmfin.net
+WWW: http://idesk.sourceforge.net
diff --git a/x11/idesk/pkg-plist b/x11/idesk/pkg-plist
index 34c27214f519..e07c8326af63 100644
--- a/x11/idesk/pkg-plist
+++ b/x11/idesk/pkg-plist
@@ -1,4 +1,3 @@
-@comment $FreeBSD$
bin/idesk
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%@dirrm %%DOCSDIR%%