aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-09-24 00:57:06 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-09-24 00:57:06 +0000
commite673a0434bab2cdf41e8f8c582cebe8751df09de (patch)
tree99ba2e156d765410bb630f59d806f6a77a779a37 /x11
parentf734cf2616e9a669c407bcc3b108664f151e43ab (diff)
downloadports-e673a0434bab2cdf41e8f8c582cebe8751df09de.tar.gz
ports-e673a0434bab2cdf41e8f8c582cebe8751df09de.zip
Drop glib < 2.60 workaround after r549741
PR: 247278
Notes
Notes: svn path=/head/; revision=549871
Diffstat (limited to 'x11')
-rw-r--r--x11/phosh/Makefile1
-rw-r--r--x11/phosh/files/patch-glib-2.5648
-rw-r--r--x11/wofi/Makefile1
-rw-r--r--x11/wofi/files/patch-glib-2.5652
4 files changed, 2 insertions, 100 deletions
diff --git a/x11/phosh/Makefile b/x11/phosh/Makefile
index 8c9f7f55302a..b30e4a6ff128 100644
--- a/x11/phosh/Makefile
+++ b/x11/phosh/Makefile
@@ -3,6 +3,7 @@
PORTNAME= phosh
DISTVERSIONPREFIX= v
DISTVERSION= 0.4.4
+PORTREVISION= 1
CATEGORIES= x11
MAINTAINER= jbeich@FreeBSD.org
diff --git a/x11/phosh/files/patch-glib-2.56 b/x11/phosh/files/patch-glib-2.56
deleted file mode 100644
index 314d0f0e2632..000000000000
--- a/x11/phosh/files/patch-glib-2.56
+++ /dev/null
@@ -1,48 +0,0 @@
-Drop after devel/glib20 is updated to 2.58 or later.
-
-meson.build:107:0: ERROR: Invalid version of dependency, need 'gio-2.0' ['>=2.58'] found '2.56.3'.
-
-../tools/dump-app-list.c:25:29: warning: implicit declaration of function 'G_SOURCE_FUNC' is invalid in C99 [-Wimplicit-function-declaration]
- g_timeout_add_seconds (2, G_SOURCE_FUNC (g_main_loop_quit), loop);
- ^
-ld: error: undefined symbol: G_SOURCE_FUNC
->>> referenced by dump-app-list.c
->>> tools/dump-app-list.p/dump-app-list.c.o:(main)
-
---- meson.build.orig 2020-08-03 08:10:28 UTC
-+++ meson.build
-@@ -27,7 +27,7 @@ configure_file(
- configuration: config_h,
- )
-
--glib_ver = 'GLIB_VERSION_2_58'
-+glib_ver = 'GLIB_VERSION_2_56'
-
- add_project_arguments([
- '-DHAVE_CONFIG_H',
-@@ -104,9 +104,9 @@ gnome = import('gnome')
- i18n = import('i18n')
-
- gcr_dep = dependency('gcr-3', version: '>= 3.7.5')
--gio_dep = dependency('gio-2.0', version: '>=2.58')
--gio_unix_dep = dependency('gio-unix-2.0', version: '>=2.58')
--glib_dep = dependency('glib-2.0', version: '>=2.58')
-+gio_dep = dependency('gio-2.0', version: '>=2.56')
-+gio_unix_dep = dependency('gio-unix-2.0', version: '>=2.56')
-+glib_dep = dependency('glib-2.0', version: '>=2.56')
- gnome_desktop_dep = dependency('gnome-desktop-3.0', version: '>=3.26')
- gobject_dep = dependency('gobject-2.0', version: '>=2.50.0')
- gtk_dep = dependency('gtk+-3.0', version: '>=3.22')
---- tools/dump-app-list.c.orig 2020-08-03 08:10:28 UTC
-+++ tools/dump-app-list.c
-@@ -10,6 +10,10 @@
-
- #include <app-list-model.h>
-
-+#if !GLIB_CHECK_VERSION(2, 58, 0)
-+#define G_SOURCE_FUNC(f) ((GSourceFunc) (void (*)(void)) (f))
-+#endif
-+
- int
- main (int argc, char **argv)
- {
diff --git a/x11/wofi/Makefile b/x11/wofi/Makefile
index 3ad6b6e6d4ae..930d8c91962c 100644
--- a/x11/wofi/Makefile
+++ b/x11/wofi/Makefile
@@ -3,6 +3,7 @@
PORTNAME= wofi
DISTVERSIONPREFIX= v
DISTVERSION= 1.2.2
+PORTREVISION= 1
CATEGORIES= x11
#MASTER_SITES= https://hg.sr.ht/~scoopta/${PORTNAME}/archive/${DISTVERSIONFULL}${EXTRACT_SUFX}?dummy=/
MASTER_SITES+= LOCAL/jbeich # https://todo.sr.ht/~sircmpwn/hg.sr.ht/33
diff --git a/x11/wofi/files/patch-glib-2.56 b/x11/wofi/files/patch-glib-2.56
deleted file mode 100644
index 0e010bb48e23..000000000000
--- a/x11/wofi/files/patch-glib-2.56
+++ /dev/null
@@ -1,52 +0,0 @@
-Partially revert https://hg.sr.ht/~scoopta/wofi/rev/6343e02e2478 until
-devel/glib20 is updated to 2.60 or later.
-
-ld: error: undefined symbol: g_app_info_launch_uris_async
->>> referenced by drun.c
->>> wofi@exe/modes_drun.c.o:(wofi_drun_exec)
-
-ld: error: undefined symbol: g_app_info_launch_uris_finish
->>> referenced by drun.c
->>> wofi@exe/modes_drun.c.o:(launch_done)
-
---- modes/drun.c.orig 2020-07-28 23:18:44 UTC
-+++ modes/drun.c
-@@ -19,6 +19,7 @@
- #include <libgen.h>
-
- #include <sys/stat.h>
-+#include <errno.h>
-
- #include <map.h>
- #include <utils.h>
-@@ -373,6 +374,7 @@ struct widget* wofi_drun_get_widget(void) {
- return NULL;
- }
-
-+#if GLIB_CHECK_VERSION(2, 60, 0)
- static void launch_done(GObject* obj, GAsyncResult* result, gpointer data) {
- GError* err = NULL;
- if(g_app_info_launch_uris_finish(G_APP_INFO(obj), result, &err)) {
-@@ -387,6 +389,7 @@ static void launch_done(GObject* obj, GAsyncResult* re
- }
- exit(1);
- }
-+#endif
-
- static void set_dri_prime(GDesktopAppInfo* info) {
- bool dri_prime = g_desktop_app_info_get_boolean(info, "PrefersNonDefaultGPU");
-@@ -404,7 +407,14 @@ void wofi_drun_exec(const gchar* cmd) {
- exit(0);
- } else {
- set_dri_prime(info);
-+#if GLIB_CHECK_VERSION(2, 60, 0)
- g_app_info_launch_uris_async(G_APP_INFO(info), NULL, NULL, NULL, launch_done, (gchar*) cmd);
-+#else
-+ const char* exec = g_app_info_get_executable(G_APP_INFO(info));
-+ execlp(exec, exec, NULL);
-+ fprintf(stderr, "%s cannot be executed\n", exec);
-+ exit(errno);
-+#endif
- }
- } else if(strrchr(cmd, ' ') != NULL) {
- char* space = strrchr(cmd, ' ');