aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-12-21 00:11:23 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-12-21 00:11:23 +0000
commit2a41b89b3ab17e4b65f01baf9ce2f1d1c247b9cf (patch)
treeb43a9b6a958308213f7e1efd92118c01915463d8 /x11
parentc5eb15edbf984773e8b4389dac187ee010a58565 (diff)
downloadports-2a41b89b3ab17e4b65f01baf9ce2f1d1c247b9cf.tar.gz
ports-2a41b89b3ab17e4b65f01baf9ce2f1d1c247b9cf.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/slim/Makefile12
-rw-r--r--x11/slim/files/patch-Ck.cpp11
-rw-r--r--x11/slim/pkg-descr1
3 files changed, 19 insertions, 5 deletions
diff --git a/x11/slim/Makefile b/x11/slim/Makefile
index b1b7a7ff93e3..9cf4e0d6ef57 100644
--- a/x11/slim/Makefile
+++ b/x11/slim/Makefile
@@ -3,7 +3,7 @@
PORTNAME= slim
PORTVERSION= 1.3.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11
MASTER_SITES= http://slim.berlios.de/releases/
@@ -12,14 +12,18 @@ COMMENT= Graphical login manager for X11, derived from Login.app
LICENSE= GPLv2
-LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
- ck-connector:${PORTSDIR}/sysutils/consolekit \
+LIB_DEPENDS= dbus-1:${PORTSDIR}/devel/dbus \
+ pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
+ jpeg:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png \
freetype:${PORTSDIR}/print/freetype2 \
+ ck-connector:${PORTSDIR}/sysutils/consolekit \
+ expat:${PORTSDIR}/textproc/expat2 \
+ xcb:${PORTSDIR}/x11/libxcb \
fontconfig:${PORTSDIR}/x11-fonts/fontconfig
USE_CMAKE= yes
-USE_XORG= x11 xft xmu xorg-server xrender
+USE_XORG= ice sm x11 xau xdmcp xext xft xmu xorg-server xrender xt
USE_PKGCONFIG= build
USE_RC_SUBR= slim
SUB_FILES= pkg-message
diff --git a/x11/slim/files/patch-Ck.cpp b/x11/slim/files/patch-Ck.cpp
new file mode 100644
index 000000000000..6eaeca0ab537
--- /dev/null
+++ b/x11/slim/files/patch-Ck.cpp
@@ -0,0 +1,11 @@
+--- Ck.cpp.orig 2012-02-22 03:59:52.000000000 +0400
++++ Ck.cpp 2012-07-19 00:03:34.000000000 +0400
+@@ -91,7 +91,7 @@
+
+ vt = *((long *)return_value);
+
+- std::snprintf(device, 32, "/dev/tty%ld", vt);
++ std::snprintf(device, 32, "/dev/ttyv%ld", vt - 1);
+
+ if(return_value)
+ XFree(return_value);
diff --git a/x11/slim/pkg-descr b/x11/slim/pkg-descr
index 671173c33823..ca5b22f0ad7b 100644
--- a/x11/slim/pkg-descr
+++ b/x11/slim/pkg-descr
@@ -5,5 +5,4 @@ It aims to be light and simple, although completely configurable through
themes and an option file; is suitable for machines on which remote login
functionalities are not needed.
-Author: Simone Rota and Johannes Winkelmann
WWW: http://slim.berlios.de/