aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2004-12-31 18:24:10 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2004-12-31 18:24:10 +0000
commit64cf27c85d89298041b8c8dc2fd090181e6d10d8 (patch)
tree11668b893f94453b0262a155d53e6eac8dd4a6f5 /x11
parent440d8863c8d496b982754e2a71867892213a902b (diff)
downloadports-64cf27c85d89298041b8c8dc2fd090181e6d10d8.tar.gz
ports-64cf27c85d89298041b8c8dc2fd090181e6d10d8.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/linux-XFree86-libs/Makefile18
-rw-r--r--x11/linux-XFree86-libs/files/pkg-install.in12
-rw-r--r--x11/linux-gnomelibs/Makefile4
-rw-r--r--x11/nvidia-driver/Makefile3
4 files changed, 26 insertions, 11 deletions
diff --git a/x11/linux-XFree86-libs/Makefile b/x11/linux-XFree86-libs/Makefile
index 15140ae435e5..6fecf8acd1ec 100644
--- a/x11/linux-XFree86-libs/Makefile
+++ b/x11/linux-XFree86-libs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= XFree86-libs
PORTVERSION= 4.3.99.902
+PORTREVISION= 1
CATEGORIES= x11 linux
MASTER_SITES= ${MASTER_SITE_SUSE} \
ftp://ftp.in2p3.fr/pub/linux/suse/update/9.1/rpm/i586/ \
@@ -18,20 +19,22 @@ EXTRACT_SUFX=
DIST_SUBDIR= rpm/i386/suse
EXTRACT_ONLY=
-MAINTAINER= trevor@FreeBSD.org
-COMMENT= XFree86 libraries, Linux/i386 binary
+MAINTAINER= freebsd-emulation@FreeBSD.org
+COMMENT= XFree86 libraries, Linux binary
BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
-RUN_DEPENDS=${LINUXBASE}/lib/libc-2.3.2.so:${PORTSDIR}/emulators/linux_base-8
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig
CONFLICTS= linux_base-6* linux_base-7* linux_base-deb* linux_base-gentoo*
+USE_LINUX= yes
+USE_LINUX_PREFIX=yes
MD5_FILE= ${MASTERDIR}/distinfo.i386
NO_BUILD= yes
NO_FILTER_SHLIBS= yes
ONLY_FOR_ARCHS= amd64 i386
+PKGINSTALL= ${WRKDIR}/pkg-install
PLIST= ${WRKDIR}/plist
PLIST_DIRS= usr/X11R6/lib/X11
-PREFIX= ${LINUXBASE}
pre-install:
@${RM} -f ${PLIST}
@@ -46,10 +49,9 @@ pre-install:
${FIND} -d usr/X11R6/lib/X11/locale -type d | \
${SED} -e 's:^:@dirrm :' >> ${PLIST}
post-install:
- @${RM} -f ${LINUXBASE}/etc/ld.so.cache
- @${FIND} ${LINUXBASE} -name lib -type d | ${SED} 's:${LINUXBASE}::g' \
- > ${LINUXBASE}/etc/ld.so.conf
- @chroot ${LINUXBASE} sbin/ldconfig
+ @${SED} -e 's|%%LINUXBASE%%|${LINUXBASE}|g ; s|%%PREFIX%%|${PREFIX}|g' \
+ < ${FILESDIR}/pkg-install.in > ${PKGINSTALL}
+ @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
do-install:
@rpm -U --ignorearch --ignoreos --root ${PREFIX} --dbpath /var/lib/rpm \
diff --git a/x11/linux-XFree86-libs/files/pkg-install.in b/x11/linux-XFree86-libs/files/pkg-install.in
new file mode 100644
index 000000000000..1be02068a889
--- /dev/null
+++ b/x11/linux-XFree86-libs/files/pkg-install.in
@@ -0,0 +1,12 @@
+#!/bin/sh
+
+PATH=/bin:/sbin:/usr/bin:/usr/sbin
+export PATH
+
+if [ "$2" = "POST-INSTALL" ]; then
+ rm -f %%LINUXBASE%%/etc/ld.so.cache
+ ( find %%LINUXBASE%% -name lib -type d | sed -e 's:%%LINUXBASE%%::g'; \
+ find %%PREFIX%% -name lib -type d | sed -e 's:%%PREFIX%%::g' ) \
+ | sort -u >%%LINUXBASE%%/etc/ld.so.conf
+ chroot %%LINUXBASE%% /sbin/ldconfig
+fi
diff --git a/x11/linux-gnomelibs/Makefile b/x11/linux-gnomelibs/Makefile
index 5c9d0fd95974..2abe16032092 100644
--- a/x11/linux-gnomelibs/Makefile
+++ b/x11/linux-gnomelibs/Makefile
@@ -7,10 +7,10 @@
PORTNAME= gnomelibs
PORTVERSION= 1.2.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 linux
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= RPM of gnome-libs
RPM_SET= gnome-libs-${PORTVERSION}-11.${MACHINE_ARCH}.rpm
diff --git a/x11/nvidia-driver/Makefile b/x11/nvidia-driver/Makefile
index bb1cd4c9ad6f..b607238c7c23 100644
--- a/x11/nvidia-driver/Makefile
+++ b/x11/nvidia-driver/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nvidia-driver
PORTVERSION= 1.0.${NVVERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11
MASTER_SITES= http://download.nvidia.com/freebsd/1.0-${NVVERSION}/ \
ftp://download.nvidia.com/freebsd/1.0-${NVVERSION}/ \
@@ -42,6 +42,7 @@ PLIST_SUB= XSERVVERSION=${XSERVVERSION} XLIBVERSION=${XLIBVERSION} \
.if !defined(WITHOUT_LINUX)
USE_LINUX= yes
+RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
PLIST_SUB+= LINUX=""
.else
PLIST_SUB+= LINUX="@comment "