aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2021-01-01 18:01:31 +0000
committerRene Ladan <rene@FreeBSD.org>2021-01-01 18:01:31 +0000
commitaffdc5892cb07e66cdcefec3c144f7be932623c2 (patch)
treef7c0d426cfd5a29f740621eb131faa1f3b5aa937 /x11
parent0dfea3782d1e64eb8760e11711232cc6faafe9ee (diff)
downloadports-affdc5892cb07e66cdcefec3c144f7be932623c2.tar.gz
ports-affdc5892cb07e66cdcefec3c144f7be932623c2.zip
Python Xapp library
WWW: https://github.com/linuxmint/python3-xapp This port is needed to upgrade the Cinnamon ports to version 4.8.4 which use Python 3 instead of Python 2. PR: 252302 Submitted by: Charlie Li
Notes
Notes: svn path=/head/; revision=559861
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/py-python-xapp/Makefile29
-rw-r--r--x11/py-python-xapp/distinfo3
-rw-r--r--x11/py-python-xapp/pkg-descr3
4 files changed, 36 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index ed9e90fe0a66..67502e0c0b91 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -275,6 +275,7 @@
SUBDIR += py-caffeine-ng
SUBDIR += py-i3ipc
SUBDIR += py-pyscreenshot
+ SUBDIR += py-python-xapp
SUBDIR += py-pyvirtualdisplay
SUBDIR += py-qt5-opengl
SUBDIR += py-xcffib
diff --git a/x11/py-python-xapp/Makefile b/x11/py-python-xapp/Makefile
new file mode 100644
index 000000000000..75e738d7a223
--- /dev/null
+++ b/x11/py-python-xapp/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= python-xapp
+DISTVERSION= 2.0.2
+CATEGORIES= x11 gnome
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DIST_SUBDIR= gnome
+
+MAINTAINER= gnome@freebsd.org
+COMMENT= Python Xapp library
+
+LICENSE= LGPL20
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psutil>0:sysutils/py-psutil@${PY_FLAVOR}
+
+USES= gnome python:3.5+ shebangfix
+
+USE_GNOME= pygobject3
+USE_PYTHON= autoplist distutils
+SHEBANG_GLOB= *.py
+
+USE_GITHUB= yes
+GH_ACCOUNT= linuxmint
+GH_PROJECT= python3-xapp
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/x11/py-python-xapp/distinfo b/x11/py-python-xapp/distinfo
new file mode 100644
index 000000000000..1050cdd8e7b6
--- /dev/null
+++ b/x11/py-python-xapp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1609405572
+SHA256 (gnome/linuxmint-python3-xapp-2.0.2_GH0.tar.gz) = 4f61dde32c7aec5ab2c819e968a2bf0136c9eddcc1356461d516aff40930159f
+SIZE (gnome/linuxmint-python3-xapp-2.0.2_GH0.tar.gz) = 19946
diff --git a/x11/py-python-xapp/pkg-descr b/x11/py-python-xapp/pkg-descr
new file mode 100644
index 000000000000..dddbe264c24b
--- /dev/null
+++ b/x11/py-python-xapp/pkg-descr
@@ -0,0 +1,3 @@
+Python Xapp library
+
+WWW: https://github.com/linuxmint/python3-xapp