aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-01-03 23:47:57 +0000
committerWill Andrews <will@FreeBSD.org>2001-01-03 23:47:57 +0000
commit9ba048d6a02c19676576ec50a5656ae76f695ea3 (patch)
treefc352a978e3ec9e8eb787af4dff92191a3f06281 /x11
parent8c3cb8aa8ae5c9085fa3bc8d97ca6fc64789d0e3 (diff)
downloadports-9ba048d6a02c19676576ec50a5656ae76f695ea3.tar.gz
ports-9ba048d6a02c19676576ec50a5656ae76f695ea3.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/p5-X11-Protocol/Makefile27
-rw-r--r--x11/p5-X11-Protocol/distinfo1
-rw-r--r--x11/p5-X11-Protocol/pkg-comment1
-rw-r--r--x11/p5-X11-Protocol/pkg-descr9
-rw-r--r--x11/p5-X11-Protocol/pkg-plist17
6 files changed, 56 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 9af360ffd6c6..ba0251db8ffc 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -55,6 +55,7 @@
SUBDIR += lupe
SUBDIR += offix-clipboard
SUBDIR += offix-execute
+ SUBDIR += p5-X11-Protocol
SUBDIR += portoseguro
SUBDIR += powershell
SUBDIR += props
diff --git a/x11/p5-X11-Protocol/Makefile b/x11/p5-X11-Protocol/Makefile
new file mode 100644
index 000000000000..58f6bc4554f3
--- /dev/null
+++ b/x11/p5-X11-Protocol/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: X11-Protocol
+# Date created: Mon Jan 1 21:49:44 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= X11-Protocol
+PORTVERSION= 0.04
+CATEGORIES= x11 perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= X11
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= X11::Auth.3 X11::Keysyms.3 X11::Protocol::Connection::Socket.3 \
+ X11::Protocol::Connection::INETSocket.3 X11::Protocol::Connection::FileHandle.3 \
+ X11::Protocol::Connection::UNIXSocket.3 X11::Protocol::Ext::BIG_REQUESTS.3 \
+ X11::Protocol::Connection::INETFH.3 X11::Protocol::Connection.3 \
+ X11::Protocol::Ext::SHAPE.3 X11::Protocol::Connection::UNIXFH.3 X11::Protocol.3
+
+.include <bsd.port.mk>
diff --git a/x11/p5-X11-Protocol/distinfo b/x11/p5-X11-Protocol/distinfo
new file mode 100644
index 000000000000..415d44ba6188
--- /dev/null
+++ b/x11/p5-X11-Protocol/distinfo
@@ -0,0 +1 @@
+MD5 (X11-Protocol-0.04.tar.gz) = 90fb0a9aa8c6299c4ae0e334d777641a
diff --git a/x11/p5-X11-Protocol/pkg-comment b/x11/p5-X11-Protocol/pkg-comment
new file mode 100644
index 000000000000..f3bc2ad38c6b
--- /dev/null
+++ b/x11/p5-X11-Protocol/pkg-comment
@@ -0,0 +1 @@
+Perl module that provides an interface roughly equivalent to Xlib
diff --git a/x11/p5-X11-Protocol/pkg-descr b/x11/p5-X11-Protocol/pkg-descr
new file mode 100644
index 000000000000..b01dbeaae5d7
--- /dev/null
+++ b/x11/p5-X11-Protocol/pkg-descr
@@ -0,0 +1,9 @@
+X11::Protocol is a perl module that provides an interface that is
+roughly equivalent to Xlib. Its low-level approach is intentional
+as the author is working on a higher-level interface that will be
+more object-oriented and easier to use, so as to allow this low
+level access to eventually be replaced by an XS interface to Xlib.
+
+Author: Stephen McCamant
+
+--will
diff --git a/x11/p5-X11-Protocol/pkg-plist b/x11/p5-X11-Protocol/pkg-plist
new file mode 100644
index 000000000000..eb7fcb76b906
--- /dev/null
+++ b/x11/p5-X11-Protocol/pkg-plist
@@ -0,0 +1,17 @@
+lib/perl5/site_perl/%%PERL_VER%%/X11/Auth.pm
+lib/perl5/site_perl/%%PERL_VER%%/X11/Keysyms.pm
+lib/perl5/site_perl/%%PERL_VER%%/X11/Protocol.pm
+lib/perl5/site_perl/%%PERL_VER%%/X11/Protocol/Connection.pm
+lib/perl5/site_perl/%%PERL_VER%%/X11/Protocol/Connection/FileHandle.pm
+lib/perl5/site_perl/%%PERL_VER%%/X11/Protocol/Connection/INETFH.pm
+lib/perl5/site_perl/%%PERL_VER%%/X11/Protocol/Connection/INETSocket.pm
+lib/perl5/site_perl/%%PERL_VER%%/X11/Protocol/Connection/Socket.pm
+lib/perl5/site_perl/%%PERL_VER%%/X11/Protocol/Connection/UNIXFH.pm
+lib/perl5/site_perl/%%PERL_VER%%/X11/Protocol/Connection/UNIXSocket.pm
+lib/perl5/site_perl/%%PERL_VER%%/X11/Protocol/Ext/BIG_REQUESTS.pm
+lib/perl5/site_perl/%%PERL_VER%%/X11/Protocol/Ext/SHAPE.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/X11/Protocol/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/X11/Protocol
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/X11/Protocol/Ext
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/X11/Protocol/Connection
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/X11/Protocol