aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2003-12-21 23:38:30 +0000
committerEric Anholt <anholt@FreeBSD.org>2003-12-21 23:38:30 +0000
commitefa1a6e57eacd2b41a320a70275d13467eaf3c88 (patch)
treed2b3c6e1c64fa091b54a30bcb02d8f35d93133c2 /x11
parentf2794becae6ba0679226183ab1b84ea4cd60ec9b (diff)
downloadports-efa1a6e57eacd2b41a320a70275d13467eaf3c88.tar.gz
ports-efa1a6e57eacd2b41a320a70275d13467eaf3c88.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/libXfont/Makefile29
-rw-r--r--x11/libXfont/distinfo1
-rw-r--r--x11/libXfont/files/patch-Makefile.in11
-rw-r--r--x11/libXfont/pkg-descr6
-rw-r--r--x11/libXfont/pkg-plist13
6 files changed, 61 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 577946f81d17..2ca870d3fcac 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -76,6 +76,7 @@
SUBDIR += libSM
SUBDIR += libX11
SUBDIR += libXau
+ SUBDIR += libXfont
SUBDIR += libXtrans
SUBDIR += libcapplet
SUBDIR += libdnd
diff --git a/x11/libXfont/Makefile b/x11/libXfont/Makefile
new file mode 100644
index 000000000000..c42bfdf700a5
--- /dev/null
+++ b/x11/libXfont/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: libXfont
+# Date Created: 29 Oct, 2003
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libXfont
+PORTVERSION= 1.4.1.p1
+CATEGORIES= x11
+MASTER_SITES= http://pdx.freedesktop.org/~anholt/dist/
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X font libary
+
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
+ ${X11BASE}/libdata/pkgconfig/xproto.pc:${PORTSDIR}/x11/xproto
+LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ARGS= --enable-freetype
+WRKSRC= ${WRKDIR}/${PORTNAME}-1.4.1
+
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/x11/libXfont/distinfo b/x11/libXfont/distinfo
new file mode 100644
index 000000000000..2656dc9a9e81
--- /dev/null
+++ b/x11/libXfont/distinfo
@@ -0,0 +1 @@
+MD5 (libXfont-1.4.1.p1.tar.bz2) = f67736c01ddcc33a230f06c0d8bbd9c6
diff --git a/x11/libXfont/files/patch-Makefile.in b/x11/libXfont/files/patch-Makefile.in
new file mode 100644
index 000000000000..1402e0ce1ee5
--- /dev/null
+++ b/x11/libXfont/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Mon Nov 10 00:15:00 2003
++++ Makefile.in Mon Nov 10 00:15:08 2003
+@@ -221,7 +221,7 @@
+ include/X11/fonts/fsmasks.h
+
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = xfont.pc
+
+ LOCAL_INCLUDES = \
diff --git a/x11/libXfont/pkg-descr b/x11/libXfont/pkg-descr
new file mode 100644
index 000000000000..9f3309dcd11a
--- /dev/null
+++ b/x11/libXfont/pkg-descr
@@ -0,0 +1,6 @@
+This package contains the X font libary
+
+WWW: http://www.freedesktop.org/Software/xlibs
+
+- Eric Anholt
+anholt@FreeBSD.org
diff --git a/x11/libXfont/pkg-plist b/x11/libXfont/pkg-plist
new file mode 100644
index 000000000000..00d31e4afd31
--- /dev/null
+++ b/x11/libXfont/pkg-plist
@@ -0,0 +1,13 @@
+include/X11/fonts/FS.h
+include/X11/fonts/FSproto.h
+include/X11/fonts/font.h
+include/X11/fonts/fontconf.h
+include/X11/fonts/fontenc.h
+include/X11/fonts/fontproto.h
+include/X11/fonts/fontstruct.h
+include/X11/fonts/fsmasks.h
+lib/libXfont.a
+lib/libXfont.la
+lib/libXfont.so
+lib/libXfont.so.1
+libdata/pkgconfig/xfont.pc