aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2011-07-04 16:35:07 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2011-07-04 16:35:07 +0000
commit3564f82faad33c20390bc52a0b0f9ff644ae2c95 (patch)
tree82c7b6a7e061e515497f9cc2840e0ae55d6dad0a /x11
parentda32c3c6d782a09dbb88e21bb8e04cb0d4db69ce (diff)
downloadports-3564f82faad33c20390bc52a0b0f9ff644ae2c95.tar.gz
ports-3564f82faad33c20390bc52a0b0f9ff644ae2c95.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/lsw/Makefile35
-rw-r--r--x11/lsw/distinfo2
-rw-r--r--x11/lsw/pkg-descr6
4 files changed, 44 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 487a6dc34998..3085aa9461f3 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -186,6 +186,7 @@
SUBDIR += linux-f10-xorg-libs
SUBDIR += linux-xorg-libs
SUBDIR += listres
+ SUBDIR += lsw
SUBDIR += luit
SUBDIR += lupe
SUBDIR += lxde-meta
diff --git a/x11/lsw/Makefile b/x11/lsw/Makefile
new file mode 100644
index 000000000000..b2b42e9e6ca8
--- /dev/null
+++ b/x11/lsw/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: lsw
+# Date created: 2011-07-03
+# Whom: Dennis Herrmann <dhn@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lsw
+PORTVERSION= 0.2
+CATEGORIES= x11
+MASTER_SITES= http://dl.suckless.org/tools/
+
+MAINTAINER= dhn@FreeBSD.org
+COMMENT= Lists the titles of all running X windows to stdout, similar to ls(1)
+
+MAKE_ARGS= PREFIX="${PREFIX}" X11LIB="${LOCALBASE}/lib" \
+ X11INC="${LOCALBASE}/include" CC="${CC}"
+PLIST_FILES= bin/lsw
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+MAN1= lsw.1
+MAKE_JOBS_SAFE= yes
+USE_XORG= x11 xt xproto xext
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-I/usr/include||;s|-L/usr/lib||;s|= -Os|+=|'\
+ -e 's|-DHAVE_SHADOW_H||' ${WRKSRC}/config.mk
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/x11/lsw/distinfo b/x11/lsw/distinfo
new file mode 100644
index 000000000000..1fa4091388a5
--- /dev/null
+++ b/x11/lsw/distinfo
@@ -0,0 +1,2 @@
+SHA256 (lsw-0.2.tar.gz) = 307dcb49d5fd814ca58e3c7cae06008a0c68343b69847e59ddf0e34a555d5f60
+SIZE (lsw-0.2.tar.gz) = 2946
diff --git a/x11/lsw/pkg-descr b/x11/lsw/pkg-descr
new file mode 100644
index 000000000000..c48e4217e17c
--- /dev/null
+++ b/x11/lsw/pkg-descr
@@ -0,0 +1,6 @@
+LSW
+
+Lists the titles of all running X windows to stdout, similar to ls(1).
+Might be useful for script integration.
+
+WWW: http://tools.suckless.org/lsw