aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--multimedia/vdr-plugin-infosatepg/Makefile2
-rw-r--r--multimedia/vdr-plugin-infosatepg/files/patch-infosatepg.cpp9
2 files changed, 10 insertions, 1 deletions
diff --git a/multimedia/vdr-plugin-infosatepg/Makefile b/multimedia/vdr-plugin-infosatepg/Makefile
index aff2084d3b44..39e232c11f49 100644
--- a/multimedia/vdr-plugin-infosatepg/Makefile
+++ b/multimedia/vdr-plugin-infosatepg/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vdr-plugin-infosatepg
PORTVERSION= 0.0.11
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= multimedia
MASTER_SITES= http://projects.vdr-developer.org/attachments/download/342/
DISTNAME= ${PORTNAME:S/-plugin-/-/}-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
diff --git a/multimedia/vdr-plugin-infosatepg/files/patch-infosatepg.cpp b/multimedia/vdr-plugin-infosatepg/files/patch-infosatepg.cpp
index 620910c6656e..8e33a6a351d0 100644
--- a/multimedia/vdr-plugin-infosatepg/files/patch-infosatepg.cpp
+++ b/multimedia/vdr-plugin-infosatepg/files/patch-infosatepg.cpp
@@ -1,5 +1,14 @@
--- a/infosatepg.cpp
+++ b/infosatepg.cpp
+@@ -193,7 +193,7 @@ void cPluginInfosatepg::MainThreadHook(v
+ if (EITScanner.UsesDevice(dev)) continue; // EITScanner is updating EPG -> skip
+ if (dev->Receiving()) continue; // device is recording -> skip
+ if (dev->IsPrimaryDevice()) continue; // device is primary -> skip
+- if (cDevice::ActualDevice()->CardIndex()==i) continue; // device is live viewing -> skip
++ if (cDevice::ActualDevice()->CardIndex()==dev->CardIndex()) continue; // device is live viewing -> skip
+ if (dev->IsTunedToTransponder(chan))
+ {
+ // we already have a device which is tuned (maybe switched manually?)
@@ -403,7 +403,7 @@ cString cPluginInfosatepg::SVDRPCommand(
cString head2;
head2="\n" \