aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/Makefile1
-rw-r--r--games/lugaru/Makefile49
-rw-r--r--games/lugaru/distinfo2
-rw-r--r--games/lugaru/files/lugaru.in7
-rw-r--r--games/lugaru/files/patch-Source-openal_wrapper.cpp11
-rw-r--r--games/lugaru/pkg-descr13
-rw-r--r--games/lugaru/pkg-plist456
7 files changed, 539 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index ff187f3324d8..8ba429b48a47 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -557,6 +557,7 @@
SUBDIR += lskat
SUBDIR += ltris
SUBDIR += lucidlife
+ SUBDIR += lugaru
SUBDIR += luola
SUBDIR += lwjgl
SUBDIR += macopix
diff --git a/games/lugaru/Makefile b/games/lugaru/Makefile
new file mode 100644
index 000000000000..fc01b8612a65
--- /dev/null
+++ b/games/lugaru/Makefile
@@ -0,0 +1,49 @@
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= lugaru
+PORTVERSION= 269
+CATEGORIES= games
+MASTER_SITES= GOOGLE_CODE
+DISTNAME= ${PORTNAME}-rev${DISTVERSION}-src
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= 3D arcade with unique fighting system and anthropomorphic characters
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis \
+ libogg.so:${PORTSDIR}/audio/libogg
+
+USE_BZIP2= yes
+USES= cmake pkgconfig
+USE_GL= glu
+USE_OPENAL= soft
+USE_SDL= sdl
+USE_XORG= sm
+USE_GCC= yes
+
+PORTDOCS= README
+
+OPTIONS_DEFINE= DOCS
+
+SUB_FILES= ${PORTNAME}
+
+DESKTOP_ENTRIES="Lugaru" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ActionGame;" false
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local/lugaru|${DATADIR}|' \
+ ${WRKSRC}/CMakeLists.txt
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ ${LN} -sf ${DATADIR}/Data/Textures/Lugaru.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/games/lugaru/distinfo b/games/lugaru/distinfo
new file mode 100644
index 000000000000..7caab37630ae
--- /dev/null
+++ b/games/lugaru/distinfo
@@ -0,0 +1,2 @@
+SHA256 (lugaru-rev269-src.tar.bz2) = 3c38ff547b0567b40bb94b16907ffc2f65623c1dec0538e41152515d4ff0cbdc
+SIZE (lugaru-rev269-src.tar.bz2) = 39250302
diff --git a/games/lugaru/files/lugaru.in b/games/lugaru/files/lugaru.in
new file mode 100644
index 000000000000..8c3983fb276a
--- /dev/null
+++ b/games/lugaru/files/lugaru.in
@@ -0,0 +1,7 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+cd "%%DATADIR%%"
+./lugaru "${@}"
diff --git a/games/lugaru/files/patch-Source-openal_wrapper.cpp b/games/lugaru/files/patch-Source-openal_wrapper.cpp
new file mode 100644
index 000000000000..dd25351e0249
--- /dev/null
+++ b/games/lugaru/files/patch-Source-openal_wrapper.cpp
@@ -0,0 +1,11 @@
+--- Source/openal_wrapper.cpp.orig 2010-05-16 06:42:54.000000000 +0200
++++ Source/openal_wrapper.cpp 2013-09-27 23:04:45.000000000 +0200
+@@ -374,7 +374,7 @@
+ char *fname = (char *) alloca(strlen(_fname) + 16);
+ strcpy(fname, _fname);
+ char *ptr = strchr(fname, '.');
+- if (ptr) *ptr = NULL;
++ if (ptr) ptr = NULL;
+ strcat(fname, ".ogg");
+
+ // just in case...
diff --git a/games/lugaru/pkg-descr b/games/lugaru/pkg-descr
new file mode 100644
index 000000000000..c471e22aa6ef
--- /dev/null
+++ b/games/lugaru/pkg-descr
@@ -0,0 +1,13 @@
+3D arcade with unique fighting system and anthropomorphic characters.
+
+Lugaru's primary feature is its unique combat system. Instead of relying
+on confusing button combinations to perform moves, Lugaru's moves are all
+logical and context sensitive. For example, if an opponent aims a roundhouse
+kick at Turner's head, you can crouch and then stand up under the attack to
+grab your assailant's leg and kick him away. If you try and punch an opponent
+and he tries to throw you over his shoulder, you can crouch to roll painlessly
+out of the throw. This new combat system makes fights look and feel much more
+intense and believable than in any other game. You can see it in action with
+the gameplay movies above.
+
+WWW: https://code.google.com/p/lugaru/
diff --git a/games/lugaru/pkg-plist b/games/lugaru/pkg-plist
new file mode 100644
index 000000000000..5d4b2aff9e50
--- /dev/null
+++ b/games/lugaru/pkg-plist
@@ -0,0 +1,456 @@
+bin/lugaru
+%%DATADIR%%/Data/Animations/Backflip
+%%DATADIR%%/Data/Animations/Backhandspring
+%%DATADIR%%/Data/Animations/Blockhighleft
+%%DATADIR%%/Data/Animations/Blockhighleftstrike
+%%DATADIR%%/Data/Animations/Climb
+%%DATADIR%%/Data/Animations/Crouch
+%%DATADIR%%/Data/Animations/Crouchdrawright
+%%DATADIR%%/Data/Animations/Crouchremoveknife
+%%DATADIR%%/Data/Animations/Crouchstab
+%%DATADIR%%/Data/Animations/Dead1
+%%DATADIR%%/Data/Animations/Dead2
+%%DATADIR%%/Data/Animations/Dead3
+%%DATADIR%%/Data/Animations/Dead4
+%%DATADIR%%/Data/Animations/Dodgeback
+%%DATADIR%%/Data/Animations/Drawleft
+%%DATADIR%%/Data/Animations/Drawright
+%%DATADIR%%/Data/Animations/Dropkick
+%%DATADIR%%/Data/Animations/Dropkickold
+%%DATADIR%%/Data/Animations/Dying
+%%DATADIR%%/Data/Animations/Fightidle
+%%DATADIR%%/Data/Animations/Fightsidestep
+%%DATADIR%%/Data/Animations/Flip
+%%DATADIR%%/Data/Animations/Getupfromback
+%%DATADIR%%/Data/Animations/Getupfromfront
+%%DATADIR%%/Data/Animations/Hangon
+%%DATADIR%%/Data/Animations/Hurtidle
+%%DATADIR%%/Data/Animations/Idle
+%%DATADIR%%/Data/Animations/JumpDown
+%%DATADIR%%/Data/Animations/JumpUp
+%%DATADIR%%/Data/Animations/Jumpcatch
+%%DATADIR%%/Data/Animations/Jumpcaught
+%%DATADIR%%/Data/Animations/Kill
+%%DATADIR%%/Data/Animations/Knifefightidle
+%%DATADIR%%/Data/Animations/Knifeslashcatch
+%%DATADIR%%/Data/Animations/Knifeslashcaught
+%%DATADIR%%/Data/Animations/Knifesneakattack
+%%DATADIR%%/Data/Animations/Knifesneakattacked
+%%DATADIR%%/Data/Animations/Knifethrow
+%%DATADIR%%/Data/Animations/Landhard
+%%DATADIR%%/Data/Animations/Landing
+%%DATADIR%%/Data/Animations/Leftflip
+%%DATADIR%%/Data/Animations/Lowkick
+%%DATADIR%%/Data/Animations/Rabbitkick
+%%DATADIR%%/Data/Animations/Rabbitkickcatch
+%%DATADIR%%/Data/Animations/Rabbitkickcaught
+%%DATADIR%%/Data/Animations/Rabbitrunning
+%%DATADIR%%/Data/Animations/Rabbittackle
+%%DATADIR%%/Data/Animations/Rabbittackledback
+%%DATADIR%%/Data/Animations/Rabbittackledfront
+%%DATADIR%%/Data/Animations/Rabbittackling
+%%DATADIR%%/Data/Animations/Removeknife
+%%DATADIR%%/Data/Animations/Rightflip
+%%DATADIR%%/Data/Animations/Roll
+%%DATADIR%%/Data/Animations/Run
+%%DATADIR%%/Data/Animations/Sit
+%%DATADIR%%/Data/Animations/Slashfollow
+%%DATADIR%%/Data/Animations/Slashfollowed
+%%DATADIR%%/Data/Animations/Slashstart
+%%DATADIR%%/Data/Animations/Sleep
+%%DATADIR%%/Data/Animations/Sneak
+%%DATADIR%%/Data/Animations/Sneakattack
+%%DATADIR%%/Data/Animations/Sneakattacked
+%%DATADIR%%/Data/Animations/Spinkick
+%%DATADIR%%/Data/Animations/Spinkickcatch
+%%DATADIR%%/Data/Animations/Spinkickcaught
+%%DATADIR%%/Data/Animations/Spinwhack
+%%DATADIR%%/Data/Animations/Spinwhackcatch
+%%DATADIR%%/Data/Animations/Spinwhackcaught
+%%DATADIR%%/Data/Animations/StaffGroundSmash
+%%DATADIR%%/Data/Animations/StaffHit
+%%DATADIR%%/Data/Animations/Staffhitcatch
+%%DATADIR%%/Data/Animations/Staffhitcaught
+%%DATADIR%%/Data/Animations/Staggerbackhard
+%%DATADIR%%/Data/Animations/Staggerbackhigh
+%%DATADIR%%/Data/Animations/Stop
+%%DATADIR%%/Data/Animations/Sweep
+%%DATADIR%%/Data/Animations/Sweepcatch
+%%DATADIR%%/Data/Animations/Sweepcaught
+%%DATADIR%%/Data/Animations/Swordfightidle
+%%DATADIR%%/Data/Animations/Swordfightidleboth
+%%DATADIR%%/Data/Animations/Swordgroundstab
+%%DATADIR%%/Data/Animations/Swordslash
+%%DATADIR%%/Data/Animations/Swordslashcatch
+%%DATADIR%%/Data/Animations/Swordslashcaught
+%%DATADIR%%/Data/Animations/Swordslashparried
+%%DATADIR%%/Data/Animations/Swordsneakattack
+%%DATADIR%%/Data/Animations/Swordsneakattacked
+%%DATADIR%%/Data/Animations/Sworduprightparry
+%%DATADIR%%/Data/Animations/TalkIdle
+%%DATADIR%%/Data/Animations/Tempanim
+%%DATADIR%%/Data/Animations/Walk
+%%DATADIR%%/Data/Animations/Walljumpback
+%%DATADIR%%/Data/Animations/Walljumpfront
+%%DATADIR%%/Data/Animations/Walljumpleft
+%%DATADIR%%/Data/Animations/Walljumpleftkick
+%%DATADIR%%/Data/Animations/Walljumpright
+%%DATADIR%%/Data/Animations/Walljumprightkick
+%%DATADIR%%/Data/Animations/Winduppunch
+%%DATADIR%%/Data/Animations/Winduppunchblocked
+%%DATADIR%%/Data/Animations/Wolfcrouch
+%%DATADIR%%/Data/Animations/Wolfidle
+%%DATADIR%%/Data/Animations/Wolflandhard
+%%DATADIR%%/Data/Animations/Wolflanding
+%%DATADIR%%/Data/Animations/Wolfrun
+%%DATADIR%%/Data/Animations/Wolfrunning
+%%DATADIR%%/Data/Animations/Wolfslap
+%%DATADIR%%/Data/Animations/Wolfstop
+%%DATADIR%%/Data/Animations/upunch
+%%DATADIR%%/Data/Animations/upunchcatch
+%%DATADIR%%/Data/Animations/upunchcaught
+%%DATADIR%%/Data/Campaigns/main.txt
+%%DATADIR%%/Data/Debug Readme
+%%DATADIR%%/Data/Dialogues/Endgood.txt
+%%DATADIR%%/Data/Dialogues/Endharsh.txt
+%%DATADIR%%/Data/Dialogues/Example.txt
+%%DATADIR%%/Data/Dialogues/alphawolf.txt
+%%DATADIR%%/Data/Dialogues/ambush.txt
+%%DATADIR%%/Data/Dialogues/april.txt
+%%DATADIR%%/Data/Dialogues/april2.txt
+%%DATADIR%%/Data/Dialogues/aprilgerm.txt
+%%DATADIR%%/Data/Dialogues/clover.txt
+%%DATADIR%%/Data/Dialogues/clover2.txt
+%%DATADIR%%/Data/Dialogues/guard.txt
+%%DATADIR%%/Data/Dialogues/guards.txt
+%%DATADIR%%/Data/Dialogues/jack.txt
+%%DATADIR%%/Data/Dialogues/jack2.txt
+%%DATADIR%%/Data/Dialogues/jack3.txt
+%%DATADIR%%/Data/Dialogues/jack4.txt
+%%DATADIR%%/Data/Dialogues/jackguards.txt
+%%DATADIR%%/Data/Dialogues/king.txt
+%%DATADIR%%/Data/Dialogues/king2.txt
+%%DATADIR%%/Data/Dialogues/protest.txt
+%%DATADIR%%/Data/Dialogues/raidercamp.txt
+%%DATADIR%%/Data/Dialogues/raiderchief.txt
+%%DATADIR%%/Data/Dialogues/raiderguard.txt
+%%DATADIR%%/Data/Dialogues/raiders.txt
+%%DATADIR%%/Data/Dialogues/raiderscout.txt
+%%DATADIR%%/Data/Dialogues/raiderscout2.txt
+%%DATADIR%%/Data/Dialogues/skipper.txt
+%%DATADIR%%/Data/Dialogues/skipper2.txt
+%%DATADIR%%/Data/Dialogues/skipper3.txt
+%%DATADIR%%/Data/Dialogues/trixie.txt
+%%DATADIR%%/Data/Dialogues/trixie2.txt
+%%DATADIR%%/Data/Dialogues/turner.txt
+%%DATADIR%%/Data/Dialogues/turner10.txt
+%%DATADIR%%/Data/Dialogues/turner2.txt
+%%DATADIR%%/Data/Dialogues/turner3.txt
+%%DATADIR%%/Data/Dialogues/turner4.txt
+%%DATADIR%%/Data/Dialogues/turner5.txt
+%%DATADIR%%/Data/Dialogues/turner6.txt
+%%DATADIR%%/Data/Dialogues/turner7.txt
+%%DATADIR%%/Data/Dialogues/turner8.txt
+%%DATADIR%%/Data/Dialogues/turner81.txt
+%%DATADIR%%/Data/Dialogues/turner82.txt
+%%DATADIR%%/Data/Dialogues/turner9.txt
+%%DATADIR%%/Data/Dialogues/wolfpatrol.txt
+%%DATADIR%%/Data/Maps/Start24
+%%DATADIR%%/Data/Maps/Start25
+%%DATADIR%%/Data/Maps/Start26
+%%DATADIR%%/Data/Maps/Start27
+%%DATADIR%%/Data/Maps/Start28
+%%DATADIR%%/Data/Maps/Start29
+%%DATADIR%%/Data/Maps/Start30
+%%DATADIR%%/Data/Maps/map1
+%%DATADIR%%/Data/Maps/map10
+%%DATADIR%%/Data/Maps/map11
+%%DATADIR%%/Data/Maps/map12
+%%DATADIR%%/Data/Maps/map13
+%%DATADIR%%/Data/Maps/map14
+%%DATADIR%%/Data/Maps/map2
+%%DATADIR%%/Data/Maps/map3
+%%DATADIR%%/Data/Maps/map4
+%%DATADIR%%/Data/Maps/map5
+%%DATADIR%%/Data/Maps/map6
+%%DATADIR%%/Data/Maps/map7
+%%DATADIR%%/Data/Maps/map8
+%%DATADIR%%/Data/Maps/map9
+%%DATADIR%%/Data/Maps/raidercamp
+%%DATADIR%%/Data/Maps/start1
+%%DATADIR%%/Data/Maps/start10
+%%DATADIR%%/Data/Maps/start11
+%%DATADIR%%/Data/Maps/start12
+%%DATADIR%%/Data/Maps/start13
+%%DATADIR%%/Data/Maps/start14
+%%DATADIR%%/Data/Maps/start15
+%%DATADIR%%/Data/Maps/start16
+%%DATADIR%%/Data/Maps/start17
+%%DATADIR%%/Data/Maps/start18
+%%DATADIR%%/Data/Maps/start19
+%%DATADIR%%/Data/Maps/start2
+%%DATADIR%%/Data/Maps/start20
+%%DATADIR%%/Data/Maps/start21
+%%DATADIR%%/Data/Maps/start22
+%%DATADIR%%/Data/Maps/start23
+%%DATADIR%%/Data/Maps/start3
+%%DATADIR%%/Data/Maps/start4
+%%DATADIR%%/Data/Maps/start5
+%%DATADIR%%/Data/Maps/start6
+%%DATADIR%%/Data/Maps/start7
+%%DATADIR%%/Data/Maps/start8
+%%DATADIR%%/Data/Maps/start9
+%%DATADIR%%/Data/Maps/tutorial
+%%DATADIR%%/Data/Models/Belt.solid
+%%DATADIR%%/Data/Models/Body.solid
+%%DATADIR%%/Data/Models/Body2.solid
+%%DATADIR%%/Data/Models/Body3.solid
+%%DATADIR%%/Data/Models/Body4.solid
+%%DATADIR%%/Data/Models/Body5.solid
+%%DATADIR%%/Data/Models/Body6.solid
+%%DATADIR%%/Data/Models/Body7.solid
+%%DATADIR%%/Data/Models/Bodylow.solid
+%%DATADIR%%/Data/Models/Box.solid
+%%DATADIR%%/Data/Models/Bush.solid
+%%DATADIR%%/Data/Models/Chimney.solid
+%%DATADIR%%/Data/Models/Cool.solid
+%%DATADIR%%/Data/Models/Cornea.solid
+%%DATADIR%%/Data/Models/Eye.solid
+%%DATADIR%%/Data/Models/Hawk.solid
+%%DATADIR%%/Data/Models/Iris.solid
+%%DATADIR%%/Data/Models/Leaves.solid
+%%DATADIR%%/Data/Models/Platform.solid
+%%DATADIR%%/Data/Models/Rabbit.solid
+%%DATADIR%%/Data/Models/Rock.solid
+%%DATADIR%%/Data/Models/Spike.solid
+%%DATADIR%%/Data/Models/Sword.solid
+%%DATADIR%%/Data/Models/Throwingknife.solid
+%%DATADIR%%/Data/Models/Treetrunk.solid
+%%DATADIR%%/Data/Models/Tunnel.solid
+%%DATADIR%%/Data/Models/Wall.solid
+%%DATADIR%%/Data/Models/Weird.solid
+%%DATADIR%%/Data/Models/Wolf.solid
+%%DATADIR%%/Data/Models/Wolf2.solid
+%%DATADIR%%/Data/Models/Wolf3.solid
+%%DATADIR%%/Data/Models/Wolf4.solid
+%%DATADIR%%/Data/Models/Wolf5.solid
+%%DATADIR%%/Data/Models/Wolf6.solid
+%%DATADIR%%/Data/Models/Wolf7.solid
+%%DATADIR%%/Data/Models/Wolflow.solid
+%%DATADIR%%/Data/Models/staff.solid
+%%DATADIR%%/Data/Skeleton/Basic Figure
+%%DATADIR%%/Data/Skeleton/Basic Figure wolf
+%%DATADIR%%/Data/Skeleton/Basic Figure wolf low
+%%DATADIR%%/Data/Skeleton/Basic Figurelow
+%%DATADIR%%/Data/Skeleton/Rabbitbelt
+%%DATADIR%%/Data/Sounds/Bark.ogg
+%%DATADIR%%/Data/Sounds/Bark2.ogg
+%%DATADIR%%/Data/Sounds/Bark3.ogg
+%%DATADIR%%/Data/Sounds/Barkgrowl.ogg
+%%DATADIR%%/Data/Sounds/Fleshstab.ogg
+%%DATADIR%%/Data/Sounds/Fleshstabremove.ogg
+%%DATADIR%%/Data/Sounds/Growl.ogg
+%%DATADIR%%/Data/Sounds/Growl2.ogg
+%%DATADIR%%/Data/Sounds/Highwhoosh.ogg
+%%DATADIR%%/Data/Sounds/Lowwhoosh.ogg
+%%DATADIR%%/Data/Sounds/MetalHit.ogg
+%%DATADIR%%/Data/Sounds/Midwhoosh.ogg
+%%DATADIR%%/Data/Sounds/Movewhoosh.ogg
+%%DATADIR%%/Data/Sounds/Rabbitattack.ogg
+%%DATADIR%%/Data/Sounds/Rabbitattack2.ogg
+%%DATADIR%%/Data/Sounds/Rabbitattack3.ogg
+%%DATADIR%%/Data/Sounds/Rabbitattack4.ogg
+%%DATADIR%%/Data/Sounds/Rabbitchitter.ogg
+%%DATADIR%%/Data/Sounds/Rabbitchitter2.ogg
+%%DATADIR%%/Data/Sounds/Rabbitpain.ogg
+%%DATADIR%%/Data/Sounds/Rabbitpain2.ogg
+%%DATADIR%%/Data/Sounds/Snarl.ogg
+%%DATADIR%%/Data/Sounds/Snarl2.ogg
+%%DATADIR%%/Data/Sounds/Swordstaff.ogg
+%%DATADIR%%/Data/Sounds/Thud.ogg
+%%DATADIR%%/Data/Sounds/Whooshhit.ogg
+%%DATADIR%%/Data/Sounds/alarm.ogg
+%%DATADIR%%/Data/Sounds/break.ogg
+%%DATADIR%%/Data/Sounds/broken.ogg
+%%DATADIR%%/Data/Sounds/bushrustle.ogg
+%%DATADIR%%/Data/Sounds/clank1.ogg
+%%DATADIR%%/Data/Sounds/clank2.ogg
+%%DATADIR%%/Data/Sounds/clank3.ogg
+%%DATADIR%%/Data/Sounds/clank4.ogg
+%%DATADIR%%/Data/Sounds/clawslice.ogg
+%%DATADIR%%/Data/Sounds/consolefail.ogg
+%%DATADIR%%/Data/Sounds/consolesuccess.ogg
+%%DATADIR%%/Data/Sounds/desertambient.ogg
+%%DATADIR%%/Data/Sounds/fire.ogg
+%%DATADIR%%/Data/Sounds/fireend.ogg
+%%DATADIR%%/Data/Sounds/firestart.ogg
+%%DATADIR%%/Data/Sounds/footstepgrass1.ogg
+%%DATADIR%%/Data/Sounds/footstepgrass2.ogg
+%%DATADIR%%/Data/Sounds/footstepsnow1.ogg
+%%DATADIR%%/Data/Sounds/footstepsnow2.ogg
+%%DATADIR%%/Data/Sounds/footstepstone1.ogg
+%%DATADIR%%/Data/Sounds/footstepstone2.ogg
+%%DATADIR%%/Data/Sounds/hawk.ogg
+%%DATADIR%%/Data/Sounds/heavyimpact.ogg
+%%DATADIR%%/Data/Sounds/jump.ogg
+%%DATADIR%%/Data/Sounds/knifedraw.ogg
+%%DATADIR%%/Data/Sounds/knifesheathe.ogg
+%%DATADIR%%/Data/Sounds/knifeslice.ogg
+%%DATADIR%%/Data/Sounds/knifeswish.ogg
+%%DATADIR%%/Data/Sounds/land.ogg
+%%DATADIR%%/Data/Sounds/land1.ogg
+%%DATADIR%%/Data/Sounds/land2.ogg
+%%DATADIR%%/Data/Sounds/music1desert.ogg
+%%DATADIR%%/Data/Sounds/music1grass.ogg
+%%DATADIR%%/Data/Sounds/music1snow.ogg
+%%DATADIR%%/Data/Sounds/music2.ogg
+%%DATADIR%%/Data/Sounds/music2old.ogg
+%%DATADIR%%/Data/Sounds/music3.ogg
+%%DATADIR%%/Data/Sounds/skid.ogg
+%%DATADIR%%/Data/Sounds/snowskid.ogg
+%%DATADIR%%/Data/Sounds/splatter.ogg
+%%DATADIR%%/Data/Sounds/staffbody.ogg
+%%DATADIR%%/Data/Sounds/staffbreak.ogg
+%%DATADIR%%/Data/Sounds/staffhead.ogg
+%%DATADIR%%/Data/Sounds/swordslice.ogg
+%%DATADIR%%/Data/Sounds/whoosh.ogg
+%%DATADIR%%/Data/Sounds/wind.ogg
+%%DATADIR%%/Data/Textures/BW2.jpg
+%%DATADIR%%/Data/Textures/Belt.png
+%%DATADIR%%/Data/Textures/BloodApril.png
+%%DATADIR%%/Data/Textures/BloodClover.png
+%%DATADIR%%/Data/Textures/BloodFlame.png
+%%DATADIR%%/Data/Textures/BloodJack.png
+%%DATADIR%%/Data/Textures/BloodKnife.png
+%%DATADIR%%/Data/Textures/BloodTrixie.png
+%%DATADIR%%/Data/Textures/Boulder.jpg
+%%DATADIR%%/Data/Textures/Boulderdesert.jpg
+%%DATADIR%%/Data/Textures/Bouldersnow.jpg
+%%DATADIR%%/Data/Textures/Chocolate.jpg
+%%DATADIR%%/Data/Textures/Cursor.png
+%%DATADIR%%/Data/Textures/Darkwolf.jpg
+%%DATADIR%%/Data/Textures/David.jpg
+%%DATADIR%%/Data/Textures/DesertBox.jpg
+%%DATADIR%%/Data/Textures/Endgame.png
+%%DATADIR%%/Data/Textures/Eyelid.png
+%%DATADIR%%/Data/Textures/Fire.jpg
+%%DATADIR%%/Data/Textures/Flame.png
+%%DATADIR%%/Data/Textures/Font.png
+%%DATADIR%%/Data/Textures/Gi.png
+%%DATADIR%%/Data/Textures/GrassBox.jpg
+%%DATADIR%%/Data/Textures/Knife.png
+%%DATADIR%%/Data/Textures/Leatherwristleft.png
+%%DATADIR%%/Data/Textures/Leatherwristright.png
+%%DATADIR%%/Data/Textures/Lightbloodknife.png
+%%DATADIR%%/Data/Textures/LizardWolf.jpg
+%%DATADIR%%/Data/Textures/Lugaru.png
+%%DATADIR%%/Data/Textures/Lynx.jpg
+%%DATADIR%%/Data/Textures/MapArrow.png
+%%DATADIR%%/Data/Textures/MapBox.png
+%%DATADIR%%/Data/Textures/MapCircle.png
+%%DATADIR%%/Data/Textures/Newgame.png
+%%DATADIR%%/Data/Textures/Opal.jpg
+%%DATADIR%%/Data/Textures/Options.png
+%%DATADIR%%/Data/Textures/Otter.jpg
+%%DATADIR%%/Data/Textures/Quit.png
+%%DATADIR%%/Data/Textures/Resume.png
+%%DATADIR%%/Data/Textures/Sable.jpg
+%%DATADIR%%/Data/Textures/Shine.png
+%%DATADIR%%/Data/Textures/Skybox(grass)/Back.jpg
+%%DATADIR%%/Data/Textures/Skybox(grass)/Down.jpg
+%%DATADIR%%/Data/Textures/Skybox(grass)/Front.jpg
+%%DATADIR%%/Data/Textures/Skybox(grass)/Left.jpg
+%%DATADIR%%/Data/Textures/Skybox(grass)/Right.jpg
+%%DATADIR%%/Data/Textures/Skybox(grass)/Up.jpg
+%%DATADIR%%/Data/Textures/Skybox(sand)/Back.jpg
+%%DATADIR%%/Data/Textures/Skybox(sand)/Down.jpg
+%%DATADIR%%/Data/Textures/Skybox(sand)/Front.jpg
+%%DATADIR%%/Data/Textures/Skybox(sand)/Left.jpg
+%%DATADIR%%/Data/Textures/Skybox(sand)/Right.jpg
+%%DATADIR%%/Data/Textures/Skybox(sand)/Up.jpg
+%%DATADIR%%/Data/Textures/Skybox(snow)/Back.jpg
+%%DATADIR%%/Data/Textures/Skybox(snow)/Down.jpg
+%%DATADIR%%/Data/Textures/Skybox(snow)/Front.jpg
+%%DATADIR%%/Data/Textures/Skybox(snow)/Left.jpg
+%%DATADIR%%/Data/Textures/Skybox(snow)/Right.jpg
+%%DATADIR%%/Data/Textures/Skybox(snow)/Up.jpg
+%%DATADIR%%/Data/Textures/Smoke.png
+%%DATADIR%%/Data/Textures/SnowBox.jpg
+%%DATADIR%%/Data/Textures/SnowWolf.jpg
+%%DATADIR%%/Data/Textures/Staff.jpg
+%%DATADIR%%/Data/Textures/Sword.jpg
+%%DATADIR%%/Data/Textures/Swordblood.jpg
+%%DATADIR%%/Data/Textures/Swordbloodlight.jpg
+%%DATADIR%%/Data/Textures/WB2.jpg
+%%DATADIR%%/Data/Textures/Wireframe.jpg
+%%DATADIR%%/Data/Textures/Wolf.jpg
+%%DATADIR%%/Data/Textures/Wolfbloodfur.png
+%%DATADIR%%/Data/Textures/World.png
+%%DATADIR%%/Data/Textures/blood.png
+%%DATADIR%%/Data/Textures/bloodfur.png
+%%DATADIR%%/Data/Textures/bloodparticle.png
+%%DATADIR%%/Data/Textures/bloodparticleinverse.png
+%%DATADIR%%/Data/Textures/bodyprint.png
+%%DATADIR%%/Data/Textures/break.png
+%%DATADIR%%/Data/Textures/bush.png
+%%DATADIR%%/Data/Textures/bushdesert.png
+%%DATADIR%%/Data/Textures/bushsnow.png
+%%DATADIR%%/Data/Textures/cloud.png
+%%DATADIR%%/Data/Textures/cloudimpact.png
+%%DATADIR%%/Data/Textures/deserttree.png
+%%DATADIR%%/Data/Textures/earwrap.png
+%%DATADIR%%/Data/Textures/fancypants.png
+%%DATADIR%%/Data/Textures/fancypantscamo.png
+%%DATADIR%%/Data/Textures/fancypantscamoarctic.png
+%%DATADIR%%/Data/Textures/fancypantscamodesert.png
+%%DATADIR%%/Data/Textures/footprint.png
+%%DATADIR%%/Data/Textures/footprintsand.png
+%%DATADIR%%/Data/Textures/footwrap.png
+%%DATADIR%%/Data/Textures/fur.jpg
+%%DATADIR%%/Data/Textures/fur2.jpg
+%%DATADIR%%/Data/Textures/fur3.jpg
+%%DATADIR%%/Data/Textures/furdarko.jpg
+%%DATADIR%%/Data/Textures/grassdirt 2.jpg
+%%DATADIR%%/Data/Textures/grassdirt.jpg
+%%DATADIR%%/Data/Textures/hawk.png
+%%DATADIR%%/Data/Textures/headband.png
+%%DATADIR%%/Data/Textures/heightmap.png
+%%DATADIR%%/Data/Textures/leaf.png
+%%DATADIR%%/Data/Textures/leatherarmor.png
+%%DATADIR%%/Data/Textures/leatherpants.png
+%%DATADIR%%/Data/Textures/logo.png
+%%DATADIR%%/Data/Textures/longsleeve.png
+%%DATADIR%%/Data/Textures/mossrock.jpg
+%%DATADIR%%/Data/Textures/pants.png
+%%DATADIR%%/Data/Textures/rock.jpg
+%%DATADIR%%/Data/Textures/rock2.jpg
+%%DATADIR%%/Data/Textures/sand.jpg
+%%DATADIR%%/Data/Textures/sandslope.jpg
+%%DATADIR%%/Data/Textures/scar.png
+%%DATADIR%%/Data/Textures/shadow.png
+%%DATADIR%%/Data/Textures/shirt.png
+%%DATADIR%%/Data/Textures/shirtfemale.png
+%%DATADIR%%/Data/Textures/snow.jpg
+%%DATADIR%%/Data/Textures/snow.png
+%%DATADIR%%/Data/Textures/snowflake.png
+%%DATADIR%%/Data/Textures/snowtree.png
+%%DATADIR%%/Data/Textures/splinter.png
+%%DATADIR%%/Data/Textures/tooth.png
+%%DATADIR%%/Data/Textures/tree.png
+%%DATADIR%%/Data/Users
+%%DATADIR%%/Data/config.txt
+%%DATADIR%%/lugaru
+share/pixmaps/lugaru.png
+@dirrm %%DATADIR%%/Data/Textures/Skybox(snow)
+@dirrm %%DATADIR%%/Data/Textures/Skybox(sand)
+@dirrm %%DATADIR%%/Data/Textures/Skybox(grass)
+@dirrm %%DATADIR%%/Data/Textures
+@dirrm %%DATADIR%%/Data/Sounds
+@dirrm %%DATADIR%%/Data/Skeleton
+@dirrm %%DATADIR%%/Data/Models
+@dirrm %%DATADIR%%/Data/Maps
+@dirrm %%DATADIR%%/Data/Dialogues
+@dirrm %%DATADIR%%/Data/Campaigns
+@dirrm %%DATADIR%%/Data/Animations
+@dirrm %%DATADIR%%/Data
+@dirrm %%DATADIR%%