aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--print/Makefile1
-rw-r--r--print/gsview/Makefile58
-rw-r--r--print/gsview/distinfo3
-rw-r--r--print/gsview/files/patch-src_gvcver.mak9
-rw-r--r--print/gsview/files/patch-srcunx_unx.mak52
-rw-r--r--print/gsview/files/pkg-message.in11
-rw-r--r--print/gsview/pkg-descr24
7 files changed, 158 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 21d314fc8a02..be4800ac57f3 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -103,6 +103,7 @@
SUBDIR += gribouy
SUBDIR += gsfonts
SUBDIR += gspdf
+ SUBDIR += gsview
SUBDIR += gtklp
SUBDIR += guitartex
SUBDIR += gutenprint
diff --git a/print/gsview/Makefile b/print/gsview/Makefile
new file mode 100644
index 000000000000..65f16a88f022
--- /dev/null
+++ b/print/gsview/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: gsview
+# Date created: 13 July 2008
+# Whom: bf <bf2006a@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gsview
+PORTVERSION= 4.9
+CATEGORIES= print
+MASTER_SITES= http://mirror.cs.wisc.edu/pub/mirrors/ghost/ghostgum/
+
+MAINTAINER= bf2006a@yahoo.com
+COMMENT= A GUI to view, search, print, and convert PostScript and PDF documents
+
+USE_GNOME= gtk12
+USE_GHOSTSCRIPT= yes
+
+RUN_DEPENDS+= epstool:${PORTSDIR}/graphics/epstool \
+ pstotext:${PORTSDIR}/print/pstotext
+
+MAKE_ENV+= PTHREAD_LIBS=${PTHREAD_LIBS} PTHREAD_CFLAGS=${PTHREAD_CFLAGS}
+
+MAN1= gsview.1
+PLIST_FILES= bin/gsview \
+ bin/gsview-help \
+ etc/gsview/printer.ini
+PLIST_DIRS= etc/gsview
+PORTDOCS= gsview.css cdorder.txt regorder.txt Readme.htm LICENCE \
+ gvxct.htm gvxde.htm gvxen.htm gvxes.htm gvxfr.htm gvxgr.htm \
+ gvxit.htm gvxnl.htm gvxru.htm gvxse.htm gvxsk.htm
+SUB_FILES= pkg-message
+
+post-patch:
+ ${CP} ${WRKSRC}/srcunx/unx.mak ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's;malloc\.h;stdlib\.h;g' \
+ ${WRKSRC}/src/doc2html.c ${WRKSRC}/src/doc2ipf.c \
+ ${WRKSRC}/src/doc2xml.c
+ ${REINPLACE_CMD} -e 's;mozilla;firefox3;g' \
+ ${WRKSRC}/srcunx/gvxhelp.txt
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/gsview ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/srcunx/gvxhelp.txt ${PREFIX}/bin/gsview-help
+ ${INSTALL_MAN} ${WRKSRC}/srcunx/gsview.1 ${PREFIX}/man/man1
+ ${MKDIR} ${PREFIX}/etc/gsview/
+ ${INSTALL_DATA} ${WRKSRC}/src/printer.ini ${PREFIX}/etc/gsview/
+.ifndef(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_MAN} gsview.css cdorder.txt regorder.txt \
+ Readme.htm LICENCE ${DOCSDIR} )
+ ${INSTALL_MAN} ${WRKSRC}/bin/*.htm ${DOCSDIR}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/print/gsview/distinfo b/print/gsview/distinfo
new file mode 100644
index 000000000000..24e10bd30018
--- /dev/null
+++ b/print/gsview/distinfo
@@ -0,0 +1,3 @@
+MD5 (gsview-4.9.tar.gz) = 96ca9460c8bd86ef20d881554331d72f
+SHA256 (gsview-4.9.tar.gz) = 1a717bef2d6372e6182e4df1793c5d222dc5881a5e02e32284dc716e209ea9e5
+SIZE (gsview-4.9.tar.gz) = 892681
diff --git a/print/gsview/files/patch-src_gvcver.mak b/print/gsview/files/patch-src_gvcver.mak
new file mode 100644
index 000000000000..20fa0c3ac827
--- /dev/null
+++ b/print/gsview/files/patch-src_gvcver.mak
@@ -0,0 +1,9 @@
+--- src/gvcver.mak.orig 2008-07-14 09:44:07.759575900 -0400
++++ src/gvcver.mak 2008-07-14 09:44:49.641971567 -0400
+@@ -32,5 +32,5 @@
+ $(ECHOGSV) -a $(OD)gsvver.h -x 23 "define GSVIEW_VERSION " $(GSVIEW_VERSION)
+ $(ECHOGSV) -a $(OD)gsvver.h -x 23 "define GSVIEW_DOT_VERSION " -x 22 $(GSVIEW_DOT_VERSION) -x 22
+ $(ECHOGSV) -a $(OD)gsvver.h -x 23 "define GSVIEW_DATE " -x 22 $(GSVIEW_DATE) -x 22
+- $(ECHOGSV) -a $(OD)gsvver.h -x 23 "define GSVIEW_DOCPATH " -x 22 $(GSVIEW_DOCPATH) "/gsview-" $(GSVIEW_DOT_VERSION) "/" -x 22
++ $(ECHOGSV) -a $(OD)gsvver.h -x 23 "define GSVIEW_DOCPATH " -x 22 $(GSVIEW_DOCPATH) "/gsview/" -x 22
+ $(ECHOGSV) -a $(OD)gsvver.h -x 23 "define GSVIEW_ETCPATH " -x 22 $(GSVIEW_ETCPATH) "/gsview/" -x 22
diff --git a/print/gsview/files/patch-srcunx_unx.mak b/print/gsview/files/patch-srcunx_unx.mak
new file mode 100644
index 000000000000..450eba32dbcc
--- /dev/null
+++ b/print/gsview/files/patch-srcunx_unx.mak
@@ -0,0 +1,52 @@
+--- srcunx/unx.mak.orig 2008-07-13 07:39:58.254461217 -0400
++++ srcunx/unx.mak 2008-07-14 09:22:24.652938045 -0400
+@@ -19,8 +19,8 @@
+ #
+ # WARNING: Doesn't install pstotext
+
+-prefix=
+-GSVIEW_ROOT=/usr/local
++prefix=${PREFIX}
++GSVIEW_ROOT=
+ GSVIEW_BASE=$(prefix)$(GSVIEW_ROOT)
+
+
+@@ -38,8 +38,6 @@
+ # GSview printer.ini and system wide gsview.ini
+ GSVIEW_ETCPATH=$(prefix)/etc
+
+-MAKE=make
+-CC=gcc
+ OBJ=o
+ INSTALL=install -m 644
+ INSTALL_EXE=install -m 755
+@@ -50,8 +48,8 @@
+
+ # Linux
+ XINCLUDE=
+-PFLAGS=-DMULTITHREAD
+-PLINK=-lpthread -lrt
++PFLAGS=-DMULTITHREAD ${PTHREAD_CFLAGS}
++PLINK=${PTHREAD_LIBS}
+
+ # SunOS 5.7
+ #XINCLUDE=-I/usr/openwin/share/lib
+@@ -77,7 +75,8 @@
+
+ # Other possible options are -Wtraditional
+ # Compiler flags for C and C++ files.
+-CFLAGS=-O -Wall -Wstrict-prototypes -Wmissing-declarations -Wmissing-prototypes -fno-builtin -fno-common -Wcast-qual -Wwrite-strings $(CDEBUG) -DX11 -DUNIX -DNONAG $(RPM_OPT_FLAGS) `gtk-config --cflags` $(XINCLUDE) $(PFLAGS)
++#CFLAGS=-O -Wall -Wstrict-prototypes -Wmissing-declarations -Wmissing-prototypes -fno-builtin -fno-common -Wcast-qual -Wwrite-strings $(CDEBUG) -DX11 -DUNIX -DNONAG $(RPM_OPT_FLAGS) `gtk-config --cflags` $(XINCLUDE) $(PFLAGS)
++CFLAGS+=-Wall -Wstrict-prototypes -Wmissing-declarations -Wmissing-prototypes -fno-builtin -fno-common -Wcast-qual -Wwrite-strings $(CDEBUG) -DX11 -DUNIX -DNONAG `gtk-config --cflags` $(XINCLUDE) $(PFLAGS)
+
+ # Linker flags
+ LFLAGS=$(LDEBUG) $(PLINK) `gtk-config --libs`
+@@ -152,7 +151,7 @@
+ #all: gsview html pstotext
+ all: $(BD)gsview$(EXE) html
+
+-GSVIEW_DOCDIR=$(GSVIEW_DOCPATH)/gsview-$(GSVIEW_DOT_VERSION)
++GSVIEW_DOCDIR=$(GSVIEW_DOCPATH)/gsview
+
+ $(BD)gsview$(EXE): $(OBJS)
+ $(COMP) $(CFLAGS) $(FO)$(BD)gsview$(EXE) $(OBJS) $(LFLAGS)
diff --git a/print/gsview/files/pkg-message.in b/print/gsview/files/pkg-message.in
new file mode 100644
index 000000000000..c09d9b11e921
--- /dev/null
+++ b/print/gsview/files/pkg-message.in
@@ -0,0 +1,11 @@
+
+=========================================================
+For html help access, edit %%PREFIX%%/bin/gsview-help
+to start your browser of choice with appropriate options.
+Some configuration of Ghostscript options may be
+necessary through the Options->Advanced Configure...
+menu. Consider installing graphics/pstoedit to take
+full advantage of the Edit->Convert to vector format...
+feature. (This feature, while useful, occasionally causes
+coredumps.)
+=========================================================
diff --git a/print/gsview/pkg-descr b/print/gsview/pkg-descr
new file mode 100644
index 000000000000..b4a0cb2fd96b
--- /dev/null
+++ b/print/gsview/pkg-descr
@@ -0,0 +1,24 @@
+GSview is a graphical interface for Ghostscript. (Ghostscript is an
+interpreter for the PostScript page description language used by
+laser printers.) For documents following the Adobe PostScript Document
+Structuring Conventions, GSview allows selected pages to be viewed or
+printed. Features include:
+* Display and print PostScript and PDF files.
+* View pages in arbitrary order (Next, Previous, Goto).
+* Page size and Orientation are automatically selected from DSC
+ comments or can be selected using the menu.
+* Print selected pages using Ghostscript.
+* Convert pages to bitmap, PDF or PostScript.
+* Selectable display resolution, depth, alpha.
+* Single button zoom.
+* Extract selected pages to another file.
+* Copy display bitmap to clipboard, and save clipboard bitmap as BMP file.
+* Add bitmap or user preview to EPS file (Interchange, TIFF or Windows
+ Metafile)
+* Graphically select and show bounding box for EPS file.
+* Extract bitmap preview or PostScript from DOS EPS file.
+* Extract text or search for text.
+* Can read gzip and bzip2 compressed PostScript and PDF files.
+* On-line help.
+* English, Catalan, Dutch, French, German, Greek, Italian, Russian,
+ Slovak, Spanish and Swedish languages.