aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--archivers/p5-Archive-Any/Makefile9
-rw-r--r--archivers/p5-Archive-Extract/Makefile9
-rw-r--r--archivers/p5-Archive-Zip/Makefile9
-rw-r--r--archivers/p5-POE-Filter-Zlib/Makefile7
-rw-r--r--biology/p5-Bio-Das/Makefile8
-rw-r--r--devel/p5-App-GitHub/Makefile8
-rw-r--r--devel/p5-Class-Accessor-Grouped/Makefile8
-rw-r--r--devel/p5-Class-Measure/Makefile8
-rw-r--r--devel/p5-Config-AutoConf/Makefile9
-rw-r--r--devel/p5-Config-JSON/Makefile8
-rw-r--r--devel/p5-Data-Dumper-Simple/Makefile9
-rw-r--r--devel/p5-Data-Stream-Bulk/Makefile8
-rw-r--r--devel/p5-DateTime/Makefile8
-rw-r--r--devel/p5-FileHandle-Unget/Makefile9
-rw-r--r--devel/p5-Getopt-Compact-WithCmd/Makefile5
-rw-r--r--devel/p5-Module-Load-Conditional/Makefile11
-rw-r--r--devel/p5-MooseX-Getopt/Makefile8
-rw-r--r--devel/p5-MooseX-Method-Signatures/Makefile8
-rw-r--r--devel/p5-Params-Classify/Makefile8
-rw-r--r--devel/p5-Params-Validate/Makefile10
-rw-r--r--devel/p5-Test-DBIx-Class/Makefile5
-rw-r--r--ftp/p5-File-Fetch/Makefile12
-rw-r--r--ftp/p5-Net-FTPServer/Makefile8
-rw-r--r--net-im/p5-Net-XMPP/Makefile12
-rw-r--r--net/p5-Crypt-DH-GMP/Makefile12
-rw-r--r--net/p5-Google-SAML-Request/Makefile8
-rw-r--r--net/p5-Google-SAML-Response/Makefile11
-rw-r--r--net/p5-Net-Amazon-AWSSign/Makefile8
-rw-r--r--net/p5-Net-Amazon-S3/Makefile8
-rw-r--r--net/p5-Net-Amazon/Makefile12
-rw-r--r--net/p5-Net-Appliance-Session/Makefile8
-rw-r--r--net/p5-Net-HTTP/Makefile11
-rw-r--r--net/p5-Net-OpenID-Consumer/Makefile9
-rw-r--r--net/p5-Net-Patricia/Makefile8
-rw-r--r--net/p5-Net-SAP/Makefile9
-rw-r--r--net/p5-Net-Twitter/Makefile9
-rw-r--r--net/p5-S3/Makefile8
-rw-r--r--net/p5-SOAP-Lite-060/Makefile8
-rw-r--r--net/p5-SOAP-Lite/Makefile8
-rw-r--r--sysutils/p5-Brackup/Makefile12
-rw-r--r--sysutils/p5-MogileFS-Server/Makefile8
-rw-r--r--sysutils/p5-MogileFS-Utils/Makefile9
-rw-r--r--sysutils/p5-arclog/Makefile8
-rw-r--r--sysutils/p5-reslog/Makefile8
44 files changed, 40 insertions, 346 deletions
diff --git a/archivers/p5-Archive-Any/Makefile b/archivers/p5-Archive-Any/Makefile
index 69d1261ad8ee..e467ac10035f 100644
--- a/archivers/p5-Archive-Any/Makefile
+++ b/archivers/p5-Archive-Any/Makefile
@@ -31,11 +31,4 @@ PERL_CONFIGURE= yes
MAN3= Archive::Any.3 Archive::Any::Plugin.3 \
Archive::Any::Plugin::Tar.3 Archive::Any::Plugin::Zip.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501000
-BUILD_DEPENDS+= p5-Archive-Tar>=0.22:${PORTSDIR}/archivers/p5-Archive-Tar
-RUN_DEPENDS+= p5-Archive-Tar>=0.22:${PORTSDIR}/archivers/p5-Archive-Tar
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/archivers/p5-Archive-Extract/Makefile b/archivers/p5-Archive-Extract/Makefile
index a5604718241e..ab95dd95b512 100644
--- a/archivers/p5-Archive-Extract/Makefile
+++ b/archivers/p5-Archive-Extract/Makefile
@@ -21,15 +21,6 @@ MAN3= Archive::Extract.3
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 501000
-BUILD_DEPENDS+= p5-Locale-Maketext-Simple>=0:${PORTSDIR}/devel/p5-Locale-Maketext-Simple \
- p5-Module-Load-Conditional>=0.04:${PORTSDIR}/devel/p5-Module-Load-Conditional \
- p5-Params-Check>=0.07:${PORTSDIR}/devel/p5-Params-Check
-RUN_DEPENDS+= p5-Locale-Maketext-Simple>=0:${PORTSDIR}/devel/p5-Locale-Maketext-Simple \
- p5-Module-Load-Conditional>=0.04:${PORTSDIR}/devel/p5-Module-Load-Conditional \
- p5-Params-Check>=0.07:${PORTSDIR}/devel/p5-Params-Check
-.endif
-
.if ${PERL_LEVEL} < 501400
BUILD_DEPENDS+= p5-IPC-Cmd>=0.64:${PORTSDIR}/devel/p5-IPC-Cmd
RUN_DEPENDS+= p5-IPC-Cmd>=0.64:${PORTSDIR}/devel/p5-IPC-Cmd
diff --git a/archivers/p5-Archive-Zip/Makefile b/archivers/p5-Archive-Zip/Makefile
index a6cfae1851c4..f583ab0b0d9b 100644
--- a/archivers/p5-Archive-Zip/Makefile
+++ b/archivers/p5-Archive-Zip/Makefile
@@ -19,11 +19,4 @@ PERL_CONFIGURE= yes
MAN3= Archive::Zip.3 Archive::Zip::Tree.3 Archive::Zip::FAQ.3 Archive::Zip::MemberRead.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500903
-BUILD_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
-RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/archivers/p5-POE-Filter-Zlib/Makefile b/archivers/p5-POE-Filter-Zlib/Makefile
index c7538eaecd5a..0525f2ea1453 100644
--- a/archivers/p5-POE-Filter-Zlib/Makefile
+++ b/archivers/p5-POE-Filter-Zlib/Makefile
@@ -24,10 +24,5 @@ PERL_CONFIGURE= yes
MAN3= POE::Filter::Zlib.3 \
POE::Filter::Zlib::Stream.3
-.include <bsd.port.pre.mk>
+.include <bsd.port.mk>
-.if ${PERL_LEVEL} < 500903
-RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/biology/p5-Bio-Das/Makefile b/biology/p5-Bio-Das/Makefile
index 50beef43c54e..a40cf4b72a86 100644
--- a/biology/p5-Bio-Das/Makefile
+++ b/biology/p5-Bio-Das/Makefile
@@ -34,10 +34,4 @@ MAN3= Bio::Das.3 Bio::Das::AGPServer::Config.3 Bio::Das::AGPServer::Daemon.3 \
Bio::Das::Request::Types.3 Bio::Das::Segment.3 Bio::Das::Stylesheet.3 \
Bio::Das::Type.3 Bio::Das::TypeHandler.3 Bio::Das::Util.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500903
-RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-App-GitHub/Makefile b/devel/p5-App-GitHub/Makefile
index 2a443d8c9e2b..9dd58b046f5a 100644
--- a/devel/p5-App-GitHub/Makefile
+++ b/devel/p5-App-GitHub/Makefile
@@ -28,10 +28,4 @@ PERL_CONFIGURE= yes
MAN1= github.pl.1
MAN3= App::GitHub.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500905
-RUN_DEPENDS+= p5-IPC-Cmd>=0:${PORTSDIR}/devel/p5-IPC-Cmd
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Class-Accessor-Grouped/Makefile b/devel/p5-Class-Accessor-Grouped/Makefile
index 2cf6fbffeab3..a15f9b52e555 100644
--- a/devel/p5-Class-Accessor-Grouped/Makefile
+++ b/devel/p5-Class-Accessor-Grouped/Makefile
@@ -26,10 +26,4 @@ PERL_CONFIGURE= yes
MAN3= Class::Accessor::Grouped.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Class-Measure/Makefile b/devel/p5-Class-Measure/Makefile
index dc520b0997e2..62c764abee06 100644
--- a/devel/p5-Class-Measure/Makefile
+++ b/devel/p5-Class-Measure/Makefile
@@ -24,10 +24,4 @@ PERL_CONFIGURE= yes
MAN3= Class::Measure.3 Class::Measure::Length.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.82:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Config-AutoConf/Makefile b/devel/p5-Config-AutoConf/Makefile
index ec7e23336c94..2da19adb6666 100644
--- a/devel/p5-Config-AutoConf/Makefile
+++ b/devel/p5-Config-AutoConf/Makefile
@@ -20,11 +20,4 @@ PERL_CONFIGURE= yes
MAN3= Config::AutoConf.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-ExtUtils-CBuilder>=0.23:${PORTSDIR}/devel/p5-ExtUtils-CBuilder
-RUN_DEPENDS+= p5-ExtUtils-CBuilder>=0.23:${PORTSDIR}/devel/p5-ExtUtils-CBuilder
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Config-JSON/Makefile b/devel/p5-Config-JSON/Makefile
index a100746f1b8a..e880ef5b1099 100644
--- a/devel/p5-Config-JSON/Makefile
+++ b/devel/p5-Config-JSON/Makefile
@@ -25,10 +25,4 @@ TEST_DEPENDS= p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep
PERL_CONFIGURE= Yes
MAN3= Config::JSON.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500905
-RUN_DEPENDS+= p5-version>=0.72.03:${PORTSDIR}/devel/p5-version
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Data-Dumper-Simple/Makefile b/devel/p5-Data-Dumper-Simple/Makefile
index 42f87da218a5..c56b6d9671de 100644
--- a/devel/p5-Data-Dumper-Simple/Makefile
+++ b/devel/p5-Data-Dumper-Simple/Makefile
@@ -18,11 +18,4 @@ PERL_MODBUILD= yes
MAN3= Data::Dumper::Simple.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500805
-BUILD_DEPENDS+= p5-Filter-Simple>=0:${PORTSDIR}/textproc/p5-Filter-Simple
-RUN_DEPENDS+= ${BUILD_DEPENDS}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Data-Stream-Bulk/Makefile b/devel/p5-Data-Stream-Bulk/Makefile
index 2e846406d208..5768d7dce145 100644
--- a/devel/p5-Data-Stream-Bulk/Makefile
+++ b/devel/p5-Data-Stream-Bulk/Makefile
@@ -41,10 +41,4 @@ MAN3= Data::Stream::Bulk.3 \
Data::Stream::Bulk::Path::Class.3 \
Data::Stream::Bulk::Util.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-DateTime/Makefile b/devel/p5-DateTime/Makefile
index d82688209c66..36230cee6b51 100644
--- a/devel/p5-DateTime/Makefile
+++ b/devel/p5-DateTime/Makefile
@@ -38,10 +38,4 @@ post-install:
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-FileHandle-Unget/Makefile b/devel/p5-FileHandle-Unget/Makefile
index a94cb522f46d..1e71a182a31f 100644
--- a/devel/p5-FileHandle-Unget/Makefile
+++ b/devel/p5-FileHandle-Unget/Makefile
@@ -18,11 +18,4 @@ PERL_CONFIGURE= yes
MAN3= FileHandle::Unget.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500805
-BUILD_DEPENDS= p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
-RUN_DEPENDS:= ${BUILD_DEPENDS}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Getopt-Compact-WithCmd/Makefile b/devel/p5-Getopt-Compact-WithCmd/Makefile
index 25feec5ff8ba..a8fd532ae6f9 100644
--- a/devel/p5-Getopt-Compact-WithCmd/Makefile
+++ b/devel/p5-Getopt-Compact-WithCmd/Makefile
@@ -24,11 +24,6 @@ MAN3= Getopt::Compact::WithCmd.3
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-Getopt-Long>=2.38:${PORTSDIR}/devel/p5-Getopt-Long
-RUN_DEPENDS+= p5-Getopt-Long>=2.38:${PORTSDIR}/devel/p5-Getopt-Long
-.endif
-
.if ${PERL_LEVEL} < 501400
TEST_DEPENDS+= p5-Test-Simple>=0.96:${PORTSDIR}/devel/p5-Test-Simple
.endif
diff --git a/devel/p5-Module-Load-Conditional/Makefile b/devel/p5-Module-Load-Conditional/Makefile
index f87189ac4cb9..b356baf83ce6 100644
--- a/devel/p5-Module-Load-Conditional/Makefile
+++ b/devel/p5-Module-Load-Conditional/Makefile
@@ -26,17 +26,6 @@ MAN3= Module::Load::Conditional.3
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 501000
-BUILD_DEPENDS+= p5-Locale-Maketext-Simple>=0:${PORTSDIR}/devel/p5-Locale-Maketext-Simple \
- p5-Module-Load>=0.11:${PORTSDIR}/devel/p5-Module-Load \
- p5-Params-Check>=0:${PORTSDIR}/devel/p5-Params-Check \
- p5-version>=0.69:${PORTSDIR}/devel/p5-version
-RUN_DEPENDS+= p5-Locale-Maketext-Simple>=0:${PORTSDIR}/devel/p5-Locale-Maketext-Simple \
- p5-Module-Load>=0.11:${PORTSDIR}/devel/p5-Module-Load \
- p5-Params-Check>=0:${PORTSDIR}/devel/p5-Params-Check \
- p5-version>=0.69:${PORTSDIR}/devel/p5-version
-.endif
-
.if ${PERL_LEVEL} < 501600
BUILD_DEPENDS+= p5-Module-Metadata>=1.000005:${PORTSDIR}/devel/p5-Module-Metadata
RUN_DEPENDS+= p5-Module-Metadata>=1.000005:${PORTSDIR}/devel/p5-Module-Metadata
diff --git a/devel/p5-MooseX-Getopt/Makefile b/devel/p5-MooseX-Getopt/Makefile
index f9f78f6d53ca..5e4e33f127e9 100644
--- a/devel/p5-MooseX-Getopt/Makefile
+++ b/devel/p5-MooseX-Getopt/Makefile
@@ -45,10 +45,4 @@ MAN3= MooseX::Getopt.3 \
MooseX::Getopt::ProcessedArgv.3 \
MooseX::Getopt::Strict.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-MooseX-Method-Signatures/Makefile b/devel/p5-MooseX-Method-Signatures/Makefile
index c7c1a5fcc362..2a1dd932cf71 100644
--- a/devel/p5-MooseX-Method-Signatures/Makefile
+++ b/devel/p5-MooseX-Method-Signatures/Makefile
@@ -46,10 +46,4 @@ MAN3= MooseX::Method::Signatures.3 \
MooseX::Method::Signatures::Types.3 \
MooseX::Method::Signatures::Meta::Method.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.89:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Params-Classify/Makefile b/devel/p5-Params-Classify/Makefile
index fb422a9e5b46..06b80e3f862d 100644
--- a/devel/p5-Params-Classify/Makefile
+++ b/devel/p5-Params-Classify/Makefile
@@ -18,10 +18,4 @@ PERL_MODBUILD= yes
MAN3= Params::Classify.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-RUN_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Params-Validate/Makefile b/devel/p5-Params-Validate/Makefile
index 026572231b2c..0eade4c1c490 100644
--- a/devel/p5-Params-Validate/Makefile
+++ b/devel/p5-Params-Validate/Makefile
@@ -23,12 +23,4 @@ PERL_MODBUILD= yes
MAN3= Attribute::Params::Validate.3 \
Params::Validate.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501000
-BUILD_DEPENDS+= p5-Attribute-Handlers>=0.79:${PORTSDIR}/devel/p5-Attribute-Handlers
-RUN_DEPENDS+= p5-Attribute-Handlers>=0.79:${PORTSDIR}/devel/p5-Attribute-Handlers
-TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-DBIx-Class/Makefile b/devel/p5-Test-DBIx-Class/Makefile
index 7033c8b57fce..04d56e96e4d6 100644
--- a/devel/p5-Test-DBIx-Class/Makefile
+++ b/devel/p5-Test-DBIx-Class/Makefile
@@ -60,11 +60,6 @@ MAN3= Test::DBIx::Class.3 \
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-Digest-MD5>=2.39:${PORTSDIR}/security/p5-Digest-MD5
-RUN_DEPENDS+= p5-Digest-MD5>=2.39:${PORTSDIR}/security/p5-Digest-MD5
-.endif
-
.if ${PERL_LEVEL} < 501400
BUILD_DEPENDS+= p5-Scalar-List-Utils>=1.23:${PORTSDIR}/lang/p5-Scalar-List-Utils
RUN_DEPENDS+= p5-Scalar-List-Utils>=1.23:${PORTSDIR}/lang/p5-Scalar-List-Utils
diff --git a/ftp/p5-File-Fetch/Makefile b/ftp/p5-File-Fetch/Makefile
index 171a1948270f..3e0276ed0c39 100644
--- a/ftp/p5-File-Fetch/Makefile
+++ b/ftp/p5-File-Fetch/Makefile
@@ -21,14 +21,4 @@ PERL_CONFIGURE= yes
MAN3= File::Fetch.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-IPC-Cmd>=0.42:${PORTSDIR}/devel/p5-IPC-Cmd \
- p5-Locale-Maketext-Simple>=0:${PORTSDIR}/devel/p5-Locale-Maketext-Simple \
- p5-Module-Load-Conditional>=0.04:${PORTSDIR}/devel/p5-Module-Load-Conditional \
- p5-Params-Check>=0.07:${PORTSDIR}/devel/p5-Params-Check
-RUN_DEPENDS:= ${BUILD_DEPENDS}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/ftp/p5-Net-FTPServer/Makefile b/ftp/p5-Net-FTPServer/Makefile
index a88eae4eb9d2..72d6c8487df7 100644
--- a/ftp/p5-Net-FTPServer/Makefile
+++ b/ftp/p5-Net-FTPServer/Makefile
@@ -55,12 +55,6 @@ DOCS= FAQ README TODO doc/*
PORTDOCS= *
PORTEXAMPLES= ftpd.conf
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500903
-RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
-.endif
-
post-patch:
@${REINPLACE_CMD} -e "s/root,root/root,wheel/" \
-e "s,/usr/sbin,${PREFIX}/sbin," \
@@ -81,4 +75,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-im/p5-Net-XMPP/Makefile b/net-im/p5-Net-XMPP/Makefile
index c0bd599cb6c2..8a482f28250d 100644
--- a/net-im/p5-Net-XMPP/Makefile
+++ b/net-im/p5-Net-XMPP/Makefile
@@ -41,14 +41,4 @@ MAN3= Net::XMPP.3 \
Net::XMPP::Roster.3 \
Net::XMPP::Stanza.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.92:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.if ${PERL_LEVEL} < 501200
-BUILD_DEPENDS+= p5-Module-Build>=0.3603:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Crypt-DH-GMP/Makefile b/net/p5-Crypt-DH-GMP/Makefile
index f30837e8dfbb..dde0570b606a 100644
--- a/net/p5-Crypt-DH-GMP/Makefile
+++ b/net/p5-Crypt-DH-GMP/Makefile
@@ -28,14 +28,4 @@ MAN3= Crypt::DH::GMP.3 \
post-patch:
${REINPLACE_CMD} -e 's#%%LOCALBASE%%#${LOCALBASE}#g' ${WRKSRC}/Makefile.PL
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-Devel-PPPort>=3.19:${PORTSDIR}/devel/p5-Devel-PPPort
-.endif
-
-.if ${PERL_LEVEL} < 501200
-BUILD_DEPENDS+= p5-ExtUtils-ParseXS>=2.21:${PORTSDIR}/devel/p5-ExtUtils-ParseXS
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Google-SAML-Request/Makefile b/net/p5-Google-SAML-Request/Makefile
index aabf3af62390..2f95058055ef 100644
--- a/net/p5-Google-SAML-Request/Makefile
+++ b/net/p5-Google-SAML-Request/Makefile
@@ -25,10 +25,4 @@ PERL_CONFIGURE= yes
MAN3= Google::SAML::Request.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500903
-RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Google-SAML-Response/Makefile b/net/p5-Google-SAML-Response/Makefile
index 15c5cf874377..a14465ed052b 100644
--- a/net/p5-Google-SAML-Response/Makefile
+++ b/net/p5-Google-SAML-Response/Makefile
@@ -30,13 +30,4 @@ PERL_CONFIGURE= yes
MAN3= Google::SAML::Response.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501000
-BUILD_DEPENDS+= p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA \
- p5-IO-Compress>=0:${PORTSDIR}/archivers/p5-IO-Compress
-RUN_DEPENDS+= p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA \
- p5-IO-Compress>=0:${PORTSDIR}/archivers/p5-IO-Compress
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Amazon-AWSSign/Makefile b/net/p5-Net-Amazon-AWSSign/Makefile
index 08a2da4663f1..4046da54ad2e 100644
--- a/net/p5-Net-Amazon-AWSSign/Makefile
+++ b/net/p5-Net-Amazon-AWSSign/Makefile
@@ -21,10 +21,4 @@ PERL_CONFIGURE= yes
MAN3= Net::Amazon::AWSSign.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500903
-RUN_DEPENDS+= p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Amazon-S3/Makefile b/net/p5-Net-Amazon-S3/Makefile
index 887282450040..b387946d7b62 100644
--- a/net/p5-Net-Amazon-S3/Makefile
+++ b/net/p5-Net-Amazon-S3/Makefile
@@ -58,10 +58,4 @@ MAN3= Net::Amazon::S3.3 Net::Amazon::S3::Bucket.3 \
Net::Amazon::S3::Request.3 \
Net::Amazon::S3::Request::CreateBucket.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500904
-RUN_DEPENDS+= p5-IO>=1.14:${PORTSDIR}/devel/p5-IO
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Amazon/Makefile b/net/p5-Net-Amazon/Makefile
index 9cdbbe7c1972..eee25ea2c465 100644
--- a/net/p5-Net-Amazon/Makefile
+++ b/net/p5-Net-Amazon/Makefile
@@ -27,14 +27,4 @@ PERL_CONFIGURE= yes
.include "Makefile.man"
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500805
-RUN_DEPENDS+= p5-Time-HiRes>=0:${PORTSDIR}/devel/p5-Time-HiRes
-.endif
-
-.if ${PERL_LEVEL} < 501000
-RUN_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Appliance-Session/Makefile b/net/p5-Net-Appliance-Session/Makefile
index 5b6ac3d66c37..aac6aa2c5b9b 100644
--- a/net/p5-Net-Appliance-Session/Makefile
+++ b/net/p5-Net-Appliance-Session/Makefile
@@ -27,10 +27,4 @@ PERL_CONFIGURE= yes
MAN3= Net::Appliance::Session.3 \
Net::Appliance::Session::APIv2.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Net-HTTP/Makefile b/net/p5-Net-HTTP/Makefile
index ae4a500fca5d..23713f916864 100644
--- a/net/p5-Net-HTTP/Makefile
+++ b/net/p5-Net-HTTP/Makefile
@@ -24,13 +24,4 @@ MAN3= Net::HTTP.3 \
Net::HTTPS.3 \
Net::HTTP::NB.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501000
-BUILD_DEPENDS+= p5-Compress-Raw-Zlib>=0:${PORTSDIR}/archivers/p5-Compress-Raw-Zlib \
- p5-IO-Compress>=0:${PORTSDIR}/archivers/p5-IO-Compress
-RUN_DEPENDS+= p5-Compress-Raw-Zlib>=0:${PORTSDIR}/archivers/p5-Compress-Raw-Zlib \
- p5-IO-Compress>=0:${PORTSDIR}/archivers/p5-IO-Compress
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Net-OpenID-Consumer/Makefile b/net/p5-Net-OpenID-Consumer/Makefile
index 0473efcdf6eb..10352dd26ce3 100644
--- a/net/p5-Net-OpenID-Consumer/Makefile
+++ b/net/p5-Net-OpenID-Consumer/Makefile
@@ -31,11 +31,4 @@ regression-test: build
cd ${WRKSRC} && ${MAKE} test
.endif
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501000
-BUILD_DEPENDS+= p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA
-RUN_DEPENDS+= p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Patricia/Makefile b/net/p5-Net-Patricia/Makefile
index 48abafa66d78..e70104d65c18 100644
--- a/net/p5-Net-Patricia/Makefile
+++ b/net/p5-Net-Patricia/Makefile
@@ -17,10 +17,4 @@ PERL_CONFIGURE= YES
MAN3= Net::Patricia.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Net-SAP/Makefile b/net/p5-Net-SAP/Makefile
index d436ad647c57..ee8434d815c7 100644
--- a/net/p5-Net-SAP/Makefile
+++ b/net/p5-Net-SAP/Makefile
@@ -25,11 +25,4 @@ PERL_MODBUILD= YES
MAN1= psapd.1
MAN3= Net::SAP.3 Net::SAP::Packet.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500903
-RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
-BUILD_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Twitter/Makefile b/net/p5-Net-Twitter/Makefile
index 13894f13a1df..ea73592ef9dd 100644
--- a/net/p5-Net-Twitter/Makefile
+++ b/net/p5-Net-Twitter/Makefile
@@ -58,11 +58,4 @@ MAN3= Net::Identica.3 \
Net::Twitter::Role::WrapError.3 \
Net::Twitter::Search.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501000
-BUILD_DEPENDS+= p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA
-RUN_DEPENDS+= p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-S3/Makefile b/net/p5-S3/Makefile
index ab28b6c26664..b7f3d25ab149 100644
--- a/net/p5-S3/Makefile
+++ b/net/p5-S3/Makefile
@@ -31,10 +31,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/S3.pm ${PREFIX}/${SITE_PERL_REL}
${INSTALL_SCRIPT} ${WRKSRC}/s3-*.pl ${PREFIX}/bin
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-SOAP-Lite-060/Makefile b/net/p5-SOAP-Lite-060/Makefile
index 35cad48ff475..00de8612ebb8 100644
--- a/net/p5-SOAP-Lite-060/Makefile
+++ b/net/p5-SOAP-Lite-060/Makefile
@@ -53,14 +53,8 @@ MAN3= Apache::SOAP.3 \
XMLRPC::Transport::POP3.3 \
XMLRPC::Transport::TCP.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500903
-RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
-.endif
-
post-patch:
@${REINPLACE_CMD} -i '' -e 's|^#!.*perl|#!${PERL}|' \
${WRKSRC}/bin/* ${WRKSRC}/t/*
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-SOAP-Lite/Makefile b/net/p5-SOAP-Lite/Makefile
index f755f5d4ef97..a69e871530bd 100644
--- a/net/p5-SOAP-Lite/Makefile
+++ b/net/p5-SOAP-Lite/Makefile
@@ -64,14 +64,8 @@ MAN3= Apache::SOAP.3 \
XMLRPC::Transport::POP3.3 \
XMLRPC::Transport::TCP.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501000
-RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
-.endif
-
post-patch:
@${REINPLACE_CMD} -i '' -e 's|^#!.*perl|#!${PERL}|' \
${WRKSRC}/bin/* ${WRKSRC}/t/*.t ${WRKSRC}/t/*.pl
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/p5-Brackup/Makefile b/sysutils/p5-Brackup/Makefile
index 750742a483ab..8f8ef18872b7 100644
--- a/sysutils/p5-Brackup/Makefile
+++ b/sysutils/p5-Brackup/Makefile
@@ -54,14 +54,4 @@ MAN3= Brackup.3 \
Brackup::Target::Riak.3 \
Brackup::Target::Sftp.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500905
-RUN_DEPENDS+= p5-File-Temp>=0.17:${PORTSDIR}/devel/p5-File-Temp
-.endif
-
-.if ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-ExtUtils-Manifest>=1.52:${PORTSDIR}/devel/p5-ExtUtils-Manifest
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/p5-MogileFS-Server/Makefile b/sysutils/p5-MogileFS-Server/Makefile
index a5bd441b306c..3edc9bab0e77 100644
--- a/sysutils/p5-MogileFS-Server/Makefile
+++ b/sysutils/p5-MogileFS-Server/Makefile
@@ -65,10 +65,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}/
.endif
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/p5-MogileFS-Utils/Makefile b/sysutils/p5-MogileFS-Utils/Makefile
index 3ab932e5103c..cd3335a5b429 100644
--- a/sysutils/p5-MogileFS-Utils/Makefile
+++ b/sysutils/p5-MogileFS-Utils/Makefile
@@ -34,14 +34,7 @@ MAN1= mogadm.1 \
mogupload.1
MAN3= MogileFS::Utils.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501000
-BUILD_DEPENDS+= p5-IO-Compress>=0:${PORTSDIR}/archivers/p5-IO-Compress
-RUN_DEPENDS+= p5-IO-Compress>=0:${PORTSDIR}/archivers/p5-IO-Compress
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '/NAME/ s|MogileFS-Utils|MogileFS::Utils|' ${WRKSRC}/Makefile.PL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/p5-arclog/Makefile b/sysutils/p5-arclog/Makefile
index a73aaabcbf1f..41ecdf6f630c 100644
--- a/sysutils/p5-arclog/Makefile
+++ b/sysutils/p5-arclog/Makefile
@@ -29,10 +29,4 @@ PLIST_FILES= bin/arclog \
%%SITE_PERL%%/%%PERL_ARCH%%/auto/arclog/.packlist
PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/arclog
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500903
-RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/p5-reslog/Makefile b/sysutils/p5-reslog/Makefile
index 10b298b1dc19..362ce03faf00 100644
--- a/sysutils/p5-reslog/Makefile
+++ b/sysutils/p5-reslog/Makefile
@@ -28,10 +28,4 @@ PLIST_FILES= bin/reslog \
%%SITE_PERL%%/%%PERL_ARCH%%/auto/reslog/.packlist
PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/reslog
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500903
-RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>