aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--converters/p5-Unicode-IMAPUtf7/Makefile2
-rw-r--r--converters/p5-Unicode-Lite/Makefile6
-rw-r--r--converters/p5-Unicode-MapUTF8/Makefile10
-rw-r--r--devel/p5-Class-Factory/Makefile4
-rw-r--r--devel/p5-Iterator-IO/Makefile2
-rw-r--r--lang/p5-Quantum-Superpositions/Makefile2
-rw-r--r--multimedia/p5-Video-OpenQuicktime/Makefile4
-rw-r--r--net-mgmt/p5-Net-IPv6Addr/Makefile4
-rw-r--r--net-mgmt/p5-SNMP-Util/Makefile2
-rw-r--r--net/p5-Event-tcp/Makefile4
-rw-r--r--net/p5-Net-Address-IPv4-Local/Makefile2
-rw-r--r--net/p5-Net-SFTP/Makefile2
-rw-r--r--net/p5-Net-Traceroute-PurePerl/Makefile2
-rw-r--r--net/p5-SOAP/Makefile4
-rw-r--r--net/p5-URI-OpenURL/Makefile2
15 files changed, 25 insertions, 27 deletions
diff --git a/converters/p5-Unicode-IMAPUtf7/Makefile b/converters/p5-Unicode-IMAPUtf7/Makefile
index ebf0d42a8385..7b0fe3aed623 100644
--- a/converters/p5-Unicode-IMAPUtf7/Makefile
+++ b/converters/p5-Unicode-IMAPUtf7/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl extension to deal with IMAP UTF7
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Unicode/String.pm:${PORTSDIR}/converters/p5-Unicode-String
+BUILD_DEPENDS= p5-Unicode-String>=0:${PORTSDIR}/converters/p5-Unicode-String
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/converters/p5-Unicode-Lite/Makefile b/converters/p5-Unicode-Lite/Makefile
index 79198452ba50..ca07cfa91181 100644
--- a/converters/p5-Unicode-Lite/Makefile
+++ b/converters/p5-Unicode-Lite/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl module for easy conversion between encodings
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Unicode/String.pm:${PORTSDIR}/converters/p5-Unicode-String \
- ${SITE_PERL}/${PERL_ARCH}/Unicode/Map.pm:${PORTSDIR}/converters/p5-Unicode-Map \
- ${SITE_PERL}/enum.pm:${PORTSDIR}/devel/p5-enum
+BUILD_DEPENDS= p5-Unicode-String>=0:${PORTSDIR}/converters/p5-Unicode-String \
+ p5-Unicode-Map>=0:${PORTSDIR}/converters/p5-Unicode-Map \
+ p5-enum>=0:${PORTSDIR}/devel/p5-enum
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/converters/p5-Unicode-MapUTF8/Makefile b/converters/p5-Unicode-MapUTF8/Makefile
index 671ef2078fba..b9f69a26d368 100644
--- a/converters/p5-Unicode-MapUTF8/Makefile
+++ b/converters/p5-Unicode-MapUTF8/Makefile
@@ -13,16 +13,14 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl class that implements conversion between arbitrary charsets
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Unicode/Map.pm:${PORTSDIR}/converters/p5-Unicode-Map \
- ${SITE_PERL}/${PERL_ARCH}/Unicode/String.pm:${PORTSDIR}/converters/p5-Unicode-String \
- ${SITE_PERL}/${PERL_ARCH}/Unicode/Map8.pm:${PORTSDIR}/converters/p5-Unicode-Map8 \
- ${JCODE}:${PORTSDIR}/japanese/p5-Jcode
+BUILD_DEPENDS= p5-Unicode-Map>=0:${PORTSDIR}/converters/p5-Unicode-Map \
+ p5-Unicode-String>=0:${PORTSDIR}/converters/p5-Unicode-String \
+ p5-Unicode-Map8>=0:${PORTSDIR}/converters/p5-Unicode-Map8 \
+ p5-Jcode>=0:${PORTSDIR}/japanese/p5-Jcode
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN3= Unicode::MapUTF8.3
-JCODE= ${SITE_PERL}/Jcode.pm
-
.include <bsd.port.mk>
diff --git a/devel/p5-Class-Factory/Makefile b/devel/p5-Class-Factory/Makefile
index 654434dfeca7..07124f4fab65 100644
--- a/devel/p5-Class-Factory/Makefile
+++ b/devel/p5-Class-Factory/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Base class for dynamic factory classes
-BUILD_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
-RUN_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+BUILD_DEPENDS= p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
PERL_CONFIGURE= yes
diff --git a/devel/p5-Iterator-IO/Makefile b/devel/p5-Iterator-IO/Makefile
index ded3bca218a6..4835b46f241c 100644
--- a/devel/p5-Iterator-IO/Makefile
+++ b/devel/p5-Iterator-IO/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Filesystem and stream iterators
-BUILD_DEPENDS= ${SITE_PERL}/Iterator.pm:${PORTSDIR}/devel/p5-Iterator
+BUILD_DEPENDS= p5-Iterator>=0:${PORTSDIR}/devel/p5-Iterator
RUN_DEPENDS+= ${BUILD_DEPENDS}
MAN3= Iterator::IO.3
diff --git a/lang/p5-Quantum-Superpositions/Makefile b/lang/p5-Quantum-Superpositions/Makefile
index cc6c1ab7496c..098b679d9a62 100644
--- a/lang/p5-Quantum-Superpositions/Makefile
+++ b/lang/p5-Quantum-Superpositions/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= QM-like superpositions in Perl
-BUILD_DEPENDS= ${SITE_PERL}/Class/Multimethods.pm:${PORTSDIR}/devel/p5-Class-Multimethods
+BUILD_DEPENDS= p5-Class-Multimethods>=0:${PORTSDIR}/devel/p5-Class-Multimethods
RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Quantum::Superpositions.3
diff --git a/multimedia/p5-Video-OpenQuicktime/Makefile b/multimedia/p5-Video-OpenQuicktime/Makefile
index f0af1a409408..e9cf041fba38 100644
--- a/multimedia/p5-Video-OpenQuicktime/Makefile
+++ b/multimedia/p5-Video-OpenQuicktime/Makefile
@@ -15,9 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= An interface to the OpenQuicktime library
-BUILD_DEPENDS= ${SITE_PERL}/Inline-API.pod:${PORTSDIR}/devel/p5-Inline
+BUILD_DEPENDS= p5-Inline>=0:${PORTSDIR}/devel/p5-Inline
LIB_DEPENDS= openquicktime.0:${PORTSDIR}/multimedia/openquicktime
-RUN_DEPENDS= ${SITE_PERL}/Inline-API.pod:${PORTSDIR}/devel/p5-Inline
+RUN_DEPENDS= p5-Inline>=0:${PORTSDIR}/devel/p5-Inline
MAKE_JOBS_UNSAFE= yes
diff --git a/net-mgmt/p5-Net-IPv6Addr/Makefile b/net-mgmt/p5-Net-IPv6Addr/Makefile
index 83f961a3f8b7..6e2cd727f883 100644
--- a/net-mgmt/p5-Net-IPv6Addr/Makefile
+++ b/net-mgmt/p5-Net-IPv6Addr/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl extension for manipulating IPv6 addresses
-BUILD_DEPENDS= ${SITE_PERL}/Net/IPv4Addr.pm:${PORTSDIR}/net-mgmt/p5-Net-IPv4Addr \
- ${SITE_PERL}/Math/Base85.pm:${PORTSDIR}/math/p5-Math-Base85
+BUILD_DEPENDS= p5-Net-IPv4Addr>=0:${PORTSDIR}/net-mgmt/p5-Net-IPv4Addr \
+ p5-Math-Base85>=0:${PORTSDIR}/math/p5-Math-Base85
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net-mgmt/p5-SNMP-Util/Makefile b/net-mgmt/p5-SNMP-Util/Makefile
index d6c7f9409a67..f6489c152589 100644
--- a/net-mgmt/p5-SNMP-Util/Makefile
+++ b/net-mgmt/p5-SNMP-Util/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl modules to perform SNMP set,get,walk,next,walk_hash etc
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/SNMP.pm:${PORTSDIR}/net-mgmt/net-snmp
+RUN_DEPENDS= net-snmp>=0:${PORTSDIR}/net-mgmt/net-snmp
EXTRA_PATCHES= ${PATCHDIR}/extra-net-snmp-patch-Makefile.PL
diff --git a/net/p5-Event-tcp/Makefile b/net/p5-Event-tcp/Makefile
index a97936ad87de..9054cb91fe22 100644
--- a/net/p5-Event-tcp/Makefile
+++ b/net/p5-Event-tcp/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Glue code to build client-server style TCP-based services
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Event.pm:${PORTSDIR}/devel/p5-Event \
- ${SITE_PERL}/${PERL_ARCH}/Ioctl.pm:${PORTSDIR}/devel/p5-Ioctl
+BUILD_DEPENDS= p5-Event>=0:${PORTSDIR}/devel/p5-Event \
+ p5-Ioctl>=0:${PORTSDIR}/devel/p5-Ioctl
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net/p5-Net-Address-IPv4-Local/Makefile b/net/p5-Net-Address-IPv4-Local/Makefile
index 856ca4a2f3ee..bad47fac9a2d 100644
--- a/net/p5-Net-Address-IPv4-Local/Makefile
+++ b/net/p5-Net-Address-IPv4-Local/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= A class for discovering the local system's IP address
-BUILD_DEPENDS= ${SITE_PERL}/Error.pm:${PORTSDIR}/lang/p5-Error
+BUILD_DEPENDS= p5-Error>=0:${PORTSDIR}/lang/p5-Error
RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Net::Address::IPv4::Local.3
diff --git a/net/p5-Net-SFTP/Makefile b/net/p5-Net-SFTP/Makefile
index 54e202ac76f4..b86ca556fe3c 100644
--- a/net/p5-Net-SFTP/Makefile
+++ b/net/p5-Net-SFTP/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl5 module implementing Secure File Transfer Protocol client
-BUILD_DEPENDS= ${SITE_PERL}/Net/SSH/Perl.pm:${PORTSDIR}/net/p5-Net-SSH-Perl
+BUILD_DEPENDS= p5-Net-SSH-Perl>=0:${PORTSDIR}/net/p5-Net-SSH-Perl
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net/p5-Net-Traceroute-PurePerl/Makefile b/net/p5-Net-Traceroute-PurePerl/Makefile
index 144bdd72f359..c920aac61106 100644
--- a/net/p5-Net-Traceroute-PurePerl/Makefile
+++ b/net/p5-Net-Traceroute-PurePerl/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Traceroute(1) functionality in perl via raw sockets
-BUILD_DEPENDS= ${SITE_PERL}/Net/Traceroute.pm:${PORTSDIR}/net/p5-Net-Traceroute
+BUILD_DEPENDS= p5-Net-Traceroute>=0:${PORTSDIR}/net/p5-Net-Traceroute
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= YES
diff --git a/net/p5-SOAP/Makefile b/net/p5-SOAP/Makefile
index 2aca2177236f..83856ac52882 100644
--- a/net/p5-SOAP/Makefile
+++ b/net/p5-SOAP/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl modules providing an API to the Simple Object Access Protocol
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
- ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
CONFLICTS= p5-SOAP-Lite-[0-9]*
diff --git a/net/p5-URI-OpenURL/Makefile b/net/p5-URI-OpenURL/Makefile
index deb0151878b8..7bd4e62610fc 100644
--- a/net/p5-URI-OpenURL/Makefile
+++ b/net/p5-URI-OpenURL/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Parse and construct OpenURL's (NISO Z39.88-2004)
-BUILD_DEPENDS= ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI
RUN_DEPENDS+= ${BUILD_DEPENDS}
MAN3= URI::OpenURL.3