aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/pidgin-musictracker/Makefile2
-rw-r--r--deskutils/gnome-main-menu/Makefile9
-rw-r--r--deskutils/libopensync-plugin-evolution2/Makefile7
-rw-r--r--deskutils/tomboy-plugin-latex/Makefile8
-rw-r--r--deskutils/tomboy-plugin-reminder/Makefile8
-rw-r--r--devel/glade2/Makefile3
-rw-r--r--devel/libglade-java/Makefile2
-rw-r--r--devel/monodevelop-database/Makefile9
-rw-r--r--games/gbrainy/Makefile3
-rw-r--r--games/opencity/Makefile2
-rw-r--r--misc/xmonad-log-applet/Makefile8
-rw-r--r--multimedia/gnome-subtitles/Makefile2
-rw-r--r--multimedia/imagination/Makefile2
-rw-r--r--net-im/pidgin-fetion/Makefile8
-rw-r--r--net-im/pidgin-guifications/Makefile3
-rw-r--r--net-im/pidgin-privacy-please/Makefile2
-rw-r--r--net-im/telepathy-haze/Makefile2
-rw-r--r--net/remmina-applet/Makefile2
-rw-r--r--palm/gnome-pilot-conduits/Makefile3
-rw-r--r--print/lilypond-devel/Makefile5
-rw-r--r--x11/gnome-swallow/Makefile8
21 files changed, 30 insertions, 68 deletions
diff --git a/audio/pidgin-musictracker/Makefile b/audio/pidgin-musictracker/Makefile
index 2a02a7713d30..be7be80812de 100644
--- a/audio/pidgin-musictracker/Makefile
+++ b/audio/pidgin-musictracker/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
USE_BZIP2= yes
-USES= gmake
+USES= gmake pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include -Wno-return-type
diff --git a/deskutils/gnome-main-menu/Makefile b/deskutils/gnome-main-menu/Makefile
index b7fc99622979..ddabf0ba1725 100644
--- a/deskutils/gnome-main-menu/Makefile
+++ b/deskutils/gnome-main-menu/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gnome-main-menu
-# Date created: 06 July 2008
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= gnome-main-menu
PORTVERSION= 0.9.12
@@ -20,8 +16,7 @@ LIB_DEPENDS= gtop-2.0.7:${PORTSDIR}/devel/libgtop
USE_BZIP2= yes
USE_GNOME= gnomehack gnomeprefix gnomepanel intlhack eel2 gnomedesktop \
libgnomeui
-USE_GMAKE= yes
-USES= gettext
+USES= gettext gmake pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="`pkg-config --libs libgnomeui-2.0`"
CPPFLAGS+= -I${LOCALBASE}/include `pkg-config --cflags libgnomeui-2.0`
diff --git a/deskutils/libopensync-plugin-evolution2/Makefile b/deskutils/libopensync-plugin-evolution2/Makefile
index 150bb9d489c3..daf846618753 100644
--- a/deskutils/libopensync-plugin-evolution2/Makefile
+++ b/deskutils/libopensync-plugin-evolution2/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libopensync-plugin-evolution2
-# Date created: 18 July 2008
-# Whom: Alexander Logvinov <ports@logvinov.com>
-#
+# Created by: Alexander Logvinov <ports@logvinov.com>
# $FreeBSD$
-#
PORTNAME= libopensync-plugin-evolution2
PORTVERSION= 0.22
@@ -20,6 +16,7 @@ CONFLICTS= libopensync-plugin-evolution2-devel-[0-9]*
USE_BZIP2= yes
GNU_CONFIGURE= yes
+USES= pkgconfig
USE_GNOME= evolutiondataserver gconf2
.include <bsd.port.mk>
diff --git a/deskutils/tomboy-plugin-latex/Makefile b/deskutils/tomboy-plugin-latex/Makefile
index 51d39b298bf5..79eb8e28e9ad 100644
--- a/deskutils/tomboy-plugin-latex/Makefile
+++ b/deskutils/tomboy-plugin-latex/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tomboy-plugin-latex
-# Date created: 2008-12-21
-# Whom: Romain Tartiere <romain@blogreen.org>
-#
+# Created by: Romain Tartiere <romain@blogreen.org>
# $FreeBSD$
-#
PORTNAME= tomboy-plugin-latex
PORTVERSION= 0.6
@@ -19,7 +15,7 @@ BUILD_DEPENDS= tomboy:${PORTSDIR}/deskutils/tomboy
RUN_DEPENDS= tomboy:${PORTSDIR}/deskutils/tomboy
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_TEX= latex
.include <bsd.port.mk>
diff --git a/deskutils/tomboy-plugin-reminder/Makefile b/deskutils/tomboy-plugin-reminder/Makefile
index e5a23c3f1219..7fcc01e3b76a 100644
--- a/deskutils/tomboy-plugin-reminder/Makefile
+++ b/deskutils/tomboy-plugin-reminder/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tomboy-plugin-reminder
-# Date created: 2008-12-21
-# Whom: Romain Tartiere <romain@blogreen.org>
-#
+# Created by: Romain Tartiere <romain@blogreen.org>
# $FreeBSD$
-#
PORTNAME= tomboy-plugin-reminder
PORTVERSION= 0.9.2
@@ -19,6 +15,6 @@ BUILD_DEPENDS= tomboy:${PORTSDIR}/deskutils/tomboy
RUN_DEPENDS= tomboy:${PORTSDIR}/deskutils/tomboy
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
.include <bsd.port.mk>
diff --git a/devel/glade2/Makefile b/devel/glade2/Makefile
index 1119c3614250..35da7e8742ea 100644
--- a/devel/glade2/Makefile
+++ b/devel/glade2/Makefile
@@ -18,9 +18,8 @@ LIB_DEPENDS= rarian.0:${PORTSDIR}/textproc/rarian
USE_BZIP2= yes
INSTALLS_OMF= yes
GNU_CONFIGURE= yes
-USES= pathfix gettext
+USES= pathfix gettext gmake pkgconfig
USE_GNOME= gnomeprefix intlhack gtk20 desktopfileutils
-USE_GMAKE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/devel/libglade-java/Makefile b/devel/libglade-java/Makefile
index d721badfa937..14b630712547 100644
--- a/devel/libglade-java/Makefile
+++ b/devel/libglade-java/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= ${JAVALIBDIR}/gtk${GTK_API_VERSION}.jar:${PORTSDIR}/x11-toolkits/li
${JAVALIBDIR}/gnome${GNOME_API_VERSION}.jar:${PORTSDIR}/x11/libgnome-java
USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_JAVA= yes
diff --git a/devel/monodevelop-database/Makefile b/devel/monodevelop-database/Makefile
index 30b2ca7ecd17..af8281d4f252 100644
--- a/devel/monodevelop-database/Makefile
+++ b/devel/monodevelop-database/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: monodevelop-database
-# Date created: 2008-03-02
-# Whom: Romain Tartiere <romain@blogreen.org>
-#
+# Created by: Romain Tartiere <romain@blogreen.org>
# $FreeBSD$
-#
PORTNAME= monodevelop-database
PORTVERSION= 3.0.2
@@ -19,8 +15,7 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/monodevelop.pc:${PORTSDIR}/devel/mon
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USES= gettext
+USES= gettext gmake pkgconfig
USE_GNOME= gnomehack gtksharp20
post-patch:
diff --git a/games/gbrainy/Makefile b/games/gbrainy/Makefile
index 75f46dda372b..0da23ce98653 100644
--- a/games/gbrainy/Makefile
+++ b/games/gbrainy/Makefile
@@ -17,8 +17,7 @@ BUILD_DEPENDS= mautil:${PORTSDIR}/devel/mono-addins \
RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_GNOME= desktopfileutils gnomehack gtksharp20 gnomesharp20
-USE_GMAKE= yes
-USES= gettext
+USES= gettext gmake pkgconfig
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/games/opencity/Makefile b/games/opencity/Makefile
index 36a4d2ee07d7..ee5c7160b267 100644
--- a/games/opencity/Makefile
+++ b/games/opencity/Makefile
@@ -13,7 +13,7 @@ COMMENT= Free 3D city simulator
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_SDL= sdl mixer image net
USE_GL= gl glu
USE_GCC= any
diff --git a/misc/xmonad-log-applet/Makefile b/misc/xmonad-log-applet/Makefile
index ae399c4aa190..91c3317b1f80 100644
--- a/misc/xmonad-log-applet/Makefile
+++ b/misc/xmonad-log-applet/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xmonad-log-applet
-# Date created: 01 September 2011
-# Whom: Alexander Kojevnikov <alexander@kojevnikov.com>
-#
+# Created by: Alexander Kojevnikov <alexander@kojevnikov.com>
# $FreeBSD$
-#
PORTNAME= xmonad-log-applet
PORTVERSION= 2.0.0
@@ -15,7 +11,7 @@ MAINTAINER= alexander@kojevnikov.com
COMMENT= An applet that will display Xmonad log information
INSTALLS_ICONS= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_GNOME= gnomeprefix gnomehack gnomepanel
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-panel=gnome2
diff --git a/multimedia/gnome-subtitles/Makefile b/multimedia/gnome-subtitles/Makefile
index d0157408ae4f..c9fcf0f70391 100644
--- a/multimedia/gnome-subtitles/Makefile
+++ b/multimedia/gnome-subtitles/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= enchant.1:${PORTSDIR}/textproc/enchant \
BUILD_DEPENDS= mono:${PORTSDIR}/lang/mono
RUN_DEPENDS= mono:${PORTSDIR}/lang/mono
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_GNOME= gnomeprefix gtksharp20 gnomesharp20 gnomedocutils
USE_GSTREAMER= yes
GNU_CONFIGURE= yes
diff --git a/multimedia/imagination/Makefile b/multimedia/imagination/Makefile
index c656d3c90b7b..e8299826e303 100644
--- a/multimedia/imagination/Makefile
+++ b/multimedia/imagination/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/gtk-2.0:${PORTSDIR}/x11-toolkits/gtk20 \
RUN_DEPENDS= ${LOCALBASE}/bin/ffmpeg:${PORTSDIR}/multimedia/ffmpeg
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
INSTALLS_ICONS= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/net-im/pidgin-fetion/Makefile b/net-im/pidgin-fetion/Makefile
index ee2730f675b2..0e51d4ac7d18 100644
--- a/net-im/pidgin-fetion/Makefile
+++ b/net-im/pidgin-fetion/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pidgin-fetion
-# Date created: 17 October 2008
-# Whom: Alexander Logvinov <ports@logvinov.com>
-#
+# Created by: Alexander Logvinov <ports@logvinov.com>
# $FreeBSD$
-#
PORTNAME= fetion
PORTVERSION= 0.98.5.2
@@ -18,9 +14,9 @@ COMMENT= Fetion protocol plugin for libpurple
LIB_DEPENDS= purple.10:${PORTSDIR}/net-im/libpurple
-
USE_BZIP2= yes
GNU_CONFIGURE= yes
+USES= pkgconfig
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/net-im/pidgin-guifications/Makefile b/net-im/pidgin-guifications/Makefile
index edb50afbfc43..913743d543c8 100644
--- a/net-im/pidgin-guifications/Makefile
+++ b/net-im/pidgin-guifications/Makefile
@@ -14,8 +14,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/pidgin/pidgin.h:${PORTSDIR}/net-im/pidgin
RUN_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
USE_BZIP2= yes
-USE_GMAKE= yes
-USES= pathfix gettext
+USES= pathfix gettext gmake pkgconfig
USE_GNOME= gnomeprefix gtk20
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
diff --git a/net-im/pidgin-privacy-please/Makefile b/net-im/pidgin-privacy-please/Makefile
index 6c0f29b5db1d..3f71949324ef 100644
--- a/net-im/pidgin-privacy-please/Makefile
+++ b/net-im/pidgin-privacy-please/Makefile
@@ -17,7 +17,7 @@ BUILD_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
RUN_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
GNU_CONFIGURE= yes
-USES= gettext gmake
+USES= gettext gmake pkgconfig
USE_GNOME= gtk20
USE_LDCONFIG= ${PREFIX}/lib/pidgin
diff --git a/net-im/telepathy-haze/Makefile b/net-im/telepathy-haze/Makefile
index 8fe65715d488..a310db8d933d 100644
--- a/net-im/telepathy-haze/Makefile
+++ b/net-im/telepathy-haze/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= purple:${PORTSDIR}/net-im/libpurple \
CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
MAN8= telepathy-haze.8
diff --git a/net/remmina-applet/Makefile b/net/remmina-applet/Makefile
index 68d49b449200..4a41a64141a1 100644
--- a/net/remmina-applet/Makefile
+++ b/net/remmina-applet/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= remmina:${PORTSDIR}/net/remmina
OPTIONS_DEFINE= AVAHI
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_GNOME= gnomehack glib20 gtk20 gnomepanel
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/palm/gnome-pilot-conduits/Makefile b/palm/gnome-pilot-conduits/Makefile
index 6dd53b4f35d2..f35f8e5a938b 100644
--- a/palm/gnome-pilot-conduits/Makefile
+++ b/palm/gnome-pilot-conduits/Makefile
@@ -15,8 +15,7 @@ COMMENT= Additional conduits for gnome-pilot
LIB_DEPENDS= gpilotd.2:${PORTSDIR}/palm/gnome-pilot
USE_BZIP2= yes
-USE_GMAKE= yes
-USES= bison pathfix gettext
+USES= bison pathfix gettext gmake pkgconfig
USE_GNOME= gnomeprefix libgnome
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-pisock=${LOCALBASE}
diff --git a/print/lilypond-devel/Makefile b/print/lilypond-devel/Makefile
index dc3e95d21a19..05cbfb73d8d0 100644
--- a/print/lilypond-devel/Makefile
+++ b/print/lilypond-devel/Makefile
@@ -43,11 +43,10 @@ INFO= lilypond-notation \
music-glossary \
internals
-USES= bison gettext
-USE_GMAKE= yes
+USES= bison gettext gmake pkgconfig perl5
USE_GHOSTSCRIPT=9
USE_PYTHON= yes
-USE_PERL5_BUILD=yes
+USE_PERL5= build
USE_TEX= latex
USE_GNOME= pango
diff --git a/x11/gnome-swallow/Makefile b/x11/gnome-swallow/Makefile
index f32811ab5115..cbadb9f36efa 100644
--- a/x11/gnome-swallow/Makefile
+++ b/x11/gnome-swallow/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gnome-swallow
-# Date created: 16 April 2003
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= gnome-swallow
PORTVERSION= 1.2
@@ -15,7 +11,7 @@ MAINTAINER= marcus@FreeBSD.org
COMMENT= Applet that swallows any X11 application into the GNOME 2 panel
USE_XORG= x11
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_GNOME= gnomeprefix gnomehack gnomepanel libgnomeui
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="`pkg-config --libs libgnomeui-2.0`"