aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/xmps-opendivx-plugin/Makefile33
-rw-r--r--graphics/xmps-opendivx-plugin/distinfo1
-rw-r--r--graphics/xmps-opendivx-plugin/pkg-comment1
-rw-r--r--graphics/xmps-opendivx-plugin/pkg-descr16
-rw-r--r--graphics/xmps-opendivx-plugin/pkg-plist2
-rw-r--r--multimedia/xmps-opendivx-plugin/Makefile33
-rw-r--r--multimedia/xmps-opendivx-plugin/distinfo1
-rw-r--r--multimedia/xmps-opendivx-plugin/pkg-comment1
-rw-r--r--multimedia/xmps-opendivx-plugin/pkg-descr16
-rw-r--r--multimedia/xmps-opendivx-plugin/pkg-plist2
11 files changed, 107 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 69bc9b504909..ca9a4be3b050 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -235,6 +235,7 @@
SUBDIR += xmountains
SUBDIR += xmovie
SUBDIR += xmps
+ SUBDIR += xmps-opendivx-plugin
SUBDIR += xmrm
SUBDIR += xpaint
SUBDIR += xpdf
diff --git a/graphics/xmps-opendivx-plugin/Makefile b/graphics/xmps-opendivx-plugin/Makefile
new file mode 100644
index 000000000000..6dff6e4099bb
--- /dev/null
+++ b/graphics/xmps-opendivx-plugin/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: xmps-opendivx-plugin
+# Date created: 03 Feb 20001
+# Whom: Mario S F Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmps-opendivx-plugin
+PORTVERSION= 0.0.1
+CATEGORIES= graphics
+MASTER_SITES= http://download.projectmayo.com/dnload/divx4linux/xmps/
+
+MAINTAINER= lioux@FreeBSD.org
+
+LIB_DEPENDS= divxdecore.0:${PORTSDIR}/graphics/libdivxdecore \
+ xmps.0:${PORTSDIR}/graphics/xmps \
+ intl.1:${PORTSDIR}/devel/gettext
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-0.0.2
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+USE_GTK= yes
+USE_X_PREFIX= yes
+INSTALLS_SHLIB= yes
+PLIST_SUB= LIB_VERSION="${LIB_VERSION}"
+
+LIB_VERSION= 0
+
+post-install:
+ @${LN} -sf libopendivx.so ${PREFIX}/lib/xmps/codecs/video/libopendivx.so.${LIB_VERSION}
+
+.include <bsd.port.mk>
diff --git a/graphics/xmps-opendivx-plugin/distinfo b/graphics/xmps-opendivx-plugin/distinfo
new file mode 100644
index 000000000000..3805ff9c4dcd
--- /dev/null
+++ b/graphics/xmps-opendivx-plugin/distinfo
@@ -0,0 +1 @@
+MD5 (xmps-opendivx-plugin-0.0.1.tar.gz) = 240fd72b9a2e1c5171dd01c528ca4c77
diff --git a/graphics/xmps-opendivx-plugin/pkg-comment b/graphics/xmps-opendivx-plugin/pkg-comment
new file mode 100644
index 000000000000..a2847037d674
--- /dev/null
+++ b/graphics/xmps-opendivx-plugin/pkg-comment
@@ -0,0 +1 @@
+xmps plugin using OpenDivX decoding engine from Project Mayo
diff --git a/graphics/xmps-opendivx-plugin/pkg-descr b/graphics/xmps-opendivx-plugin/pkg-descr
new file mode 100644
index 000000000000..44e591e5b221
--- /dev/null
+++ b/graphics/xmps-opendivx-plugin/pkg-descr
@@ -0,0 +1,16 @@
+xmps plugin using the Decore engine
+
+Decore [excerpt from OpenDivX Project Mayo site]
+
+"Decore" is our decoder core - that part of the codec that decodes
+video from DivX video bitstream into uncompressed RGB bitmaps. Its
+API is defined in decore.h. The API is another frame-in, frame-out
+scheme, you give it a chunk of OpenDivX bitstream and it comes back
+to you with an uncompressed RGB frame. Like "encore", "decore" is
+truly independent of any other code, making no system calls.
+
+"Decore" is a decoder compliant with MPEG-4 natural video, simple
+profile. It also incorporates a video postprocessor which postprocessor,
+which hides many of the artifacts inherent in low bit-rate video.
+
+WWW: http://www.projectmayo.com/linux/xmps/
diff --git a/graphics/xmps-opendivx-plugin/pkg-plist b/graphics/xmps-opendivx-plugin/pkg-plist
new file mode 100644
index 000000000000..4e8b51bf57bb
--- /dev/null
+++ b/graphics/xmps-opendivx-plugin/pkg-plist
@@ -0,0 +1,2 @@
+lib/xmps/codecs/video/libopendivx.so
+lib/xmps/codecs/video/libopendivx.so.%%LIB_VERSION%%
diff --git a/multimedia/xmps-opendivx-plugin/Makefile b/multimedia/xmps-opendivx-plugin/Makefile
new file mode 100644
index 000000000000..6dff6e4099bb
--- /dev/null
+++ b/multimedia/xmps-opendivx-plugin/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: xmps-opendivx-plugin
+# Date created: 03 Feb 20001
+# Whom: Mario S F Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmps-opendivx-plugin
+PORTVERSION= 0.0.1
+CATEGORIES= graphics
+MASTER_SITES= http://download.projectmayo.com/dnload/divx4linux/xmps/
+
+MAINTAINER= lioux@FreeBSD.org
+
+LIB_DEPENDS= divxdecore.0:${PORTSDIR}/graphics/libdivxdecore \
+ xmps.0:${PORTSDIR}/graphics/xmps \
+ intl.1:${PORTSDIR}/devel/gettext
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-0.0.2
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+USE_GTK= yes
+USE_X_PREFIX= yes
+INSTALLS_SHLIB= yes
+PLIST_SUB= LIB_VERSION="${LIB_VERSION}"
+
+LIB_VERSION= 0
+
+post-install:
+ @${LN} -sf libopendivx.so ${PREFIX}/lib/xmps/codecs/video/libopendivx.so.${LIB_VERSION}
+
+.include <bsd.port.mk>
diff --git a/multimedia/xmps-opendivx-plugin/distinfo b/multimedia/xmps-opendivx-plugin/distinfo
new file mode 100644
index 000000000000..3805ff9c4dcd
--- /dev/null
+++ b/multimedia/xmps-opendivx-plugin/distinfo
@@ -0,0 +1 @@
+MD5 (xmps-opendivx-plugin-0.0.1.tar.gz) = 240fd72b9a2e1c5171dd01c528ca4c77
diff --git a/multimedia/xmps-opendivx-plugin/pkg-comment b/multimedia/xmps-opendivx-plugin/pkg-comment
new file mode 100644
index 000000000000..a2847037d674
--- /dev/null
+++ b/multimedia/xmps-opendivx-plugin/pkg-comment
@@ -0,0 +1 @@
+xmps plugin using OpenDivX decoding engine from Project Mayo
diff --git a/multimedia/xmps-opendivx-plugin/pkg-descr b/multimedia/xmps-opendivx-plugin/pkg-descr
new file mode 100644
index 000000000000..44e591e5b221
--- /dev/null
+++ b/multimedia/xmps-opendivx-plugin/pkg-descr
@@ -0,0 +1,16 @@
+xmps plugin using the Decore engine
+
+Decore [excerpt from OpenDivX Project Mayo site]
+
+"Decore" is our decoder core - that part of the codec that decodes
+video from DivX video bitstream into uncompressed RGB bitmaps. Its
+API is defined in decore.h. The API is another frame-in, frame-out
+scheme, you give it a chunk of OpenDivX bitstream and it comes back
+to you with an uncompressed RGB frame. Like "encore", "decore" is
+truly independent of any other code, making no system calls.
+
+"Decore" is a decoder compliant with MPEG-4 natural video, simple
+profile. It also incorporates a video postprocessor which postprocessor,
+which hides many of the artifacts inherent in low bit-rate video.
+
+WWW: http://www.projectmayo.com/linux/xmps/
diff --git a/multimedia/xmps-opendivx-plugin/pkg-plist b/multimedia/xmps-opendivx-plugin/pkg-plist
new file mode 100644
index 000000000000..4e8b51bf57bb
--- /dev/null
+++ b/multimedia/xmps-opendivx-plugin/pkg-plist
@@ -0,0 +1,2 @@
+lib/xmps/codecs/video/libopendivx.so
+lib/xmps/codecs/video/libopendivx.so.%%LIB_VERSION%%