aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/linux-alienarena/Makefile8
-rw-r--r--graphics/linux-ac3d/Makefile8
2 files changed, 10 insertions, 6 deletions
diff --git a/games/linux-alienarena/Makefile b/games/linux-alienarena/Makefile
index b0ed6f99b915..2b600bcabe44 100644
--- a/games/linux-alienarena/Makefile
+++ b/games/linux-alienarena/Makefile
@@ -18,8 +18,7 @@ EXTRACT_SUFX= .run
MAINTAINER= acm@FreeBSD.org
COMMENT= Alien Arena 2006 (Linux version)
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libGLU.so.1:${PORTSDIR}/graphics/linux_dri \
- ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12 \
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12 \
${DATADIR}/arena/default.cfg:${PORTSDIR}/games/alienarena-data
ONLY_FOR_ARCHS= i386 amd64
@@ -43,7 +42,10 @@ DESKTOP_ENTRIES="Alien Arena 2006 (Linux version)" \
.include <bsd.port.pre.mk>
.if defined(WITH_NVIDIA_GL)
-RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
+RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver \
+ ${LINUXBASE}/usr/X11R6/lib/libGLU.so.1:${PORTSDIR}/graphics/linux-libGLU
+.else
+RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGLU.so.1:${PORTSDIR}/graphics/linux_dri
.endif
.if ${ARCH} == "i386"
diff --git a/graphics/linux-ac3d/Makefile b/graphics/linux-ac3d/Makefile
index 1ef74b32a308..cfdd15e1e165 100644
--- a/graphics/linux-ac3d/Makefile
+++ b/graphics/linux-ac3d/Makefile
@@ -18,11 +18,13 @@ COMMENT= Easy to use and powerful 3D graphics modeller (trial version)
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libjpeg.so.62:${PORTSDIR}/graphics/linux-jpeg \
${LINUXBASE}/usr/lib/libpng.so.2:${PORTSDIR}/graphics/linux-png10 \
- ${LINUXBASE}/usr/lib/libtiff.so.3:${PORTSDIR}/graphics/linux-tiff \
- ${LINUXBASE}/usr/X11R6/lib/libGLU.so.1:${PORTSDIR}/graphics/linux_dri
+ ${LINUXBASE}/usr/lib/libtiff.so.3:${PORTSDIR}/graphics/linux-tiff
.ifdef(WITH_NVIDIA_GL)
-RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
+RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver \
+ ${LINUXBASE}/usr/X11R6/lib/libGLU.so.1:${PORTSDIR}/graphics/linux-libGLU
+.else
+RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGLU.so.1:${PORTSDIR}/graphics/linux_dri
.endif
RESTRICTED= no distribution permitted