aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/Makefile1
-rw-r--r--lang/python-mode.el/Makefile37
-rw-r--r--lang/python-mode.el/distinfo2
-rw-r--r--lang/python-mode.el/pkg-descr3
-rw-r--r--lang/python-mode.el/pkg-message4
-rw-r--r--lang/python-mode.el/pkg-plist9
6 files changed, 56 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 1d0ff6db8a3b..dcfb1c1607a4 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -217,6 +217,7 @@
SUBDIR += python-doc-pdf-letter
SUBDIR += python-doc-postscript-a4
SUBDIR += python-doc-postscript-letter
+ SUBDIR += python-mode.el
SUBDIR += python21
SUBDIR += python22
SUBDIR += python23
diff --git a/lang/python-mode.el/Makefile b/lang/python-mode.el/Makefile
new file mode 100644
index 000000000000..0dec65e15c44
--- /dev/null
+++ b/lang/python-mode.el/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: python-mode.el
+# Date created: 11 October 2005
+# Whom: Dario Freni <saturnero@gufi.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= python-mode.el
+PORTVERSION= 1.0.a
+CATEGORIES= lang elisp python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=python-mode
+DISTNAME= python-mode-1.0alpha
+
+MAINTAINER= saturnero@gufi.org
+COMMENT= Emacs lisp module for the Python language
+
+NO_BUILD= yes
+
+CONFLICTS= python-2.4.[012]*
+EMACSLISPDIR= ${PREFIX}/share/emacs/site-lisp
+XEMACSLISPDIR= ${PREFIX}/lib/xemacs/site-lisp
+
+LISPFILES= python-mode.el pycomplete.el
+
+do-install:
+ ${MKDIR} ${EMACSLISPDIR}
+ ${MKDIR} ${XEMACSLISPDIR}
+ for i in ${LISPFILES}; do \
+ ${INSTALL_DATA} ${WRKSRC}/$${i} ${EMACSLISPDIR}/$${i}; \
+ ${LN} -sf ${EMACSLISPDIR}/$${i} ${XEMACSLISPDIR}; \
+ done;
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/lang/python-mode.el/distinfo b/lang/python-mode.el/distinfo
new file mode 100644
index 000000000000..f853e6c96860
--- /dev/null
+++ b/lang/python-mode.el/distinfo
@@ -0,0 +1,2 @@
+MD5 (python-mode-1.0alpha.tar.gz) = 41adbb7bc4079d9aac3323e962c1e542
+SIZE (python-mode-1.0alpha.tar.gz) = 53666
diff --git a/lang/python-mode.el/pkg-descr b/lang/python-mode.el/pkg-descr
new file mode 100644
index 000000000000..017ca0c5d24b
--- /dev/null
+++ b/lang/python-mode.el/pkg-descr
@@ -0,0 +1,3 @@
+Emacs lisp modules for the Python language.
+
+WWW: http://python-mode.sourceforge.net/
diff --git a/lang/python-mode.el/pkg-message b/lang/python-mode.el/pkg-message
new file mode 100644
index 000000000000..3f48d58f8c65
--- /dev/null
+++ b/lang/python-mode.el/pkg-message
@@ -0,0 +1,4 @@
+To use python-mode in Emacs/XEmacs, add the following lines to your ~/.emacs:
+
+(autoload 'python-mode "python-mode" "Mode for editing Python source files")
+(add-to-list 'auto-mode-alist '("\\.py" . python-mode))
diff --git a/lang/python-mode.el/pkg-plist b/lang/python-mode.el/pkg-plist
new file mode 100644
index 000000000000..ef1b6a89ea27
--- /dev/null
+++ b/lang/python-mode.el/pkg-plist
@@ -0,0 +1,9 @@
+share/emacs/site-lisp/python-mode.el
+share/emacs/site-lisp/pycomplete.el
+@exec mkdir -p %D/lib/xemacs/site-lisp
+@exec ln -sf %D/%F %D/lib/xemacs/site-lisp/python-mode.el
+@exec ln -sf %D/%F %D/lib/xemacs/site-lisp/pycomplete.el
+@unexec rm %D/lib/xemacs/site-lisp/python-mode.el 2>/dev/null || true
+@unexec rm %D/lib/xemacs/site-lisp/pycomplete.el 2>/dev/null || true
+@unexec rmdir %D/lib/xemacs/site-lisp 2>/dev/null || true
+@unexec rmdir %D/lib/xemacs 2>/dev/null || true