aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/Makefile1
-rw-r--r--games/gottet/Makefile53
-rw-r--r--games/gottet/distinfo2
-rw-r--r--games/gottet/pkg-descr3
4 files changed, 59 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index b762c80c26c3..8dbdc9691b18 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -345,6 +345,7 @@
SUBDIR += gomoku
SUBDIR += gondola
SUBDIR += goonies
+ SUBDIR += gottet
SUBDIR += gracer
SUBDIR += greed
SUBDIR += gretools
diff --git a/games/gottet/Makefile b/games/gottet/Makefile
new file mode 100644
index 000000000000..46846edd5ba5
--- /dev/null
+++ b/games/gottet/Makefile
@@ -0,0 +1,53 @@
+# New Ports collection makefile for: gottet
+# Date created: 21 April 2012
+# Whom: nemysis@gmx.ch
+#
+# $FreeBSD$
+#
+
+PORTNAME= gottet
+PORTVERSION= 1.0.4
+CATEGORIES= games
+MASTER_SITES= http://gottcode.org/${PORTNAME}/
+EXTRACT_SUFX= -src.tar.bz2
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= A Tetris clone
+
+LICENSE= GPLv3
+
+USE_BZIP2= yes
+USE_QT_VER= 4
+QT_COMPONENTS= moc_build qmake_build rcc_build iconengines imageformats
+USE_GMAKE= yes
+MAKE_JOBS_SAFE= yes
+
+PORTDOCS= ChangeLog
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/applications/${PORTNAME}.desktop \
+ share/pixmaps/${PORTNAME}.png
+PLIST_DIRSTRY= share/applications
+
+.include <bsd.port.options.mk>
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ ${QMAKE} ${QMAKEFLAGS}
+
+do-install:
+# Executable
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+# Pixmaps and Desktop
+ ${INSTALL_DATA} ${WRKSRC}/icons/${PORTNAME}.png ${PREFIX}/share/pixmaps/
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/icons/${PORTNAME}.desktop ${PREFIX}/share/applications/
+
+# Documentation
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/gottet/distinfo b/games/gottet/distinfo
new file mode 100644
index 000000000000..a156725e0250
--- /dev/null
+++ b/games/gottet/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gottet-1.0.4-src.tar.bz2) = 7144e035b6e575eecea9920ee301487915d3866a2cb0e40622fe9e45d83cb379
+SIZE (gottet-1.0.4-src.tar.bz2) = 29121
diff --git a/games/gottet/pkg-descr b/games/gottet/pkg-descr
new file mode 100644
index 000000000000..0ee857d1b2f1
--- /dev/null
+++ b/games/gottet/pkg-descr
@@ -0,0 +1,3 @@
+Gottet is a tetris clone.
+
+WWW: http://gottcode.org/gottet/