aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--science/oof/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/science/oof/Makefile b/science/oof/Makefile
index 6cb7970f7ae2..0119351c27e1 100644
--- a/science/oof/Makefile
+++ b/science/oof/Makefile
@@ -47,6 +47,12 @@ ALL_TARGET+= oof2abaqus
PLIST_FILES+= bin/oof2abaqus
.endif
+.include <bsd.port.pre.mk>
+
+.if ${ARCH}==sparc64
+BROKEN= does not compile on ${ARCH}
+.endif
+
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/XOOF/oof ${PREFIX}/bin
@${INSTALL_PROGRAM} ${WRKSRC}/XPPM2OOF/ppm2oof ${PREFIX}/bin
@@ -54,4 +60,4 @@ do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/OOF2ABAQUS/oof2abaqus ${PREFIX}/bin
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>