aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/ricochet/Makefile16
-rw-r--r--net-im/ricochet/files/patch-ricochet.pro16
2 files changed, 21 insertions, 11 deletions
diff --git a/net-im/ricochet/Makefile b/net-im/ricochet/Makefile
index fc329ea61624..3f83cf204551 100644
--- a/net-im/ricochet/Makefile
+++ b/net-im/ricochet/Makefile
@@ -17,10 +17,6 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LIB_DEPENDS= libprotobuf.so:devel/protobuf
-OPTIONS_DEFINE= TOR
-OPTIONS_DEFAULT= TOR
-TOR_DESC= Install Tor: it is required for ${PORTNAME} to run
-
USES= compiler:c++11-lib gmake pkgconfig qmake ssl
USE_GITHUB= yes
GH_ACCOUNT= ricochet-im
@@ -29,17 +25,19 @@ USE_QT5= core gui multimedia network qml quick quickcontrols widgets \
USE_GL= gl
QMAKE_ARGS+= DEFINES+=RICOCHET_NO_PORTABLE OPENSSLDIR=${OPENSSLBASE}
+OPTIONS_DEFINE= TOR
+OPTIONS_DEFAULT= TOR
+TOR_DESC= Install Tor: it is required for ${PORTNAME} to run
+
+TOR_RUN_DEPENDS= tor:security/tor
+
PLIST_FILES= bin/ricochet \
share/applications/ricochet.desktop \
share/icons/hicolor/48x48/apps/ricochet.png \
share/icons/hicolor/scalable/apps/ricochet.svg
-TOR_RUN_DEPENDS= tor:security/tor
-
-.include <bsd.port.pre.mk>
-
post-patch:
@${REINPLACE_CMD} -E 's| -fsanitize=[a-z-]+| |g' \
${WRKSRC}/hardened.pri
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-im/ricochet/files/patch-ricochet.pro b/net-im/ricochet/files/patch-ricochet.pro
index dcd1476601a0..95e60a660f0d 100644
--- a/net-im/ricochet/files/patch-ricochet.pro
+++ b/net-im/ricochet/files/patch-ricochet.pro
@@ -1,6 +1,6 @@
---- ricochet.pro.orig 2015-06-17 04:00:47 UTC
+--- ricochet.pro.orig 2016-11-04 22:05:33 UTC
+++ ricochet.pro
-@@ -46,18 +46,18 @@ CONFIG(release,debug|release):DEFINES +=
+@@ -52,18 +52,18 @@ CONFIG(release,debug|release):DEFINES +=
contains(DEFINES, RICOCHET_NO_PORTABLE) {
unix:!macx {
@@ -24,3 +24,15 @@
bundletor.files = tor/*
INSTALLS += bundletor
DEFINES += BUNDLED_TOR_PATH=\\\"/usr/lib/ricochet/tor/\\\"
+@@ -108,7 +108,10 @@ INCLUDEPATH += src
+
+ unix {
+ !isEmpty(OPENSSLDIR) {
+- INCLUDEPATH += $${OPENSSLDIR}/include
++ !equals(OPENSSLDIR, "/usr") {
++ # adding /usr/include to INCLUDEPATH breaks STL's include logic
++ INCLUDEPATH += $${OPENSSLDIR}/include
++ }
+ LIBS += -L$${OPENSSLDIR}/lib -lcrypto
+ } else:macx:!packagesExist(libcrypto) {
+ # Fall back to the OS-provided 0.9.8 if no other libcrypto is present