aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/autocd/Makefile4
-rw-r--r--audio/baudline/Makefile8
-rw-r--r--audio/boodler/Makefile2
-rw-r--r--audio/cmp3/Makefile4
-rw-r--r--audio/cutmp3/Makefile4
-rw-r--r--audio/cymbaline/Makefile10
-rw-r--r--audio/eawpats/Makefile4
-rw-r--r--audio/enscribe/Makefile4
-rw-r--r--audio/ezstream/Makefile2
-rw-r--r--audio/fapg/Makefile4
-rw-r--r--audio/fcplay/Makefile4
-rw-r--r--audio/fdmf/Makefile4
-rw-r--r--audio/festival-freebsoft-utils/Makefile4
-rw-r--r--audio/firefly/Makefile2
-rw-r--r--audio/flite/Makefile4
-rw-r--r--audio/gervill/Makefile6
-rw-r--r--audio/id3mtag/Makefile4
-rw-r--r--audio/ksmp3play/Makefile4
-rw-r--r--audio/lame/Makefile2
-rw-r--r--audio/liboggz/Makefile4
-rw-r--r--audio/linux-mbrola/Makefile7
-rw-r--r--audio/linux-neroaaccodec/Makefile4
-rw-r--r--audio/liquidsoap/Makefile6
-rw-r--r--audio/listener/Makefile4
-rw-r--r--audio/maplay/Makefile4
-rw-r--r--audio/mp3riot/Makefile13
-rw-r--r--audio/napster/Makefile4
-rw-r--r--audio/py-eyed3/Makefile4
-rw-r--r--audio/py-mpd/Makefile4
-rw-r--r--audio/py-openal/Makefile4
-rw-r--r--audio/py-pyliblo/Makefile4
-rw-r--r--audio/raproxy/Makefile4
-rw-r--r--audio/ruby-taglib/Makefile4
-rw-r--r--audio/shairport/Makefile4
-rw-r--r--audio/spiralloops/Makefile4
-rw-r--r--audio/spiralsynth/Makefile6
-rw-r--r--audio/streamtranscoder/Makefile4
-rw-r--r--audio/teamspeak_client/Makefile4
-rw-r--r--audio/timidity++/Makefile2
-rw-r--r--audio/toolame/Makefile4
-rw-r--r--audio/tuxguitar/Makefile2
-rw-r--r--audio/voipong/Makefile3
-rw-r--r--audio/vsound/Makefile4
-rw-r--r--audio/wmix/Makefile4
-rw-r--r--audio/wmsmixer/Makefile4
-rw-r--r--audio/xmms-crossfade/Makefile16
-rw-r--r--audio/xmms2-scrobbler/Makefile4
-rw-r--r--audio/xwave/Makefile4
48 files changed, 142 insertions, 77 deletions
diff --git a/audio/autocd/Makefile b/audio/autocd/Makefile
index ba317732df55..65bbf6d59657 100644
--- a/audio/autocd/Makefile
+++ b/audio/autocd/Makefile
@@ -20,8 +20,10 @@ PORTDOCS= README.rus.html
USE_RC_SUBR= autocd
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
.endif
diff --git a/audio/baudline/Makefile b/audio/baudline/Makefile
index 03e3ccca4d9c..25f7773fe096 100644
--- a/audio/baudline/Makefile
+++ b/audio/baudline/Makefile
@@ -27,13 +27,11 @@ PLIST_FILES= bin/baudline
OPTIONS_DEFINE= MPG123
OPTIONS_DEFAULT= MPG123
+MMPG123_RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
+
.include <bsd.port.options.mk>
.include <bsd.port.pre.mk>
-.if ${PORT_OPTIONS:MMPG123}
-RUN_DEPENDS+= mpg123:${PORTSDIR}/audio/mpg123
-.endif
-
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
IGNORE= may not be automatically fetched due to licensing\
restrictions. You must manually fetch ${DISTFILES} from\
@@ -47,7 +45,7 @@ do-build:
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/baudline ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${INSTALL} -d ${DOCSDIR}
@cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
.endif
diff --git a/audio/boodler/Makefile b/audio/boodler/Makefile
index b756bb256e2a..1a2e46271bf5 100644
--- a/audio/boodler/Makefile
+++ b/audio/boodler/Makefile
@@ -61,7 +61,7 @@ do-install:
@${CHMOD} -R u+w,a+r,og-w ${WRKDIR}/boodler-snd
@${FIND} ${WRKDIR}/boodler-snd -type d -print0 | ${XARGS} -0 ${CHMOD} 755
@cd ${WRKDIR} && ${CP} -pPR boodler/boodle boodler/effects boodler-snd ${BHOME}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}
.endif
diff --git a/audio/cmp3/Makefile b/audio/cmp3/Makefile
index 235b6e7c770b..9450c14ed2fd 100644
--- a/audio/cmp3/Makefile
+++ b/audio/cmp3/Makefile
@@ -28,8 +28,10 @@ PLIST_FILES= bin/cmp3 bin/rnmp3
RUN_DEPENDS+= ogg123:${PORTSDIR}/audio/vorbis-tools
.endif
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for docs in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
diff --git a/audio/cutmp3/Makefile b/audio/cutmp3/Makefile
index e54c20153a20..5d6e4f7bf878 100644
--- a/audio/cutmp3/Makefile
+++ b/audio/cutmp3/Makefile
@@ -19,11 +19,13 @@ PLIST_FILES= bin/cutmp3
PORTDOCS= README README.timetable USAGE
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|gcc|${CC}|g' ${WRKSRC}/Makefile
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
.endif
diff --git a/audio/cymbaline/Makefile b/audio/cymbaline/Makefile
index e74acc816c48..cf0af30bf806 100644
--- a/audio/cymbaline/Makefile
+++ b/audio/cymbaline/Makefile
@@ -16,19 +16,21 @@ NO_STAGE= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-.if !defined(NOPORTDOCS)
+PLIST_FILES= bin/cymbaline
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= *
.endif
-PLIST_FILES= bin/cymbaline
-
post-install:
@${MV} -f ${PREFIX}/bin/cymbaline.py ${PREFIX}/bin/cymbaline
@${FIND} ${PYTHON_SITELIBDIR}/cypack ! -type d | \
${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
@${FIND} ${PYTHON_SITELIBDIR}/cypack -type d | ${SORT} -r | \
${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
diff --git a/audio/eawpats/Makefile b/audio/eawpats/Makefile
index 34833b0b864a..550c0e527611 100644
--- a/audio/eawpats/Makefile
+++ b/audio/eawpats/Makefile
@@ -23,6 +23,8 @@ DOC_SUBDIRS= ethnic gsdrum08 gsdrum25 gsdrum40 power wime
WRKSRC= ${WRKDIR}/${PORTNAME}
TIMIDITY_DATADIR= ${PREFIX}/share/timidity
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|/home/user/eawpats|${DATADIR}|' ${WRKSRC}/linuxconfig/timidity.cfg
@@ -37,7 +39,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/linuxconfig/timidity.cfg ${TIMIDITY_DATADIR}/timidity.cfg-eawpats
[ -f ${TIMIDITY_DATADIR}/timidity.cfg ] || \
${INSTALL_DATA} ${WRKSRC}/linuxconfig/timidity.cfg ${TIMIDITY_DATADIR}/timidity.cfg
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/*.txt ${WRKSRC}/*.hlp ${DOCSDIR}
.for subdir in ${DOC_SUBDIRS}
diff --git a/audio/enscribe/Makefile b/audio/enscribe/Makefile
index f2c64dab3051..b17f02d4b584 100644
--- a/audio/enscribe/Makefile
+++ b/audio/enscribe/Makefile
@@ -25,6 +25,8 @@ LICENSE= GPLv2
PORTDOCS= README
PLIST_FILES= bin/enscribe
+.include <bsd.port.options.mk>
+
do-build:
cd ${BUILD_WRKSRC}; ${CC} ${CFLAGS} \
`pkg-config --cflags --libs sndfile freetype2` \
@@ -34,7 +36,7 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/enscribe ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
diff --git a/audio/ezstream/Makefile b/audio/ezstream/Makefile
index 4be9f3eb7ef1..92a50e0b66e3 100644
--- a/audio/ezstream/Makefile
+++ b/audio/ezstream/Makefile
@@ -50,7 +50,7 @@ post-patch:
s|: install-dist_docDATA|:|g' ${WRKSRC}/Makefile.in
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}/
.for file in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}/
diff --git a/audio/fapg/Makefile b/audio/fapg/Makefile
index c5e7850f9d05..0810a93f26ee 100644
--- a/audio/fapg/Makefile
+++ b/audio/fapg/Makefile
@@ -16,6 +16,8 @@ NO_STAGE= yes
MAN1= fapg.1
+.include <bsd.port.options.mk>
+
do-build:
@cd ${WRKSRC} && ${MAKE} ${PORTNAME}
@@ -24,7 +26,7 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/fapg.1 ${MAN1PREFIX}/man/man1
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for file in COPYING README
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
diff --git a/audio/fcplay/Makefile b/audio/fcplay/Makefile
index 46a3f06a176e..1b3938e2e121 100644
--- a/audio/fcplay/Makefile
+++ b/audio/fcplay/Makefile
@@ -23,6 +23,8 @@ CXXFLAGS+= -I${LOCALBASE}/include
PORTDOCS= ABOUT POINTER
PLIST_FILES= bin/fcplay
+.include <bsd.port.options.mk>
+
post-patch:
.for f in configure Config.h.in
@${REINPLACE_CMD} -e "s@machine/soundcard\.h@sys/soundcard\.h@g; \
@@ -32,7 +34,7 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fcplay ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
diff --git a/audio/fdmf/Makefile b/audio/fdmf/Makefile
index 8abf7529a80a..e612b62e263b 100644
--- a/audio/fdmf/Makefile
+++ b/audio/fdmf/Makefile
@@ -27,13 +27,15 @@ BINS= sonic_reducer vector_pairs
SCRS= ${PORTNAME} ${PORTNAME}_bench cleanup_dups optparam
PLIST_FILES= ${BINS:S,^,bin/,} ${SCRS:S,^,bin/,}
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -Ee '/^(CFLAGS|CC) =/s|.*||' -e 's|common/||g' ${WRKSRC}/Makefile
do-install:
@${INSTALL_PROGRAM} ${BINS:S,^,${WRKSRC}/,} ${PREFIX}/bin/
@${INSTALL_SCRIPT} ${SCRS:S,^,${WRKSRC}/,} ${PREFIX}/bin/
-.ifndef NOPORTDOCS
+.if ${PORT_OPTIONS:MDOCS}
@${INSTALL} -d ${DOCSDIR}/
@${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
.endif
diff --git a/audio/festival-freebsoft-utils/Makefile b/audio/festival-freebsoft-utils/Makefile
index 81fa29e5c6d0..a2352bd58a22 100644
--- a/audio/festival-freebsoft-utils/Makefile
+++ b/audio/festival-freebsoft-utils/Makefile
@@ -20,13 +20,15 @@ PORTDOCS= ANNOUNCE NEWS README
INFO= ${PORTNAME}
+.include <bsd.port.options.mk>
+
do-install:
${MKDIR} ${LOCALBASE}/share/festival/lib
cd ${WRKSRC} && ${INSTALL_DATA} *.scm ${LOCALBASE}/share/festival/lib
cd ${WRKSRC}/doc && ${INSTALL_MAN} ${PORTNAME}.info ${PREFIX}/${INFO_PATH}
post-install:
-.ifndef(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_MAN} ${WRKSRC}/${f} ${DOCSDIR}
diff --git a/audio/firefly/Makefile b/audio/firefly/Makefile
index 37308f9041fd..cd2ef0feb58e 100644
--- a/audio/firefly/Makefile
+++ b/audio/firefly/Makefile
@@ -67,7 +67,7 @@ post-patch:
${WRKSRC}/configure
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for i in README AUTHORS COPYING CREDITS \
ChangeLog INSTALL NEWS TODO
diff --git a/audio/flite/Makefile b/audio/flite/Makefile
index 012125382e72..ee290d59ee2e 100644
--- a/audio/flite/Makefile
+++ b/audio/flite/Makefile
@@ -21,10 +21,12 @@ MAKE_JOBS_UNSAFE= yes
CFLAGS:= ${CFLAGS:N-O:N-O[0123456789]} -O0
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|-pd|-p|g' ${WRKSRC}/main/Makefile
-.ifndef NOPORTDOCS
+.if ${PORT_OPTIONS:MDOCS}
post-install:
@${MKDIR} ${DOCSDIR}/
${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}/
diff --git a/audio/gervill/Makefile b/audio/gervill/Makefile
index 29e80ca33dd3..d70282f6e59e 100644
--- a/audio/gervill/Makefile
+++ b/audio/gervill/Makefile
@@ -21,14 +21,16 @@ JARFILE= ${PORTNAME}.jar
PLIST_FILES= %%JAVAJARDIR%%/${JARFILE}
PORTDOCS= *
-.if !defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
ALL_TARGET+= javadocs
.endif
do-install:
${MKDIR} ${JAVAJARDIR}
${INSTALL_DATA} ${WRKSRC}/${JARFILE} ${JAVAJARDIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
cd ${WRKSRC}/javadocs && ${COPYTREE_SHARE} \* ${DOCSDIR}
.endif
diff --git a/audio/id3mtag/Makefile b/audio/id3mtag/Makefile
index a7f95286e023..0189519bf5de 100644
--- a/audio/id3mtag/Makefile
+++ b/audio/id3mtag/Makefile
@@ -21,11 +21,13 @@ MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" \
PORTDOCS= *
+.include <bsd.port.options.mk>
+
do-install:
${MKDIR} ${PREFIX}/bin ${MANPREFIX}/man/man1
${INSTALL_PROGRAM} ${WRKSRC}/id3 ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/id3.man ${MANPREFIX}/man/man1/id3.1
-. if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/CHANGES ${DOCSDIR}
diff --git a/audio/ksmp3play/Makefile b/audio/ksmp3play/Makefile
index bb4194da3fc6..48df0038950f 100644
--- a/audio/ksmp3play/Makefile
+++ b/audio/ksmp3play/Makefile
@@ -23,8 +23,10 @@ MAN1= ksmp3play.1
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${TAR} -C ${WRKSRC}/doc --exclude "CVS" -cf - . | \
${TAR} -C ${DOCSDIR} --unlink -xf -
diff --git a/audio/lame/Makefile b/audio/lame/Makefile
index 33ef1bcb1d20..d19128dd169b 100644
--- a/audio/lame/Makefile
+++ b/audio/lame/Makefile
@@ -34,7 +34,7 @@ post-patch:
@${REINPLACE_CMD} -e 's,test -d \.libs || mkdir,mkdir -p,' \
${WRKSRC}/libmp3lame/i386/Makefile.in
-.if defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
do-install:
@cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} install-exec
diff --git a/audio/liboggz/Makefile b/audio/liboggz/Makefile
index e8426f9e0bee..844faaa42057 100644
--- a/audio/liboggz/Makefile
+++ b/audio/liboggz/Makefile
@@ -34,6 +34,8 @@ MAN1= oggz.1 \
oggz-validate.1 \
oggz-codecs.1
+.include <bsd.port.options.mk>
+
# First REINPLACE_CMD line makes all timestimes relative to localtime, crude hack
post-patch:
@${REINPLACE_CMD} -e 's/timezone/0/' \
@@ -41,7 +43,7 @@ post-patch:
${WRKSRC}/src/tools/oggz-chop/httpdate_test.c
@${REINPLACE_CMD} -e '/^pkgconfigdir/s!=.*!= ${PREFIX}/libdata/pkgconfig!' \
${WRKSRC}/Makefile.in
-.ifdef NOPORTDOCS
+.if ${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} -e '/^install-data-am/s!install-data-local!!' \
${WRKSRC}/doc/Makefile.in
.endif
diff --git a/audio/linux-mbrola/Makefile b/audio/linux-mbrola/Makefile
index 23a5e3cba8e9..7ae7fc7585b8 100644
--- a/audio/linux-mbrola/Makefile
+++ b/audio/linux-mbrola/Makefile
@@ -27,7 +27,10 @@ PLIST= ${WRKDIR}/plist
PLIST_DIRS= share/doc/mbrola
PLIST_FILES= bin/mbrola
-.if !defined(NOPORTDOCS)
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
PLIST_FILES+= share/doc/mbrola/readme.txt
.endif
@@ -38,7 +41,7 @@ do-extract:
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/mbrola-linux-i386 ${PREFIX}/bin/mbrola
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
.endif
diff --git a/audio/linux-neroaaccodec/Makefile b/audio/linux-neroaaccodec/Makefile
index f179280ada70..d4c88c4b6aa9 100644
--- a/audio/linux-neroaaccodec/Makefile
+++ b/audio/linux-neroaaccodec/Makefile
@@ -30,12 +30,14 @@ PORTDOCS= NeroAAC_tut.pdf \
license.txt \
readme.txt
+.include <bsd.port.options.mk>
+
do-install:
.for f in ${PLIST_FILES}
${INSTALL_PROGRAM} ${WRKSRC}/linux/${f:T} ${PREFIX}/bin
.endfor
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
diff --git a/audio/liquidsoap/Makefile b/audio/liquidsoap/Makefile
index 681178903e80..05b541b17bec 100644
--- a/audio/liquidsoap/Makefile
+++ b/audio/liquidsoap/Makefile
@@ -21,11 +21,9 @@ RUN_DEPENDS= ${LOCALBASE}/${OCAML_SITELIBDIR}/camomile/camomile.a:${PORTSDIR}/de
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
-.if !defined(NOPORTDOCS)
-BUILD_DEPENDS+= p5-XML-DOM>=0:${PORTSDIR}/textproc/p5-XML-DOM
-.endif
+DOCS_BUILD_DEPENDS= p5-XML-DOM>=0:${PORTSDIR}/textproc/p5-XML-DOM
-OPTIONS_DEFINE= AACPLUS AO CRY DSSI FAAD FESTIVAL FLAC GAVL GSTREAMER JACK LADSPA LO \
+OPTIONS_DEFINE= AACPLUS AO CRY DOCS DSSI FAAD FESTIVAL FLAC GAVL GSTREAMER JACK LADSPA LO \
MAD OGG VOAACENC VORBIS SCHROEDINGER SPEEX THEORA SAMPLERATE PULSEAUDIO \
TAGLIB WGET DOCS EXAMPLES
OPTIONS_DEFAULT= AACPLUS CRY FAAD FESTIVAL JACK MAD OGG VOAACENC VORBIS TAGLIB WGET
diff --git a/audio/listener/Makefile b/audio/listener/Makefile
index b5ee81e70f78..bc9ac9b54b03 100644
--- a/audio/listener/Makefile
+++ b/audio/listener/Makefile
@@ -18,8 +18,10 @@ PORTDOCS= manual.html
PLIST_FILES= bin/setlistener bin/listener bin/listenersoundpipe \
etc/listener.conf.sample
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
.endif
diff --git a/audio/maplay/Makefile b/audio/maplay/Makefile
index 03fc9069cd87..7089362af357 100644
--- a/audio/maplay/Makefile
+++ b/audio/maplay/Makefile
@@ -19,13 +19,15 @@ NO_STAGE= yes
PLIST_FILES= bin/maplay
PORTDOCS= README
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's,machine/soundcard.h,sys/soundcard.h,' \
${WRKSRC}/configuration.sh
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/maplay ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
.endif
diff --git a/audio/mp3riot/Makefile b/audio/mp3riot/Makefile
index d7a32bcff74f..c12c28881c41 100644
--- a/audio/mp3riot/Makefile
+++ b/audio/mp3riot/Makefile
@@ -12,7 +12,6 @@ COMMENT= Mp3riot creates mp3 playlists, HTML files, etc
RUN_DEPENDS= p5-MP3-Info>=0:${PORTSDIR}/audio/p5-MP3-Info
USES= perl5
-NO_STAGE= yes
USE_ZIP= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
@@ -20,15 +19,11 @@ NO_WRKSUBDIR= yes
PORTDOCS= example.unix groupfile CHANGELOG MANUAL mp3table.sql README repl.dat TODO utf.dat
PLIST_FILES= bin/mp3riot
-.include <bsd.port.pre.mk>
-
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/mp3riot ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/mp3riot ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for item in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${item} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${item} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/napster/Makefile b/audio/napster/Makefile
index 49eb02fe5a49..402587e65321 100644
--- a/audio/napster/Makefile
+++ b/audio/napster/Makefile
@@ -16,8 +16,10 @@ NO_STAGE= yes
MAN1= nap.1
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for file in NEWS README doc/napster.txt doc/userguide.html
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
diff --git a/audio/py-eyed3/Makefile b/audio/py-eyed3/Makefile
index b2ae289f2603..42586b5d2136 100644
--- a/audio/py-eyed3/Makefile
+++ b/audio/py-eyed3/Makefile
@@ -32,6 +32,8 @@ MANCOMPRESSED= yes
INSTALLS_EGGINFO= yes
PYDISTUTILS_PKGNAME= eyeD3
+.include <bsd.port.options.mk>
+
post-patch:
${REINPLACE_CMD} -e 's,PYTHON="",,g' -e 's,/usr/local,${LOCALBASE},g' \
-e 's,2\\\.\[23456789\]\\\.,2.[23456789],g' \
@@ -40,7 +42,7 @@ post-patch:
-e 's,\(setup.py install\),$${SETUP_COMMAND} install $${SETUP_ARGS_INSTALL} ,g' \
-e 's,^docdir:=.*,docdir:=${DOCSDIR},g' \
${WRKSRC}/Makefile.in
-.if defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${REINPLACE_CMD} -e 's,.*docdir.*,#,g' \
${WRKSRC}/Makefile.in
.endif
diff --git a/audio/py-mpd/Makefile b/audio/py-mpd/Makefile
index 32bc2d56a19a..6c5fc07fc469 100644
--- a/audio/py-mpd/Makefile
+++ b/audio/py-mpd/Makefile
@@ -18,7 +18,9 @@ NO_STAGE= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= python_mpd
-.if !defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
post-install:
diff --git a/audio/py-openal/Makefile b/audio/py-openal/Makefile
index b47f42657cef..bc8df027db8a 100644
--- a/audio/py-openal/Makefile
+++ b/audio/py-openal/Makefile
@@ -21,12 +21,14 @@ PYDISTUTILS_PKGNAME= PyOpenAL
WRKSRC= ${WRKDIR}/PyOpenAL-${PORTVERSION}
EXAMPLESDIR= ${PREFIX}/share/examples/py-openal
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/setup.py
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/demo/* ${EXAMPLESDIR}
.endif
diff --git a/audio/py-pyliblo/Makefile b/audio/py-pyliblo/Makefile
index 639524a28d7f..55b294f13482 100644
--- a/audio/py-pyliblo/Makefile
+++ b/audio/py-pyliblo/Makefile
@@ -22,6 +22,8 @@ LDFLAGS+= -L${LOCALBASE}/lib
MAN1= dump_osc.1 send_osc.1
+.include <bsd.port.options.mk>
+
post-patch:
${REINPLACE_CMD} -e 's#%%LOCALBASE%%#${LOCALBASE}#g' ${WRKSRC}/setup.py
@@ -29,7 +31,7 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/scripts/dump_osc.1 ${PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/scripts/send_osc.1 ${PREFIX}/man/man1
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/doc/API.html ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/doc/examples.html ${DOCSDIR}
diff --git a/audio/raproxy/Makefile b/audio/raproxy/Makefile
index d82cc2652a05..376ac3a78915 100644
--- a/audio/raproxy/Makefile
+++ b/audio/raproxy/Makefile
@@ -21,11 +21,13 @@ PLIST_FILES= libexec/raproxy
PORTDOCS= *
MAN8= raproxy.8
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/raproxy ${PREFIX}/libexec
${INSTALL_MAN} ${WRKSRC}/raproxy.man ${PREFIX}/man/man8/raproxy.8
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${PREFIX}/share/doc/raproxy
@${INSTALL_DATA} ${WRKSRC}/*.html ${WRKSRC}/*.pdf \
${PREFIX}/share/doc/raproxy
diff --git a/audio/ruby-taglib/Makefile b/audio/ruby-taglib/Makefile
index c6d350145ffc..7a0ad9fc670b 100644
--- a/audio/ruby-taglib/Makefile
+++ b/audio/ruby-taglib/Makefile
@@ -25,10 +25,12 @@ NO_BUILD= yes
DOCS= README
+.include <bsd.port.options.mk>
+
do-install:
${MKDIR} ${RUBY_SITELIBDIR}/
${INSTALL_DATA} ${WRKSRC}/lib/taglib.rb ${RUBY_SITELIBDIR}/
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${RUBY_MODDOCDIR}
${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${RUBY_MODDOCDIR}/
.endif
diff --git a/audio/shairport/Makefile b/audio/shairport/Makefile
index 7e1635d76e3f..a4df021a90fa 100644
--- a/audio/shairport/Makefile
+++ b/audio/shairport/Makefile
@@ -33,6 +33,8 @@ PORTDOCS= README.md
REV= b1cb9ea
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|avahi-|${LOCALBASE}/bin/avahi-|g' \
-e 's|$$FindBin.*|"${PREFIX}/bin/hairtunes";|' \
@@ -44,7 +46,7 @@ do-install:
.for file in ${PORTNAME} hairtunes
${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/bin
.endfor
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for i in ${PORTDOCS}
${INSTALL_DATA} -p ${WRKSRC}/${i} ${DOCSDIR}
diff --git a/audio/spiralloops/Makefile b/audio/spiralloops/Makefile
index dff833d3e30e..4fb28f6c9a96 100644
--- a/audio/spiralloops/Makefile
+++ b/audio/spiralloops/Makefile
@@ -42,7 +42,7 @@ post-patch:
pre-install:
${ECHO_CMD} bin/SpiralLoops > ${PLIST}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
.for i in ${DOC_FILES}
${ECHO_CMD} ${DOCDIR}/`${BASENAME} ${i}` >> ${PLIST}
.endfor
@@ -51,7 +51,7 @@ pre-install:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/SpiralLoops ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for i in ${DOC_FILES}
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
diff --git a/audio/spiralsynth/Makefile b/audio/spiralsynth/Makefile
index 8a99b6e1bd9b..e42cdca963c7 100644
--- a/audio/spiralsynth/Makefile
+++ b/audio/spiralsynth/Makefile
@@ -23,6 +23,8 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
DOC_FILES= CHANGES COPYING README
+.include <bsd.port.options.mk>
+
post-patch:
.for ii in \
Makefile.in \
@@ -66,7 +68,7 @@ pre-install:
.else
${ECHO_CMD} bin/SpiralSynth > ${PLIST}
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
.for ii in ${DOC_FILES}
${ECHO_CMD} share/doc/spiralsynth/${ii} >> ${PLIST}
.endfor
@@ -80,7 +82,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/SpiralSynth ${PREFIX}/bin
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for ii in ${DOC_FILES}
${INSTALL_DATA} ${WRKSRC}/${ii} ${DOCSDIR}
diff --git a/audio/streamtranscoder/Makefile b/audio/streamtranscoder/Makefile
index 54c9b83b8352..1ecfebb35bd9 100644
--- a/audio/streamtranscoder/Makefile
+++ b/audio/streamtranscoder/Makefile
@@ -24,6 +24,8 @@ LDFLAGS+= -L${LOCALBASE}/lib
PLIST_FILES= bin/streamTranscoder
PORTDOCS= AUTHORS README
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|-D_REENTRANT|${PTHREAD_CFLAGS}|g; \
s|-pthread|${PTHREAD_LIBS}|g; s|-O20|$$CFLAGS|g' \
@@ -33,7 +35,7 @@ post-patch:
${WRKSRC}/src/libtranscoder/transcurl.cpp
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
diff --git a/audio/teamspeak_client/Makefile b/audio/teamspeak_client/Makefile
index 59509616768f..b4a8b46c22af 100644
--- a/audio/teamspeak_client/Makefile
+++ b/audio/teamspeak_client/Makefile
@@ -36,6 +36,8 @@ DESKTOP_ENTRIES="TeamSpeak" \
"Network;Telephony;" \
false
+.include <bsd.port.options.mk>
+
post-extract:
@${MKDIR} ${WRKDIR}/programs
@${GZIP_CMD} -dc ${DISTDIR}/setduplexfake.so.gz >${WRKDIR}/programs/setduplexfake.so
@@ -62,7 +64,7 @@ do-install:
${FIND} * -type d -exec ${MKDIR} "${TSHOME}/{}" \; && \
${FIND} * -type f -exec ${INSTALL_PROGRAM} "{}" "${TSHOME}/{}" \;
${INSTALL_SCRIPT} ${WRKDIR}/TeamSpeak ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
cd ${WRKDIR}/doc && \
${FIND} * -type d -exec ${MKDIR} "${DOCSDIR}/{}" \; && \
${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DOCSDIR}/{}" \;
diff --git a/audio/timidity++/Makefile b/audio/timidity++/Makefile
index 06bf9286e08d..bb3e9166a4d3 100644
--- a/audio/timidity++/Makefile
+++ b/audio/timidity++/Makefile
@@ -80,7 +80,7 @@ post-install::
.endif # !defined(PKGNAMESUFFIX)
post-install::
-.if !defined(NOPORTDOCS) && defined(DOCFILES)
+.if ${PORT_OPTIONS:MDOCS} && defined(DOCFILES)
.for lang in ${DOCLANG}
${MKDIR} ${PREFIX}/share/doc/${lang:C,^C$,,:C,ja_.*,ja/,}timidity++
cd ${WRKSRC}/doc/${lang} && ${INSTALL_DATA} ${DOCFILES} \
diff --git a/audio/toolame/Makefile b/audio/toolame/Makefile
index 78c9afe720e7..74f03409993f 100644
--- a/audio/toolame/Makefile
+++ b/audio/toolame/Makefile
@@ -23,10 +23,10 @@ USE_CSTD= gnu89
PLIST_FILES= bin/toolame
PORTDOCS= FUTURE HISTORY LGPL.txt README
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
do-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for docs in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
diff --git a/audio/tuxguitar/Makefile b/audio/tuxguitar/Makefile
index 3f828ff72915..7667f2fd6ecd 100644
--- a/audio/tuxguitar/Makefile
+++ b/audio/tuxguitar/Makefile
@@ -113,7 +113,7 @@ do-install:
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${DOCSDIR}
.endif
diff --git a/audio/voipong/Makefile b/audio/voipong/Makefile
index ddf6570edc49..56ae82d71925 100644
--- a/audio/voipong/Makefile
+++ b/audio/voipong/Makefile
@@ -14,11 +14,12 @@ PORTDOCS= ALGORITHMS AUTHORS ChangeLog COPYING INSTALL KNOWN_BUGS \
LICENSE NEWS README THANKS TODO
NO_STAGE= yes
+.include <bsd.port.options.mk>
post-patch:
${MV} ${WRKSRC}/Makefile.bsd ${WRKSRC}/Makefile
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${MKDIR} ${DOCSDIR}/users-manual
${INSTALL_DATA} ${WRKSRC}/docs/users-manual/*.html ${DOCSDIR}/users-manual/
diff --git a/audio/vsound/Makefile b/audio/vsound/Makefile
index b18ca4fd7e97..208088328e38 100644
--- a/audio/vsound/Makefile
+++ b/audio/vsound/Makefile
@@ -16,8 +16,10 @@ NO_STAGE= yes
USE_AUTOTOOLS= libtool
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
diff --git a/audio/wmix/Makefile b/audio/wmix/Makefile
index 54896790248c..584b3656422e 100644
--- a/audio/wmix/Makefile
+++ b/audio/wmix/Makefile
@@ -19,11 +19,13 @@ MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
PORTDOCS= AUTHORS BUGS INSTALL NEWS README
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wmix ${PREFIX}/bin
post-install:
-.ifndef (NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for i in ${PORTDOCS}
@${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
diff --git a/audio/wmsmixer/Makefile b/audio/wmsmixer/Makefile
index 81f78cd610ee..0776ec908d06 100644
--- a/audio/wmsmixer/Makefile
+++ b/audio/wmsmixer/Makefile
@@ -18,9 +18,11 @@ NO_STAGE= yes
USE_XORG= xpm
MAKE_ARGS= CC="${CXX}" CFLAGS="${CXXFLAGS}"
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wmsmixer ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
diff --git a/audio/xmms-crossfade/Makefile b/audio/xmms-crossfade/Makefile
index e2b5c1cc065b..54bcf2067ba4 100644
--- a/audio/xmms-crossfade/Makefile
+++ b/audio/xmms-crossfade/Makefile
@@ -18,6 +18,7 @@ HAS_CONFIGURE= yes
USE_CSTD= gnu89
NO_STAGE= yes
USES= pkgconfig
+
APP?= xmms
.if ${APP} == bmp
PORTVERSION= 0.3.12
@@ -29,12 +30,13 @@ PLIST_FILES= ${PLUGDIR}/libcrossfade.so
DOCSDIR?= ${PREFIX}/share/doc/${UNIQUENAME}
CONFIGURE_ARGS+= --enable-player=${APP}
-.ifndef WITHOUT_SAMPLERATE
-LIB_DEPENDS+= libsamplerate.so:${PORTSDIR}/audio/libsamplerate
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS+=--enable-samplerate
-.endif
+OPTIONS_DEFINE= SAMPLERATE
+SAMPLERATE_LIB_DEPENDS= libsamplerate.so:${PORTSDIR}/audio/libsamplerate
+SAMPLERATE_CPPFLAGS= -I${LOCALBASE}/include
+SAMPLERATE_LDFLAGS= -L${LOCALBASE}/lib
+SAMPLERATE_CONFIGURE_ENABLE= samplerate
+
+.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e '/objformat=/s|aout|elf|; \
@@ -43,7 +45,7 @@ post-patch:
do-install:
@${MKDIR} ${PREFIX}/${PLUGDIR}/
${INSTALL_PROGRAM} ${WRKSRC}/.libs/libcrossfade.so ${PREFIX}/${PLUGDIR}/
-.ifndef NOPORTDOCS
+.if ${PORT_OPTIONS:MDOCS}
@${INSTALL} -d ${DOCSDIR}/
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
.endif
diff --git a/audio/xmms2-scrobbler/Makefile b/audio/xmms2-scrobbler/Makefile
index 8ceb35e928f8..9ad0bc4ff55e 100644
--- a/audio/xmms2-scrobbler/Makefile
+++ b/audio/xmms2-scrobbler/Makefile
@@ -24,11 +24,13 @@ PORTDOCS= README
SUB_FILES= pkg-message
+.include <bsd.port.options.mk>
+
post-install:
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}; \
cd ${WRKSRC} && ${INSTALL_MAN} ${PORTDOCS} ${DOCSDIR}
.endif
diff --git a/audio/xwave/Makefile b/audio/xwave/Makefile
index a277cae07ba1..85c9a04f329a 100644
--- a/audio/xwave/Makefile
+++ b/audio/xwave/Makefile
@@ -20,10 +20,12 @@ MAKE_JOBS_UNSAFE= yes
DOC_FILES= README README-XWAVE2 README.v06 INSTALL
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/xwave ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/src/XWave ${PREFIX}/lib/X11/app-defaults
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${PREFIX}/share/doc/xwave
.for i in ${DOC_FILES}
${INSTALL_MAN} ${WRKSRC}/${i} ${PREFIX}/share/doc/xwave