aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/orsa/Makefile6
-rw-r--r--audio/snd/Makefile6
-rw-r--r--cad/gmsh/Makefile3
-rw-r--r--graphics/qgis/Makefile3
-rw-r--r--mail/bogofilter/Makefile4
-rw-r--r--math/PDL/Makefile3
-rw-r--r--math/freefem++/Makefile3
-rw-r--r--math/freemat/Makefile9
-rw-r--r--math/labplot/Makefile4
-rw-r--r--math/orpie/Makefile3
-rw-r--r--math/p5-Math-GSL/Makefile4
-rw-r--r--math/pspp/Makefile3
-rw-r--r--math/py-gsl/Makefile3
-rw-r--r--math/qtiplot/Makefile4
-rw-r--r--math/yacas/Makefile3
-rw-r--r--science/getdp/Makefile3
-rw-r--r--science/gnudatalanguage/Makefile6
-rw-r--r--science/kst/Makefile3
-rw-r--r--science/kst2/Makefile3
19 files changed, 43 insertions, 33 deletions
diff --git a/astro/orsa/Makefile b/astro/orsa/Makefile
index 65db9c4861a5..645f61a3e97c 100644
--- a/astro/orsa/Makefile
+++ b/astro/orsa/Makefile
@@ -8,7 +8,7 @@
PORTNAME= orsa
PORTVERSION= 0.6.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= astro
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,7 +16,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Orbit Reconstruction, Simulation and Analysis
-LIB_DEPENDS= gsl.7:${PORTSDIR}/math/gsl \
+LIB_DEPENDS= gsl.9:${PORTSDIR}/math/gsl \
cln.4:${PORTSDIR}/math/cln \
fftw.2:${PORTSDIR}/math/fftw \
ginac-1.3.3:${PORTSDIR}/math/GiNaC
@@ -30,7 +30,7 @@ INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-BROKEN= "Does not compile on FreeBSD 4.x"
+BROKEN= does not compile on FreeBSD 4.x
.endif
.include <bsd.port.post.mk>
diff --git a/audio/snd/Makefile b/audio/snd/Makefile
index 945bede2b5b4..62e05a732f6f 100644
--- a/audio/snd/Makefile
+++ b/audio/snd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= snd
PORTVERSION= 7.8
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Multitracking sound editor and utilities
-LIB_DEPENDS= gsl.7:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.9:${PORTSDIR}/math/gsl
ALL_TARGET= audinfo snd sndinfo sndplay sndrecord sndsine
CONFIGURE_ARGS= --with-float-samples \
@@ -83,7 +83,7 @@ USE_XLIB= yes
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
-BROKEN= "Does not compile on sparc64"
+BROKEN= does not compile on sparc64
.endif
post-build:
diff --git a/cad/gmsh/Makefile b/cad/gmsh/Makefile
index ab3e1b9056a3..ac1092616616 100644
--- a/cad/gmsh/Makefile
+++ b/cad/gmsh/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gmsh
PORTVERSION= 1.64.1
+PORTREVISION= 1
CATEGORIES= cad
MASTER_SITES= http://www.geuz.org/gmsh/src/
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
@@ -16,7 +17,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= An automatic 3D finite element mesh generator
RUN_DEPENDS= getdp:${PORTSDIR}/science/getdp
-LIB_DEPENDS= gsl.7:${PORTSDIR}/math/gsl \
+LIB_DEPENDS= gsl.9:${PORTSDIR}/math/gsl \
fltk.1:${PORTSDIR}/x11-toolkits/fltk
.if defined(PACKAGE_BUILDING)
diff --git a/graphics/qgis/Makefile b/graphics/qgis/Makefile
index 792437d56514..75981469ad92 100644
--- a/graphics/qgis/Makefile
+++ b/graphics/qgis/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qgis
PORTVERSION= 0.7.4
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR=${PORTNAME}
@@ -16,7 +17,7 @@ COMMENT= A Geographical Information System (GIS) data viewer
LIB_DEPENDS= geos:${PORTSDIR}/graphics/geos \
proj:${PORTSDIR}/graphics/proj \
- gsl:${PORTSDIR}/math/gsl \
+ gsl.9:${PORTSDIR}/math/gsl \
gdal:${PORTSDIR}/graphics/gdal
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
diff --git a/mail/bogofilter/Makefile b/mail/bogofilter/Makefile
index ea674f313601..bb98da896577 100644
--- a/mail/bogofilter/Makefile
+++ b/mail/bogofilter/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bogofilter
PORTVERSION= 1.0.2
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -40,7 +40,7 @@ USE_ICONV= yes
BF_LIBS+= -liconv
.endif
.if !defined(WITHOUT_GSL)
-LIB_DEPENDS+= gsl:${PORTSDIR}/math/gsl
+LIB_DEPENDS+= gsl.9:${PORTSDIR}/math/gsl
.else
CONFIGURE_ARGS+= --with-included-gsl
.endif
diff --git a/math/PDL/Makefile b/math/PDL/Makefile
index 8c9912ec0023..47f1de9c8c43 100644
--- a/math/PDL/Makefile
+++ b/math/PDL/Makefile
@@ -8,6 +8,7 @@
PORTNAME= PDL
PORTVERSION= 2.4.2
+PORTREVISION= 1
CATEGORIES= math perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:S/$/:cpan/} \
${MASTER_SITE_SOURCEFORGE:S/$/:sf/}
@@ -27,7 +28,7 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/PGPLOT.pm:${PORTSDIR}/graphics/pgperl \
${SITE_PERL}/Term/ReadLine/readline.pm:${PORTSDIR}/devel/p5-ReadLine-Perl
LIB_DEPENDS= plplotd.10:${PORTSDIR}/math/plplot \
fftw.2:${PORTSDIR}/math/fftw \
- gsl.7:${PORTSDIR}/math/gsl
+ gsl.9:${PORTSDIR}/math/gsl
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_GL= yes
diff --git a/math/freefem++/Makefile b/math/freefem++/Makefile
index 1c87c537e4e9..95b0f1e6f0b6 100644
--- a/math/freefem++/Makefile
+++ b/math/freefem++/Makefile
@@ -7,6 +7,7 @@
PORTNAME= freefem++
PORTVERSION= 2.7
+PORTREVISION= 1
CATEGORIES= math science
MASTER_SITES= http://www.freefem.org/ff++/ftp/
@@ -15,7 +16,7 @@ COMMENT= An implementation of a language dedicated to the finite element method
LIB_DEPENDS= atlas.1:${PORTSDIR}/math/atlas \
f2c.2:${PORTSDIR}/lang/f2c \
- gsl.7:${PORTSDIR}/math/gsl \
+ gsl.9:${PORTSDIR}/math/gsl \
lapack.3:${PORTSDIR}/math/lapack \
fltk.1:${PORTSDIR}/x11-toolkits/fltk-threads \
fftw3.3:${PORTSDIR}/math/fftw3
diff --git a/math/freemat/Makefile b/math/freemat/Makefile
index 4b56e0a10faf..b76d390252f0 100644
--- a/math/freemat/Makefile
+++ b/math/freemat/Makefile
@@ -7,7 +7,7 @@
PORTNAME= freemat
PORTVERSION= 1.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math science
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,7 +20,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= An environment for rapid engineering and scientific processing
LIB_DEPENDS= f2c.2:${PORTSDIR}/lang/f2c \
- gsl.7:${PORTSDIR}/math/gsl \
+ gsl.9:${PORTSDIR}/math/gsl \
jpeg.9:${PORTSDIR}/graphics/jpeg \
lapack.3:${PORTSDIR}/math/lapack \
png.5:${PORTSDIR}/graphics/png \
@@ -29,7 +29,6 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libarpack.a:${PORTSDIR}/math/arpack \
${LOCALBASE}/lib/libumfpack.a:${PORTSDIR}/math/umfpack
USE_GL= yes
-USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-blas="${lib_blas}"
@@ -70,7 +69,7 @@ DATADIR= ${PREFIX}/share/FreeMat
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-BROKEN= "Does not compile with gcc-2.95"
+BROKEN= Does not compile with gcc-2.95
.endif
.if exists(${LOCALBASE}/bin/balky)
@@ -78,7 +77,7 @@ WITH_MPI= yes
.endif
.if defined(WITH_MPI)
. if exists(${LOCALBASE}/bin/laminfo)
-BROKEN= "does not work with net/lam7, please install net/lam"
+BROKEN= does not work with net/lam7, please install net/lam
. endif
BUILD_DEPENDS+= mpiCC:${PORTSDIR}/net/lam
RUN_DEPENDS+= lamboot:${PORTSDIR}/net/lam
diff --git a/math/labplot/Makefile b/math/labplot/Makefile
index cf44ebf8a2fa..a86ba6cc76dc 100644
--- a/math/labplot/Makefile
+++ b/math/labplot/Makefile
@@ -7,7 +7,7 @@
PORTNAME= LabPlot
PORTVERSION= 1.5.0.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=labplot
@@ -18,7 +18,7 @@ COMMENT= LabPlot : Data analysis and visualisation
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
Magick.9:${PORTSDIR}/graphics/ImageMagick \
audiofile.0:${PORTSDIR}/audio/libaudiofile \
- gsl.7:${PORTSDIR}/math/gsl \
+ gsl.9:${PORTSDIR}/math/gsl \
jasper.4:${PORTSDIR}/graphics/jasper \
fftw3.3:${PORTSDIR}/math/fftw3 \
netcdf:${PORTSDIR}/science/netcdf \
diff --git a/math/orpie/Makefile b/math/orpie/Makefile
index f3700189d636..b22b0dc4eac5 100644
--- a/math/orpie/Makefile
+++ b/math/orpie/Makefile
@@ -7,6 +7,7 @@
PORTNAME= orpie
PORTVERSION= 1.4.1
+PORTREVISION= 1
CATEGORIES+= math
MASTER_SITES= http://www.eecs.umich.edu/~pelzlpj/orpie/
@@ -14,7 +15,7 @@ MAINTAINER= dylan@dylex.net
COMMENT= A fullscreen RPN calculator for the console
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
-LIB_DEPENDS= gsl.7:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.9:${PORTSDIR}/math/gsl
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/math/p5-Math-GSL/Makefile b/math/p5-Math-GSL/Makefile
index fe4d274f586a..790be98d1417 100644
--- a/math/p5-Math-GSL/Makefile
+++ b/math/p5-Math-GSL/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Math-GSL
PORTVERSION= 0.01
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Math
@@ -16,7 +16,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= A perl interface to GNU Scientific Library
-LIB_DEPENDS= gsl.7:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.9:${PORTSDIR}/math/gsl
PERL_CONFIGURE= yes
MAKE_ENV= INC="-I${LOCALBASE}/include"
diff --git a/math/pspp/Makefile b/math/pspp/Makefile
index 858407888917..cd19b73d0273 100644
--- a/math/pspp/Makefile
+++ b/math/pspp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pspp
PORTVERSION= 0.4.0
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -29,7 +30,7 @@ INFO= pspp
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
-BROKEN= "Needs at least Perl 5.6"
+BROKEN= needs at least Perl 5.6
.endif
.include <bsd.port.post.mk>
diff --git a/math/py-gsl/Makefile b/math/py-gsl/Makefile
index adf720852e34..d5252672651e 100644
--- a/math/py-gsl/Makefile
+++ b/math/py-gsl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gsl
PORTVERSION= 0.3.2
+PORTREVISION= 1
CATEGORIES= math python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pygsl
@@ -19,7 +20,7 @@ COMMENT= Python interface to GNU Scientific Library
BUILD_DEPENDS= ${PYNUMERIC}
RUN_DEPENDS= ${PYNUMERIC}
-LIB_DEPENDS= gsl.7:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.9:${PORTSDIR}/math/gsl
PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S,^${LOCALBASE}/,,g}
USE_PYTHON= yes
diff --git a/math/qtiplot/Makefile b/math/qtiplot/Makefile
index c9cdaff2d7fe..b7b2df16be5e 100644
--- a/math/qtiplot/Makefile
+++ b/math/qtiplot/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qtiplot
PORTVERSION= 0.6.4
+PORTREVISION= 1
CATEGORIES= math science
MASTER_SITES= http://soft.proindependent.com/src/
@@ -14,12 +15,11 @@ MAINTAINER= gaoj@cpsc.ucalgary.ca
COMMENT= An Origin clone for data analysis and scientific plotting
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
-LIB_DEPENDS= gsl:${PORTSDIR}/math/gsl \
+LIB_DEPENDS= gsl.9:${PORTSDIR}/math/gsl \
qwt:${PORTSDIR}/x11-toolkits/qwt \
qwtplot3d:${PORTSDIR}/math/qwtplot3d
USE_BZIP2= yes
-USE_REINPLACE= yes
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/${PORTNAME}-${PORTVERSION}
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index 2056acbdd7d8..391bbce3cc6d 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -8,13 +8,14 @@
PORTNAME= yacas
PORTVERSION= 1.0.59
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= http://yacas.sourceforge.net/backups/
MAINTAINER= ports@FreeBSD.org
COMMENT= Yet Another Computer Algebra System
-LIB_DEPENDS= gsl.7:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.9:${PORTSDIR}/math/gsl
USE_PERL5_BUILD= yes
USE_GMAKE= yes
diff --git a/science/getdp/Makefile b/science/getdp/Makefile
index d123e79867b1..69849861b0c6 100644
--- a/science/getdp/Makefile
+++ b/science/getdp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= getdp
PORTVERSION= 1.2.1
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= http://www.geuz.org/getdp/src/
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
@@ -15,7 +16,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= A rather general finite element solver using mixed finite elements
-LIB_DEPENDS= gsl.7:${PORTSDIR}/math/gsl \
+LIB_DEPENDS= gsl.9:${PORTSDIR}/math/gsl \
lapack.3:${PORTSDIR}/math/lapack
GNU_CONFIGURE= yes
diff --git a/science/gnudatalanguage/Makefile b/science/gnudatalanguage/Makefile
index 080315bf5815..36ad6bdd477a 100644
--- a/science/gnudatalanguage/Makefile
+++ b/science/gnudatalanguage/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnudatalanguage
PORTVERSION= 0.8.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -32,7 +32,7 @@ COMMENT?= GDL, a free IDL compatible incremental compiler
#---------------------------------------------------------------------------
LIB_DEPENDS+= plplotd.10:${PORTSDIR}/math/plplot \
- gsl.7:${PORTSDIR}/math/gsl \
+ gsl.9:${PORTSDIR}/math/gsl \
readline.5:${PORTSDIR}/devel/readline
USE_XLIB= yes
@@ -104,7 +104,7 @@ CONFIGURE_ARGS+=--with-fftw=${LOCALBASE}
.endif
.if ${OSVERSION} < 500000
-BROKEN= "Does not compile with gcc-2.95"
+BROKEN= Does not compile with gcc-2.95
.endif
.if defined(BUILD_PYTHON_MODULE)
diff --git a/science/kst/Makefile b/science/kst/Makefile
index 99e00a98d487..8448a1bfe6f5 100644
--- a/science/kst/Makefile
+++ b/science/kst/Makefile
@@ -6,6 +6,7 @@
PORTNAME= kst
PORTVERSION= 1.2.1
+PORTREVISION= 1
CATEGORIES= science kde
MASTER_SITES= ${MASTER_SITE_KDE} \
http://omega.astro.utoronto.ca/${PORTNAME}/
@@ -15,7 +16,7 @@ MAINTAINER= kay_lehmann@web.de
COMMENT= Data viewing program for KDE
LIB_DEPENDS= cfitsio.0:${PORTSDIR}/astro/cfitsio \
- gsl.7:${PORTSDIR}/math/gsl
+ gsl.9:${PORTSDIR}/math/gsl
USE_KDELIBS_VER=3
USE_GMAKE= yes
diff --git a/science/kst2/Makefile b/science/kst2/Makefile
index 99e00a98d487..8448a1bfe6f5 100644
--- a/science/kst2/Makefile
+++ b/science/kst2/Makefile
@@ -6,6 +6,7 @@
PORTNAME= kst
PORTVERSION= 1.2.1
+PORTREVISION= 1
CATEGORIES= science kde
MASTER_SITES= ${MASTER_SITE_KDE} \
http://omega.astro.utoronto.ca/${PORTNAME}/
@@ -15,7 +16,7 @@ MAINTAINER= kay_lehmann@web.de
COMMENT= Data viewing program for KDE
LIB_DEPENDS= cfitsio.0:${PORTSDIR}/astro/cfitsio \
- gsl.7:${PORTSDIR}/math/gsl
+ gsl.9:${PORTSDIR}/math/gsl
USE_KDELIBS_VER=3
USE_GMAKE= yes