aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/bedic-data/Makefile35
-rw-r--r--textproc/bedic-data/distinfo1
-rw-r--r--textproc/bedic-data/pkg-comment1
-rw-r--r--textproc/bedic-data/pkg-descr4
5 files changed, 42 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 0b18fb1c1468..0099b6a0b9f6 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -7,6 +7,7 @@
SUBDIR += antiword
SUBDIR += ascii2pdf
SUBDIR += aspell
+ SUBDIR += bedic-data
SUBDIR += bibtex2html
SUBDIR += br-ispell
SUBDIR += british-ispell
diff --git a/textproc/bedic-data/Makefile b/textproc/bedic-data/Makefile
new file mode 100644
index 000000000000..fa1b0d7b8c18
--- /dev/null
+++ b/textproc/bedic-data/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: bedic-data
+# Date created: 15 April 2002
+# Whom: Peter Pentchev <roam@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bedic-data
+PORTVERSION= 0.1.b1
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://kbedic.search.bg/download/
+MASTER_SITE_SUBDIR=kbedic
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= todorov_bg@gmx.net
+
+NO_BUILD= yes
+PLIST= ${WRKDIR}/pkg-plist
+
+DICT_ALL= buleng.dat engbul.dat
+DICT_DIR?= ${PREFIX}/share
+DICTIONARIES?= ${DICT_ALL}
+
+pre-fetch:
+ @${ECHO_MSG} "You may set the DICTIONARIES variable to specify which dictionaries"
+ @${ECHO_MSG} "should be installed; currently, it is set to ${DICTIONARIES}"
+ @${ECHO_MSG} "Set it to one or more of the following: ${DICT_ALL}"
+
+do-install:
+ ${ECHO_CMD} ${DICTIONARIES} | ${TR} ' ' '\n' | ${SED} 's,^,share/,' > ${PLIST}
+ ${MKDIR} ${DICT_DIR}
+ ${INSTALL} ${DICTIONARIES:S,^,${WRKSRC}/,} ${DICT_DIR}/
+
+.include <bsd.port.mk>
diff --git a/textproc/bedic-data/distinfo b/textproc/bedic-data/distinfo
new file mode 100644
index 000000000000..3624d1674c57
--- /dev/null
+++ b/textproc/bedic-data/distinfo
@@ -0,0 +1 @@
+MD5 (bedic-data.tar.gz) = 4ff72f149c2f3fad91b547c7b70eb932
diff --git a/textproc/bedic-data/pkg-comment b/textproc/bedic-data/pkg-comment
new file mode 100644
index 000000000000..1abcd14a21a8
--- /dev/null
+++ b/textproc/bedic-data/pkg-comment
@@ -0,0 +1 @@
+Data (dictionary) files for the kbedic and cbedic ports
diff --git a/textproc/bedic-data/pkg-descr b/textproc/bedic-data/pkg-descr
new file mode 100644
index 000000000000..39457f4c08cb
--- /dev/null
+++ b/textproc/bedic-data/pkg-descr
@@ -0,0 +1,4 @@
+These are the dictionary files used by the textproc/kbedic and
+textproc/cbedic ports.
+
+WWW: http://kbedic.sourceforge.net/