aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/ghc/bsd.hackage.mk1
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/hs-wx/Makefile22
-rw-r--r--x11-toolkits/hs-wx/distinfo2
-rw-r--r--x11-toolkits/hs-wx/pkg-descr6
5 files changed, 32 insertions, 0 deletions
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index 6f3920331701..a6e8d47cc17b 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -281,6 +281,7 @@ wai-extra_port= www/hs-wai-extra
wai-logger_port= www/hs-wai-logger
warp_port= www/hs-warp
webkit_port= www/hs-webkit
+wx_port= x11-toolkits/hs-wx
wxcore_port= x11-toolkits/hs-wxcore # lib_depends
wxdirect_port= x11-toolkits/hs-wxdirect # executable
X11_port= x11/hs-X11 # lib_depends
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index df532c0a5ae5..90b32fa15084 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -88,6 +88,7 @@
SUBDIR += hs-gtksourceview2
SUBDIR += hs-pango
SUBDIR += hs-vte
+ SUBDIR += hs-wx
SUBDIR += hs-wxcore
SUBDIR += hs-wxdirect
SUBDIR += irrlicht
diff --git a/x11-toolkits/hs-wx/Makefile b/x11-toolkits/hs-wx/Makefile
new file mode 100644
index 000000000000..2648bc878019
--- /dev/null
+++ b/x11-toolkits/hs-wx/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: hs-wx
+# Date created: January 26, 2012
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= wx
+PORTVERSION= 0.13.2.1
+CATEGORIES= x11-toolkits haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= wxHaskell
+
+
+USE_CABAL= stm wxcore>=0.13.1
+
+BUILD_DEPENDS+= wxgtk2-unicode>=2.8:${PORTSDIR}/x11-toolkits/wxgtk28-unicode \
+ wxgtk2-unicode-contrib>=2.8:${PORTSDIR}/x11-toolkits/wxgtk28-unicode-contrib
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/x11-toolkits/hs-wx/distinfo b/x11-toolkits/hs-wx/distinfo
new file mode 100644
index 000000000000..c213ebd33500
--- /dev/null
+++ b/x11-toolkits/hs-wx/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/wx-0.13.2.1.tar.gz) = 7bd91026c81ac0833ed78bcfa1639a7945965315c1fd7afe86ca881bb3aeb268
+SIZE (cabal/wx-0.13.2.1.tar.gz) = 47690
diff --git a/x11-toolkits/hs-wx/pkg-descr b/x11-toolkits/hs-wx/pkg-descr
new file mode 100644
index 000000000000..d94efdfca4d2
--- /dev/null
+++ b/x11-toolkits/hs-wx/pkg-descr
@@ -0,0 +1,6 @@
+wxHaskell is a portable and native GUI library for Haskell. It is built
+on top of wxWidgets - a comprehensive C++ library that is portable
+across all major GUI platforms; including GTK, Windows, X11, and MacOS
+X. This version works with wxWidgets 2.8 and 2.9.
+
+WWW: http://haskell.org/haskellwiki/WxHaskell