aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/man2web/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/www/man2web/Makefile b/www/man2web/Makefile
index bff5b39da9c7..120dabc0cd70 100644
--- a/www/man2web/Makefile
+++ b/www/man2web/Makefile
@@ -7,6 +7,7 @@
PORTNAME= man2web
PORTVERSION= 0.88
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,7 +17,9 @@ COMMENT= Convert man pages to HTML
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --sysconfdir="${PREFIX}/etc" \
+CONFIGURE_ARGS= --bindir="${PREFIX}/${CGIDIR}" \
+ --sysconfdir="${PREFIX}/etc" \
+ --with-manpath=/usr/share/man:${X11BASE}/man:${LOCALBASE}/man \
--with-distro=freebsd --enable-lynx
PLIST_SUB= CGIDIR="${CGIDIR}"
@@ -30,7 +33,6 @@ post-extract:
# default Apache configuration disallows symlinks in cgi-bin
post-install:
- ${LN} -f ${PREFIX}/bin/man2web ${PREFIX}/${CGIDIR}/man2web || \
- ${INSTALL_PROGRAM} ${WRKSRC}/src/man2web ${PREFIX}/${CGIDIR}/
+ ${LN} -sf ${PREFIX}/${CGIDIR}/man2web ${PREFIX}/bin/man2web
.include <bsd.port.mk>