aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/any2dvd/Makefile43
-rw-r--r--multimedia/any2dvd/distinfo3
-rw-r--r--multimedia/any2dvd/pkg-descr6
-rw-r--r--multimedia/any2dvd/pkg-message25
5 files changed, 78 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 34c3fdfe11d5..7e7df7f27bc4 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -4,6 +4,7 @@
COMMENT = Multimedia software
SUBDIR += acidrip
+ SUBDIR += any2dvd
SUBDIR += audacious
SUBDIR += audacious-plugins
SUBDIR += avidemux2
diff --git a/multimedia/any2dvd/Makefile b/multimedia/any2dvd/Makefile
new file mode 100644
index 000000000000..195f199e4119
--- /dev/null
+++ b/multimedia/any2dvd/Makefile
@@ -0,0 +1,43 @@
+#
+# Ports collection makefile for: any2dvd
+# Date created: 28 December 2006
+# GRRR. Why is this breach of grammar necessary?
+# Whom: Greg Lehey <grog@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= any2dvd
+PORTVERSION= 0.32
+CATEGORIES= multimedia
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= any2dvd
+
+MAINTAINER= grog@FreeBSD.org
+COMMENT= A script to ease the pain of burning multimedia DVDs
+
+RUN_DEPENDS= transcode:${PORTSDIR}/multimedia/transcode
+LIB_DEPENDS+= Magick.10:${PORTSDIR}/graphics/ImageMagick
+
+MAN1= any2vob.1 any2dvd.1
+
+PLIST_FILES= bin/any2dvd \
+ bin/any2vob
+
+NO_BUILD= yes
+
+USE_BZIP2= yes
+USE_GHOSTSCRIPT_RUN= yes
+
+do-install:
+# scripts
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${WRKSRC}/any2vob ${PREFIX}/bin
+# Man pages! What luxury!
+ ${INSTALL_MAN} ${WRKSRC}/any2dvd.1 ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/any2vob.1 ${MANPREFIX}/man/man1
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+all:
+
+.include <bsd.port.mk>
diff --git a/multimedia/any2dvd/distinfo b/multimedia/any2dvd/distinfo
new file mode 100644
index 000000000000..6a42dad6a455
--- /dev/null
+++ b/multimedia/any2dvd/distinfo
@@ -0,0 +1,3 @@
+MD5 (any2dvd-0.32.tar.bz2) = 012f0cb2d03d9ccd672e21fe6d7c7dfe
+SHA256 (any2dvd-0.32.tar.bz2) = d441f3ef240add51a25d8c8f04d488d4b68159601da8d3b35b45cf2dcd64a230
+SIZE (any2dvd-0.32.tar.bz2) = 313935
diff --git a/multimedia/any2dvd/pkg-descr b/multimedia/any2dvd/pkg-descr
new file mode 100644
index 000000000000..0d5c57978bbb
--- /dev/null
+++ b/multimedia/any2dvd/pkg-descr
@@ -0,0 +1,6 @@
+any2dvd is a behemoth script to transform PC multimedia files, in any
+format, into a DVD complete with menus & suitable for playback on a
+standalone DVD player. The package also includes the script any2vob
+to create .VOB files.
+
+WWW: http://any2dvd.sf.net
diff --git a/multimedia/any2dvd/pkg-message b/multimedia/any2dvd/pkg-message
new file mode 100644
index 000000000000..c54e0d9d8410
--- /dev/null
+++ b/multimedia/any2dvd/pkg-message
@@ -0,0 +1,25 @@
+------------------------------------------------------------
+Installation summary:
+
+Scripts:
+
+ any2dvd, any2vob.
+
+Man pages:
+
+ any2dvd.1, any2vob.1.
+
+Other documentation:
+
+ 'any2dvd -h' and 'any2vob -h' both output a help summary. Bring a
+ wide xterm.
+
+ There is currently no useful documentation at the web site
+ (http://any2dvd.sf.net).
+
+Problems:
+
+ These scripts use dozens of other programs, but there's no
+ documentation saying what. There's a good chance that you'll you
+ run into a missing dependency. If you do, please report it.
+------------------------------------------------------------