aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/google-perftools/Makefile51
-rw-r--r--devel/google-perftools/distinfo3
-rw-r--r--devel/google-perftools/pkg-descr10
-rw-r--r--devel/google-perftools/pkg-plist76
5 files changed, 141 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 92f74678a1bd..bc60945f5504 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -416,6 +416,7 @@
SUBDIR += goffice
SUBDIR += goffice1
SUBDIR += gonzui
+ SUBDIR += google-perftools
SUBDIR += google-sparsehash
SUBDIR += gorm
SUBDIR += gperf
diff --git a/devel/google-perftools/Makefile b/devel/google-perftools/Makefile
new file mode 100644
index 000000000000..e29f43e7b8ce
--- /dev/null
+++ b/devel/google-perftools/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: google-sparsehash
+# Date created: 07 January 2007
+# Whom: Yuri Victorovich <yuri@tsoft.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= google-perftools
+PORTVERSION= 0.93
+CATEGORIES= devel
+MASTER_SITES= http://google-perftools.googlecode.com/files/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= vd/${PORTNAME}
+
+MAINTAINER= yuri@tsoft.com
+COMMENT= Fast, mutli-threaded malloc() and nifty performance analysis tools
+
+LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
+
+post-patch:
+.if defined(NOPORTDOCS)
+ ${REINPLACE_CMD} -e \
+ '/^install-data-am:/ s|install-dist_docDATA||' \
+ ${WRKSRC}/Makefile.in
+.endif
+
+post-build:
+ @${ECHO}
+ @${ECHO} "Be aware that one of the self tests is known to fail."
+ @${ECHO} "Run 'make check' and try to fix that. Thanks!"
+ @${ECHO}
+
+# one of the tests is known to fail, uncomment this as soon as it is fixed
+#regression-test: check
+
+check: build
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+# src/stacktrace.cc:81:5: #error Cannnot calculate stack trace: need libunwind (see INSTALL file)
+BROKEN= Does not build on amd64, cannnot calculate stack trace: need libunwind (see INSTALL file)
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/google-perftools/distinfo b/devel/google-perftools/distinfo
new file mode 100644
index 000000000000..969c68ddfba9
--- /dev/null
+++ b/devel/google-perftools/distinfo
@@ -0,0 +1,3 @@
+MD5 (google-perftools-0.93.tar.gz) = 9934d8df6151e891872198b6708c3a6d
+SHA256 (google-perftools-0.93.tar.gz) = e9e9048b8da2b82a51a78629768f02d1921429727318afcbf189d536f9157273
+SIZE (google-perftools-0.93.tar.gz) = 1887604
diff --git a/devel/google-perftools/pkg-descr b/devel/google-perftools/pkg-descr
new file mode 100644
index 000000000000..06b1b8d833a0
--- /dev/null
+++ b/devel/google-perftools/pkg-descr
@@ -0,0 +1,10 @@
+Perf Tools is a collection of a high-performance multi-threaded malloc()
+implementation, plus some pretty nifty performance analysis tools.
+Perf Tools is the fastest memory allocation library available,
+it also often allows applications to have smaller memory
+footprint.
+
+Multithreaded support is not yet ported to FreeBSD but many programs can
+benefit from performance improvement of memory allocation.
+
+WWW: http://code.google.com/p/google-perftools
diff --git a/devel/google-perftools/pkg-plist b/devel/google-perftools/pkg-plist
new file mode 100644
index 000000000000..a7b013eac102
--- /dev/null
+++ b/devel/google-perftools/pkg-plist
@@ -0,0 +1,76 @@
+bin/pprof
+include/google/heap-checker.h
+include/google/heap-profiler.h
+include/google/malloc_extension.h
+include/google/malloc_hook.h
+include/google/profiler.h
+include/google/stacktrace.h
+lib/libprofiler.a
+lib/libprofiler.la
+lib/libprofiler.so
+lib/libprofiler.so.0
+lib/libstacktrace.a
+lib/libstacktrace.la
+lib/libstacktrace.so
+lib/libstacktrace.so.0
+lib/libtcmalloc.a
+lib/libtcmalloc.la
+lib/libtcmalloc.so
+lib/libtcmalloc.so.0
+lib/libtcmalloc_minimal.a
+lib/libtcmalloc_minimal.la
+lib/libtcmalloc_minimal.so
+lib/libtcmalloc_minimal.so.0
+man/man1/pprof.1
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README.windows
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/cpuprofile.html
+%%PORTDOCS%%%%DOCSDIR%%/designstyle.css
+%%PORTDOCS%%%%DOCSDIR%%/heap-example1.png
+%%PORTDOCS%%%%DOCSDIR%%/heap_checker.html
+%%PORTDOCS%%%%DOCSDIR%%/heapprofile.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/overview.dot
+%%PORTDOCS%%%%DOCSDIR%%/overview.gif
+%%PORTDOCS%%%%DOCSDIR%%/pageheap.dot
+%%PORTDOCS%%%%DOCSDIR%%/pageheap.gif
+%%PORTDOCS%%%%DOCSDIR%%/pprof-test-big.gif
+%%PORTDOCS%%%%DOCSDIR%%/pprof-test.gif
+%%PORTDOCS%%%%DOCSDIR%%/pprof-vsnprintf-big.gif
+%%PORTDOCS%%%%DOCSDIR%%/pprof-vsnprintf.gif
+%%PORTDOCS%%%%DOCSDIR%%/pprof_remote_servers.html
+%%PORTDOCS%%%%DOCSDIR%%/spanmap.dot
+%%PORTDOCS%%%%DOCSDIR%%/spanmap.gif
+%%PORTDOCS%%%%DOCSDIR%%/t-test1.times.txt
+%%PORTDOCS%%%%DOCSDIR%%/tcmalloc-opspercpusec.vs.threads.1024.bytes.png
+%%PORTDOCS%%%%DOCSDIR%%/tcmalloc-opspercpusec.vs.threads.128.bytes.png
+%%PORTDOCS%%%%DOCSDIR%%/tcmalloc-opspercpusec.vs.threads.131072.bytes.png
+%%PORTDOCS%%%%DOCSDIR%%/tcmalloc-opspercpusec.vs.threads.16384.bytes.png
+%%PORTDOCS%%%%DOCSDIR%%/tcmalloc-opspercpusec.vs.threads.2048.bytes.png
+%%PORTDOCS%%%%DOCSDIR%%/tcmalloc-opspercpusec.vs.threads.256.bytes.png
+%%PORTDOCS%%%%DOCSDIR%%/tcmalloc-opspercpusec.vs.threads.32768.bytes.png
+%%PORTDOCS%%%%DOCSDIR%%/tcmalloc-opspercpusec.vs.threads.4096.bytes.png
+%%PORTDOCS%%%%DOCSDIR%%/tcmalloc-opspercpusec.vs.threads.512.bytes.png
+%%PORTDOCS%%%%DOCSDIR%%/tcmalloc-opspercpusec.vs.threads.64.bytes.png
+%%PORTDOCS%%%%DOCSDIR%%/tcmalloc-opspercpusec.vs.threads.65536.bytes.png
+%%PORTDOCS%%%%DOCSDIR%%/tcmalloc-opspercpusec.vs.threads.8192.bytes.png
+%%PORTDOCS%%%%DOCSDIR%%/tcmalloc-opspersec.vs.size.1.threads.png
+%%PORTDOCS%%%%DOCSDIR%%/tcmalloc-opspersec.vs.size.12.threads.png
+%%PORTDOCS%%%%DOCSDIR%%/tcmalloc-opspersec.vs.size.16.threads.png
+%%PORTDOCS%%%%DOCSDIR%%/tcmalloc-opspersec.vs.size.2.threads.png
+%%PORTDOCS%%%%DOCSDIR%%/tcmalloc-opspersec.vs.size.20.threads.png
+%%PORTDOCS%%%%DOCSDIR%%/tcmalloc-opspersec.vs.size.3.threads.png
+%%PORTDOCS%%%%DOCSDIR%%/tcmalloc-opspersec.vs.size.4.threads.png
+%%PORTDOCS%%%%DOCSDIR%%/tcmalloc-opspersec.vs.size.5.threads.png
+%%PORTDOCS%%%%DOCSDIR%%/tcmalloc-opspersec.vs.size.8.threads.png
+%%PORTDOCS%%%%DOCSDIR%%/tcmalloc.html
+%%PORTDOCS%%%%DOCSDIR%%/threadheap.dot
+%%PORTDOCS%%%%DOCSDIR%%/threadheap.gif
+@dirrmtry include/google
+%%PORTDOCS%%@dirrm %%DOCSDIR%%