aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/nagiosgraph/Makefile35
-rw-r--r--net-mgmt/nagiosgraph/distinfo6
-rw-r--r--net-mgmt/nagiosgraph/pkg-plist22
3 files changed, 38 insertions, 25 deletions
diff --git a/net-mgmt/nagiosgraph/Makefile b/net-mgmt/nagiosgraph/Makefile
index 971289e6673a..2ff8e789812b 100644
--- a/net-mgmt/nagiosgraph/Makefile
+++ b/net-mgmt/nagiosgraph/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= nagiosgraph
-PORTVERSION= 0.9.0
-PORTREVISION= 3
+PORTVERSION= 1.4.0
CATEGORIES= net-mgmt
MASTER_SITES= SF
-EXTRACT_SUFX= .tgz
MAINTAINER= dsh@wizard.volgograd.ru
COMMENT= Generate rrdtool\'s graphs by performance data from nagios plugins
@@ -21,41 +19,46 @@ RUN_DEPENDS= ${LOCALBASE}/bin/nagios:${PORTSDIR}/net-mgmt/nagios \
USE_PERL5_RUN= yes
NO_BUILD= yes
-PORTDOCS= CHANGELOG INSTALL README README.map
+PORTDOCS= AUTHORS CHANGELOG INSTALL README README.map TODO
PLIST_SUB= NAGIOSWWWDIR=${NAGIOSWWWDIR}
NAGIOSWWWDIR?= www/nagios
post-patch:
-.for i in insert.pl testcolor.cgi testentry.pl
+.for i in lib/insert.pl cgi/show.cgi cgi/showgraph.cgi cgi/showhost.cgi cgi/showservice.cgi cgi/testcolor.cgi
${REINPLACE_CMD} -e 's!/usr/bin/perl!${PERL}!g' -e 's!/usr/local!${PREFIX}!g' \
- -e 's!nagiosgraph\.conf!nagios/nagiosgraph/nagiosgraph.conf!g' ${WRKSRC}/$i
-.endfor
-.for i in show.cgi
- ${REINPLACE_CMD} -e 's!/usr/bin/perl!${PERL}!g' -e 's!/usr/local!${PREFIX}!g' \
- -e 's!nagiosgraph/nagiosgraph\.conf!nagios/nagiosgraph/nagiosgraph.conf!g' ${WRKSRC}/$i
+ -e 's!/etc/nagios/!/usr/local/etc/nagios/!g' ${WRKSRC}/$i
.endfor
do-install:
${MKDIR} ${PREFIX}/etc/nagios/nagiosgraph
-.for i in map nagiosgraph.conf
- ${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/etc/nagios/nagiosgraph/${i}.example
+
+ ${INSTALL_DATA} ${WRKSRC}/etc/ngshared.pm ${PREFIX}/etc/nagios/nagiosgraph/ngshared.pm
+
+.for i in hostdb.conf map nagiosgraph.conf servdb.conf
+ ${INSTALL_DATA} ${WRKSRC}/etc/$i ${PREFIX}/etc/nagios/nagiosgraph/${i}.example
.endfor
${MKDIR} ${PREFIX}/libexec/${PORTNAME}
- ${INSTALL_SCRIPT} ${WRKSRC}/insert.pl ${PREFIX}/libexec/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKSRC}/lib/insert.pl ${PREFIX}/libexec/${PORTNAME}
${MKDIR} ${PREFIX}/${NAGIOSWWWDIR}/cgi-bin/nagiosgraph
-.for i in show.cgi testcolor.cgi
+.for i in cgi/show.cgi cgi/showgraph.cgi cgi/showhost.cgi cgi/showservice.cgi cgi/testcolor.cgi
${INSTALL_SCRIPT} ${WRKSRC}/$i ${PREFIX}/${NAGIOSWWWDIR}/cgi-bin/nagiosgraph
.endfor
${MKDIR} ${PREFIX}/${NAGIOSWWWDIR}/stylesheets
- ${INSTALL_DATA} ${WRKSRC}/nagiosgraph.css ${PREFIX}/${NAGIOSWWWDIR}/stylesheets
+.for i in share/action.gif share/nagiosgraph.css share/nagiosgraph.js
+ ${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/${NAGIOSWWWDIR}/stylesheets
+.endfor
+.if !defined(NOPORTEXAMPLES)
${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/testentry.pl ${EXAMPLESDIR}
+.for i in utils/authz.pl utils/testentry.pl utils/upgrade.pl
+ ${INSTALL_SCRIPT} ${WRKSRC}/$i ${EXAMPLESDIR}
+.endfor
+.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
diff --git a/net-mgmt/nagiosgraph/distinfo b/net-mgmt/nagiosgraph/distinfo
index ff11affe4595..ba0560db9505 100644
--- a/net-mgmt/nagiosgraph/distinfo
+++ b/net-mgmt/nagiosgraph/distinfo
@@ -1,3 +1,3 @@
-MD5 (nagiosgraph-0.9.0.tgz) = 4450d5d3f28d4ba379fc225e8aee893e
-SHA256 (nagiosgraph-0.9.0.tgz) = d93957c6f1435f9a10191e07c3fb6b42203a68f9537d9d9509879b9e5fa8dfff
-SIZE (nagiosgraph-0.9.0.tgz) = 20149
+MD5 (nagiosgraph-1.4.0.tar.gz) = d7bece0637df1ab2e94463d2c575b3e3
+SHA256 (nagiosgraph-1.4.0.tar.gz) = 1cb8b77d269201f271d18e4739ea12d927d8e5bf63449ace71c17e07a23f5fb6
+SIZE (nagiosgraph-1.4.0.tar.gz) = 61820
diff --git a/net-mgmt/nagiosgraph/pkg-plist b/net-mgmt/nagiosgraph/pkg-plist
index 930a41cdd09a..9027c4a5eec2 100644
--- a/net-mgmt/nagiosgraph/pkg-plist
+++ b/net-mgmt/nagiosgraph/pkg-plist
@@ -1,15 +1,25 @@
+etc/nagios/nagiosgraph/hostdb.conf.example
etc/nagios/nagiosgraph/map.example
etc/nagios/nagiosgraph/nagiosgraph.conf.example
+etc/nagios/nagiosgraph/ngshared.pm
+etc/nagios/nagiosgraph/servdb.conf.example
libexec/nagiosgraph/insert.pl
-%%EXAMPLESDIR%%/testentry.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/authz.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testentry.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/upgrade.pl
%%NAGIOSWWWDIR%%/cgi-bin/nagiosgraph/show.cgi
+%%NAGIOSWWWDIR%%/cgi-bin/nagiosgraph/showgraph.cgi
+%%NAGIOSWWWDIR%%/cgi-bin/nagiosgraph/showhost.cgi
+%%NAGIOSWWWDIR%%/cgi-bin/nagiosgraph/showservice.cgi
%%NAGIOSWWWDIR%%/cgi-bin/nagiosgraph/testcolor.cgi
+%%NAGIOSWWWDIR%%/stylesheets/action.gif
%%NAGIOSWWWDIR%%/stylesheets/nagiosgraph.css
-@dirrm etc/nagios/nagiosgraph
-@dirrmtry etc/nagios
-@dirrm libexec/nagiosgraph
-@dirrm %%EXAMPLESDIR%%
+%%NAGIOSWWWDIR%%/stylesheets/nagiosgraph.js
+@dirrmtry %%NAGIOSWWWDIR%%/stylesheets
@dirrm %%NAGIOSWWWDIR%%/cgi-bin/nagiosgraph
@dirrmtry %%NAGIOSWWWDIR%%/cgi-bin
-@dirrmtry %%NAGIOSWWWDIR%%/stylesheets
@dirrmtry %%NAGIOSWWWDIR%%
+@dirrm libexec/nagiosgraph
+@dirrm etc/nagios/nagiosgraph
+@dirrmtry etc/nagios
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%