aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-ez_xml/Makefile22
-rw-r--r--devel/py-ez_xml/distinfo3
-rw-r--r--devel/py-ez_xml/pkg-descr6
-rw-r--r--devel/py-ez_xml/pkg-plist11
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f5be3552218c..0f7367c8d65d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1784,6 +1784,7 @@
SUBDIR += py-elementtree
SUBDIR += py-epsilon
SUBDIR += py-event
+ SUBDIR += py-ez_xml
SUBDIR += py-ezpyinline
SUBDIR += py-fam
SUBDIR += py-fileutils
diff --git a/devel/py-ez_xml/Makefile b/devel/py-ez_xml/Makefile
new file mode 100644
index 000000000000..df3dc23c7329
--- /dev/null
+++ b/devel/py-ez_xml/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: py-ez_xml
+# Date created: 2007-03-27
+# Whom: Thinker K.F. Li <thinker@branda.to>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ez_xml
+PORTVERSION= 0.1.3
+CATEGORIES= devel textproc
+MASTER_SITES= http://master.branda.to/downloads/ez_xml/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= thinker@seeker.branda.to
+COMMENT= Ez_xml compiles a XML template file into a Python module
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pythk/__init__.py:${PORTSDIR}/devel/pythk
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-ez_xml/distinfo b/devel/py-ez_xml/distinfo
new file mode 100644
index 000000000000..4a8d2b3976f7
--- /dev/null
+++ b/devel/py-ez_xml/distinfo
@@ -0,0 +1,3 @@
+MD5 (ez_xml-0.1.3.tar.gz) = 12813684ac9047e237a2e8b6035079c1
+SHA256 (ez_xml-0.1.3.tar.gz) = a6592e08348877969adf43a1a3e29173580ecf56ad966250754dd9b3f90cd74a
+SIZE (ez_xml-0.1.3.tar.gz) = 4144
diff --git a/devel/py-ez_xml/pkg-descr b/devel/py-ez_xml/pkg-descr
new file mode 100644
index 000000000000..2fbe53c97715
--- /dev/null
+++ b/devel/py-ez_xml/pkg-descr
@@ -0,0 +1,6 @@
+ez_xml is a XML template generator that compiles a XML template file into a
+Python module. Programmers feed data to a template module to generate a
+respective XML document. ez_xml provides concise functions, no complex
+flow-control instructions.
+
+WWW: https://opensvn.csie.org/traccgi/PumperWeb/wiki/ez_xml
diff --git a/devel/py-ez_xml/pkg-plist b/devel/py-ez_xml/pkg-plist
new file mode 100644
index 000000000000..18772e833861
--- /dev/null
+++ b/devel/py-ez_xml/pkg-plist
@@ -0,0 +1,11 @@
+@comment $FreeBSD$
+%%PYTHON_SITELIBDIR%%/ez_xml/__init__.py
+%%PYTHON_SITELIBDIR%%/ez_xml/compiler.py
+%%PYTHON_SITELIBDIR%%/ez_xml/tools.py
+%%PYTHON_SITELIBDIR%%/ez_xml/__init__.pyc
+%%PYTHON_SITELIBDIR%%/ez_xml/compiler.pyc
+%%PYTHON_SITELIBDIR%%/ez_xml/tools.pyc
+%%PYTHON_SITELIBDIR%%/ez_xml/__init__.pyo
+%%PYTHON_SITELIBDIR%%/ez_xml/compiler.pyo
+%%PYTHON_SITELIBDIR%%/ez_xml/tools.pyo
+@dirrmtry %%PYTHON_SITELIBDIR%%/ez_xml