aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/jetspeed/Makefile39
-rw-r--r--www/jetspeed/distinfo1
-rw-r--r--www/jetspeed/pkg-descr12
-rw-r--r--www/jetspeed/pkg-message6
-rw-r--r--www/jetspeed/pkg-plist8
6 files changed, 67 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 0545095012f9..8be1087e562d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -142,6 +142,7 @@
SUBDIR += jakarta-tomcat5
SUBDIR += jdresolve
SUBDIR += jesred
+ SUBDIR += jetspeed
SUBDIR += jetty
SUBDIR += jonah
SUBDIR += junkbuster
diff --git a/www/jetspeed/Makefile b/www/jetspeed/Makefile
new file mode 100644
index 000000000000..3105eb8b8bdf
--- /dev/null
+++ b/www/jetspeed/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: jetspeed
+# Date created: 30 July 2003
+# Whom: francisco@gomezmarin.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= jetspeed
+PORTVERSION= 1.4
+CATEGORIES= www
+MASTER_SITES= http://apache.inspire.net.nz/jakarta/jetspeed/binaries/
+#MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
+#MASTER_SITE_SUBDIR=jakarta-jetspeed/release/v1.4b4
+DISTNAME= ${PORTNAME}-${PORTVERSION}-b4-war
+
+MAINTAINER= francisco@gomezmarin.com
+COMMENT= Jetspeed is an Open Source Portal, written in Java and XML
+
+RUN_DEPENDS= ${LOCALBASE}/linux-sun-jdk1.4.1/bin/java:${PORTSDIR}/java/linux-sun-jdk14 \
+ ${LOCALBASE}/bin/ant:${PORTSDIR}/devel/jakarta-ant \
+ ${LOCALBASE}/bin/tomcat41ctl:${PORTSDIR}/www/jakarta-tomcat41
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-b4
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+JAKARTA_HOME= ${LOCALBASE}/jakarta-tomcat4.1
+
+do-install:
+ @${CP} ${WRKSRC}/jetspeed.war ${JAKARTA_HOME}/webapps
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${CP} ${WRKSRC}/* ${DOCSDIR}
+.endif
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/jetspeed/distinfo b/www/jetspeed/distinfo
new file mode 100644
index 000000000000..a8a73f566029
--- /dev/null
+++ b/www/jetspeed/distinfo
@@ -0,0 +1 @@
+MD5 (jetspeed-1.4-b4-war.zip) = 4f8c3dfe72b0ffdf0c4ca7855bc316a9
diff --git a/www/jetspeed/pkg-descr b/www/jetspeed/pkg-descr
new file mode 100644
index 000000000000..d950e49761b0
--- /dev/null
+++ b/www/jetspeed/pkg-descr
@@ -0,0 +1,12 @@
+Jetspeed is an Open Source implementation of an Enterprise
+Information Portal, using Java and XML. A portal makes network
+resources (applications, databases and so forth) available to
+end-users. The user can access the portal via a web browser,
+WAP-phone, pager or any other device. Jetspeed acts as the central
+hub where information from multiple sources are made available in
+an easy to use manner.
+
+WWW: http://jakarta.apache.org/jetspeed/site/index.html
+
+- Francisco -
+francisco@gomezmarin.com
diff --git a/www/jetspeed/pkg-message b/www/jetspeed/pkg-message
new file mode 100644
index 000000000000..b9f62e49dd87
--- /dev/null
+++ b/www/jetspeed/pkg-message
@@ -0,0 +1,6 @@
+Once everything is finally installed set the JAVA_HOME
+variable to ${LOCALBASE}/linux-sun-jdk1.4.1 and run the Tomcat
+server. The JetSpeed portal war file is copied to
+${LOCALBASE}/jakarta-tomcat4.1/webapps, where tomcat resides.
+
+For more information on how it works look at JetSpeed homepage.
diff --git a/www/jetspeed/pkg-plist b/www/jetspeed/pkg-plist
new file mode 100644
index 000000000000..636eae91689a
--- /dev/null
+++ b/www/jetspeed/pkg-plist
@@ -0,0 +1,8 @@
+jakarta-tomcat4.1/webapps/jetspeed.war
+share/doc/jetspeed/INSTALL
+share/doc/jetspeed/LICENSE
+share/doc/jetspeed/README
+share/doc/jetspeed/NOTES
+share/doc/jetspeed/jetspeed.war
+share/doc/jetspeed/WARNING
+@dirrm share/doc/jetspeed/