aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/kid3-kde4/Makefile2
-rw-r--r--cad/librecad/Makefile5
-rw-r--r--devel/qdevelop/Makefile7
-rw-r--r--devel/qdevelop/pkg-descr2
-rw-r--r--emulators/aqemu/Makefile5
-rw-r--r--emulators/qtemu/Makefile10
-rw-r--r--graphics/klatexformula/Makefile2
-rw-r--r--graphics/qcomicbook/Makefile2
-rw-r--r--irc/quassel/Makefile2
-rw-r--r--math/qtiplot/Makefile5
-rw-r--r--math/qtoctave/Makefile2
-rw-r--r--multimedia/minitube/Makefile7
-rw-r--r--science/kst2/Makefile2
-rw-r--r--x11-fonts/fontmatrix/Makefile6
14 files changed, 23 insertions, 36 deletions
diff --git a/audio/kid3-kde4/Makefile b/audio/kid3-kde4/Makefile
index 85f4eb6e424d..5895551b2ee1 100644
--- a/audio/kid3-kde4/Makefile
+++ b/audio/kid3-kde4/Makefile
@@ -33,7 +33,7 @@ CMAKE_ARGS+= -DWITH_QT5=true
.else
# Qt 4 and KDE 4
USE_QT4= qmake_build moc_build rcc_build uic_build \
- linguist_build
+ linguisttools_build
.endif
.if defined(PKGNAMESUFFIX) && ${PKGNAMESUFFIX} == "-qt4"
diff --git a/cad/librecad/Makefile b/cad/librecad/Makefile
index 3740eb8c8a77..d89b1932392e 100644
--- a/cad/librecad/Makefile
+++ b/cad/librecad/Makefile
@@ -2,6 +2,7 @@
PORTNAME= librecad
DISTVERSION= 2.0.5
+PORTREVISION= 1
CATEGORIES= cad
MASTER_SITES= GITHUB
@@ -11,8 +12,8 @@ COMMENT= 2D CAD system
BUILD_DEPENDS= ${LOCALBASE}/include/boost/version.hpp:${PORTSDIR}/devel/boost-libs
LIB_DEPENDS= libmuparser.so:${PORTSDIR}/math/muparser
-USE_QT4= help qt3support help-tools_build linguist_build moc_build \
- rcc_build uic_build uic3_build
+USE_QT4= gui help network sql svg help-tools_build \
+ linguisttools_build moc_build rcc_build uic_build
USES= compiler:c++11-lib desktop-file-utils pkgconfig qmake
USE_GITHUB= yes
diff --git a/devel/qdevelop/Makefile b/devel/qdevelop/Makefile
index 53540f26e450..0404e5532f4c 100644
--- a/devel/qdevelop/Makefile
+++ b/devel/qdevelop/Makefile
@@ -17,8 +17,6 @@ USE_QT4= gui sql network xml designer sql-sqlite3_run \
moc_build uic_build rcc_build
USES= qmake
-STRIP_FILES= bin/${PORTNAME}
-
DESKTOP_ENTRIES= "QDevelop" \
"Qt 4 development environment" \
"${PREFIX}/share/pixmaps/qdevelop.png" \
@@ -29,10 +27,10 @@ DESKTOP_ENTRIES= "QDevelop" \
OPTIONS_DEFINE= TOOLS DOCS NLS
OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
OPTIONS_SUB= yes
-NLS_USE= QT4=linguist_build
+NLS_USE= QT4=linguisttools_build
TOOLS_DESC= Install Qt 4 development tools (qmake, moc, etc.)
TOOLS_USE= ${_TOOLS:C|.*|QT4=&_run|}
-_TOOLS= assistant linguist moc qmake rcc uic
+_TOOLS= assistant linguisttools moc qmake rcc uic
.include <bsd.port.options.mk>
@@ -59,7 +57,6 @@ post-configure:
.endif
post-install:
- ${STRIP_CMD} ${STRIP_FILES:S,^,${STAGEDIR}${PREFIX}/,}
${INSTALL_DATA} ${WRKSRC}/resources/images/logo.png ${STAGEDIR}${PREFIX}/share/pixmaps/qdevelop.png
.if ${PORT_OPTIONS:MNLS}
@${MKDIR} ${STAGEDIR}${DATADIR}/translations
diff --git a/devel/qdevelop/pkg-descr b/devel/qdevelop/pkg-descr
index ba677e742a2a..b46a7206d335 100644
--- a/devel/qdevelop/pkg-descr
+++ b/devel/qdevelop/pkg-descr
@@ -4,4 +4,4 @@ to Qt and is totally independent of KDevelop. Less complete, but faster,
light and especially multi-platforms. QDevelop and KDevelop have different
code sources.
-WWW: http://biord-software.org/qdevelop/
+WWW: http://code.google.com/p/qdevelop/
diff --git a/emulators/aqemu/Makefile b/emulators/aqemu/Makefile
index b3ced03140b8..811480cf57a6 100644
--- a/emulators/aqemu/Makefile
+++ b/emulators/aqemu/Makefile
@@ -2,6 +2,7 @@
PORTNAME= aqemu
PORTVERSION= 0.8.2
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:S,.0$,,}/
@@ -10,8 +11,8 @@ COMMENT= Qt 4 based Qemu frontend
LIB_DEPENDS= libvncclient.so:${PORTSDIR}/net/libvncserver
-USE_QT4= gui qtestlib xml qmake_build uic_build moc_build rcc_build \
- linguist_build
+USE_QT4= gui network qtestlib xml linguisttools_build \
+ moc_build qmake_build rcc_build uic_build
USES= cmake tar:bzip2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S,.0$,,}
diff --git a/emulators/qtemu/Makefile b/emulators/qtemu/Makefile
index 85abd83d84a1..7658658b9b95 100644
--- a/emulators/qtemu/Makefile
+++ b/emulators/qtemu/Makefile
@@ -17,15 +17,11 @@ DESKTOP_ENTRIES="QtEmu" "QEMU frontend" "" \
"qtemu" "" true
OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
+NLS_USE= QT4=linguisttools_build
-.if ${PORT_OPTIONS:MNLS}
-USE_QT4+= linguist_build
-PLIST_SUB+= NLS=""
-.else
-PLIST_SUB+= NLS="@comment "
-.endif
+.include <bsd.port.options.mk>
post-configure:
.if ${PORT_OPTIONS:MNLS}
diff --git a/graphics/klatexformula/Makefile b/graphics/klatexformula/Makefile
index 949768aa7ca3..478cc213e3f5 100644
--- a/graphics/klatexformula/Makefile
+++ b/graphics/klatexformula/Makefile
@@ -11,7 +11,7 @@ COMMENT= Convert LaTeX formula to image
BUILD_DEPENDS= help2man:${PORTSDIR}/misc/help2man
USES= cmake:outsource desktop-file-utils shared-mime-info
-USE_QT4= gui xml dbus designer_build linguist_build \
+USE_QT4= gui xml dbus designer_build linguisttools_build \
qmake_build moc_build rcc_build uic_build
USE_TEX= latex dvipsk
USE_GHOSTSCRIPT_RUN= yes
diff --git a/graphics/qcomicbook/Makefile b/graphics/qcomicbook/Makefile
index 01242f3e1883..2048f7ef3b12 100644
--- a/graphics/qcomicbook/Makefile
+++ b/graphics/qcomicbook/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libpoppler-qt4.so:${PORTSDIR}/graphics/poppler-qt4
USES= cmake:outsource pkgconfig
-USE_QT4= corelib gui linguist_build moc_build qmake_build rcc_build \
+USE_QT4= corelib gui linguisttools_build moc_build qmake_build rcc_build \
uic_build xml
OPTIONS_DEFINE= 7ZIP ACE RAR ZIP
diff --git a/irc/quassel/Makefile b/irc/quassel/Makefile
index 3ec31a2f4af4..fe177ef7b8ef 100644
--- a/irc/quassel/Makefile
+++ b/irc/quassel/Makefile
@@ -41,7 +41,7 @@ CLIENT_CMAKE_OFF= -DWANT_QTCLIENT=off
KDE_DESC= KDE 4 integration (for clients only)
-NLS_USE= QT4=linguist_build
+NLS_USE= QT4=linguisttools_build
.include <bsd.port.options.mk>
diff --git a/math/qtiplot/Makefile b/math/qtiplot/Makefile
index 1130828f772a..633a6da4221f 100644
--- a/math/qtiplot/Makefile
+++ b/math/qtiplot/Makefile
@@ -34,8 +34,6 @@ OPTIONS_DEFAULT= DOCS PYTHON NLS
DOCS_DESC= Install the QtiPlot Handbook
PYTHON_DESC= Python scripting support
-STRIP_FILES= bin/qtiplot share/qtiplot/fitPlugins/*.so.1.0.0
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPYTHON}
@@ -55,7 +53,7 @@ USE_QT4+= assistant-adp_run
.endif
.if ${PORT_OPTIONS:MNLS}
-USE_QT4+= linguist_build
+USE_QT4+= linguisttools_build
PLIST_SUB+= NLS=""
.else
PLIST_SUB+= NLS="@comment "
@@ -99,7 +97,6 @@ pre-configure:
.endif
post-install:
- ${STRIP_CMD} ${STRIP_FILES:S,^,${STAGEDIR}${PREFIX}/,}
${INSTALL_DATA} ${WRKSRC}/qtiplot_logo.png ${STAGEDIR}${PREFIX}/share/pixmaps/qtiplot.png
.if ${PORT_OPTIONS:MPYTHON}
.for s in qtiplotrc.py qtiUtil.py
diff --git a/math/qtoctave/Makefile b/math/qtoctave/Makefile
index 785c520ad3ff..8e892ee18c6e 100644
--- a/math/qtoctave/Makefile
+++ b/math/qtoctave/Makefile
@@ -13,7 +13,7 @@ RUN_DEPENDS= octave:${PORTSDIR}/math/octave
USE_QT4= designer gui network script svg xml \
qmake_build moc_build rcc_build uic_build \
- linguist_build
+ linguisttools_build
USES= cmake
CMAKE_ARGS+= -DWITH_UseRPMTools:Bool=Off
diff --git a/multimedia/minitube/Makefile b/multimedia/minitube/Makefile
index d7b488c1219b..994c105599fc 100644
--- a/multimedia/minitube/Makefile
+++ b/multimedia/minitube/Makefile
@@ -18,11 +18,9 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
QMAKE_ARGS= QMAKE_LRELEASE=${LRELEASE}
-STRIP_FILES= bin/minitube
-
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
-NLS_USE= QT4=linguist_build
+NLS_USE= QT4=linguisttools_build
.include <bsd.port.options.mk>
@@ -32,7 +30,4 @@ pre-configure:
${REINPLACE_CMD} -e '/include(locale\/locale.pri)/d' ${WRKSRC}/minitube.pro
.endif
-post-install:
- ${STRIP_CMD} ${STRIP_FILES:S,^,${STAGEDIR}${PREFIX}/,}
-
.include <bsd.port.mk>
diff --git a/science/kst2/Makefile b/science/kst2/Makefile
index 0e3bd92322b0..3c8d2e4e8df3 100644
--- a/science/kst2/Makefile
+++ b/science/kst2/Makefile
@@ -13,7 +13,7 @@ COMMENT= Data viewing and plotting tool
LIB_DEPENDS= libgsl.so:${PORTSDIR}/math/gsl
USES= cmake:outsource pkgconfig
-_USE_QT4= gui xml designer svg linguist_build \
+_USE_QT4= gui xml designer svg linguisttools_build \
qmake_build moc_build rcc_build uic_build
_USE_QT5= concurrent network printsupport widgets xml \
buildtools_build linguisttools_build qmake_build
diff --git a/x11-fonts/fontmatrix/Makefile b/x11-fonts/fontmatrix/Makefile
index 671d243ae1ad..ad886d8fc247 100644
--- a/x11-fonts/fontmatrix/Makefile
+++ b/x11-fonts/fontmatrix/Makefile
@@ -13,7 +13,7 @@ COMMENT= Graphical font manager
RUN_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
USES= cmake
-USE_QT4= gui svg network moc_build uic_build rcc_build qmake_build linguist_build
+USE_QT4= gui svg network moc_build uic_build rcc_build qmake_build linguisttools_build
INSTALLS_ICONS= yes
OPTIONS_DEFINE= FONTFORGE
@@ -28,7 +28,7 @@ post-patch:
pre-configure:
cd ${WRKSRC}/src/messages && \
- ${LOCALBASE}/bin/lupdate-qt4 -noobsolete ../ -ts *.ts && \
- ${LOCALBASE}/bin/lrelease-qt4 *.ts
+ ${LUPDATE} -noobsolete ../ -ts *.ts && \
+ ${LRELEASE} *.ts
.include <bsd.port.mk>