aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/jakarta-commons-jxpath/Makefile42
-rw-r--r--devel/jakarta-commons-jxpath/distinfo3
-rw-r--r--devel/jakarta-commons-jxpath/pkg-descr6
4 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 653c726d7c64..aeca35236c47 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -464,6 +464,7 @@
SUBDIR += jakarta-commons-chain
SUBDIR += jakarta-commons-configuration
SUBDIR += jakarta-commons-io
+ SUBDIR += jakarta-commons-jxpath
SUBDIR += jakelib2
SUBDIR += jam
SUBDIR += java-util-concurrent
diff --git a/devel/jakarta-commons-jxpath/Makefile b/devel/jakarta-commons-jxpath/Makefile
new file mode 100644
index 000000000000..53065ca0c9f4
--- /dev/null
+++ b/devel/jakarta-commons-jxpath/Makefile
@@ -0,0 +1,42 @@
+# ports collection makefile for: Jakarta Commons IO
+# Date created: February 08, 2007
+# Whom: Nemo Liu <nemoliu@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= commons-jxpath
+PORTVERSION= 1.2
+CATEGORIES= devel www java
+MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
+MASTER_SITE_SUBDIR= ${PORTNAME:S,-,/,}/binaries
+PKGNAMEPREFIX= jakarta-
+
+MAINTAINER= nemoliu@gmail.com
+COMMENT= Utilities for manipulating Java Beans using the XPath syntax
+
+USE_JAVA= yes
+JAVA_VERSION= 1.2+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${PORTNAME}.jar..."
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}-${PORTVERSION}.jar ${JAVAJARDIR}/${PORTNAME}.jar
+ @${ECHO_MSG} " [ DONE ]"
+
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}/..."
+ @cd ${WRKSRC}/docs \
+ && ${FIND} . -type d -exec ${MKDIR} ${DOCSDIR}/{} \; \
+ && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
+ @${ECHO_MSG} " [ DONE ]"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/jakarta-commons-jxpath/distinfo b/devel/jakarta-commons-jxpath/distinfo
new file mode 100644
index 000000000000..b0b887c3dffd
--- /dev/null
+++ b/devel/jakarta-commons-jxpath/distinfo
@@ -0,0 +1,3 @@
+MD5 (commons-jxpath-1.2.tar.gz) = 1730dae5f0ef0594a47ead5d1a4ac41b
+SHA256 (commons-jxpath-1.2.tar.gz) = c78ba33996c86d5f95f8dfc28a1cf387f8d96539ed48e8448539c786cc4f5865
+SIZE (commons-jxpath-1.2.tar.gz) = 903113
diff --git a/devel/jakarta-commons-jxpath/pkg-descr b/devel/jakarta-commons-jxpath/pkg-descr
new file mode 100644
index 000000000000..2de18b2de3c8
--- /dev/null
+++ b/devel/jakarta-commons-jxpath/pkg-descr
@@ -0,0 +1,6 @@
+The org.apache.commons.jxpath package defines a simple interpreter of an
+expression language called XPath. JXPath applies XPath expressions to
+graphs of objects of all kinds: JavaBeans, Maps, Servlet contexts, DOM
+etc, including mixtures thereof.
+
+WWW: http://jakarta.apache.org/commons/jxpath/