aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/pure-sockets/Makefile39
-rw-r--r--net/pure-sockets/distinfo2
-rw-r--r--net/pure-sockets/pkg-descr6
4 files changed, 48 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index bc63486c366a..da442df7e8be 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -831,6 +831,7 @@
SUBDIR += ptpd
SUBDIR += ptpd2
SUBDIR += ptunnel
+ SUBDIR += pure-sockets
SUBDIR += pvm
SUBDIR += pvm++
SUBDIR += pxe
diff --git a/net/pure-sockets/Makefile b/net/pure-sockets/Makefile
new file mode 100644
index 000000000000..d1a42ce10eb1
--- /dev/null
+++ b/net/pure-sockets/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: pure-sockets
+# Date created: 2011-03-18
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pure-sockets
+PORTVERSION= 0.4
+CATEGORIES= net
+MASTER_SITES= http://pure-lang.googlecode.com/files/
+
+MAINTAINER= lichray@gmail.com
+COMMENT= Pure language interface to the Berkeley socket functions
+
+BUILD_DEPENDS+= clang>=2.8:${PORTSDIR}/lang/clang
+LIB_DEPENDS+= pure.7:${PORTSDIR}/lang/pure
+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+PLIST_FILES= lib/pure/sockets.pure \
+ lib/pure/sockets.so
+
+USE_GMAKE= yes
+
+MAKE_ARGS+= prefix=${PREFIX} CPPFLAGS+=-I${LOCALBASE}/include \
+ LDFLAGS+=-L${LOCALBASE}/lib CFLAGS="${CFLAGS}"
+
+PORTEXAMPLES= *
+
+.include <bsd.port.pre.mk>
+
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/pure-sockets/distinfo b/net/pure-sockets/distinfo
new file mode 100644
index 000000000000..e38c251fec29
--- /dev/null
+++ b/net/pure-sockets/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pure-sockets-0.4.tar.gz) = 9a6279d1ca9d520e650800b0ec5311d5f06cac141f98773cf467a1d70a0a4eca
+SIZE (pure-sockets-0.4.tar.gz) = 40275
diff --git a/net/pure-sockets/pkg-descr b/net/pure-sockets/pkg-descr
new file mode 100644
index 000000000000..4e873af0e78c
--- /dev/null
+++ b/net/pure-sockets/pkg-descr
@@ -0,0 +1,6 @@
+Pure interface to the Berkeley socket functions. Provides most of the core
+functionality, so you can create sockets for both stream and datagram based
+protocols and use these to transmit messages. Unix-style file sockets are
+also available if the host system supports them.
+
+WWW: http://docs.pure-lang.googlecode.com/hg/pure-sockets.html