aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/closure-compiler/Makefile28
-rw-r--r--www/closure-compiler/distinfo3
-rw-r--r--www/closure-compiler/files/closure-compiler.in5
-rw-r--r--www/closure-compiler/pkg-descr8
-rw-r--r--www/closure-compiler/pkg-plist4
6 files changed, 49 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 082b00f9b336..7f657c100729 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -97,6 +97,7 @@
SUBDIR += clearsilver
SUBDIR += clearsilver-python
SUBDIR += clickheat
+ SUBDIR += closure-compiler
SUBDIR += cmsmadesimple
SUBDIR += cntlm
SUBDIR += cocoon
diff --git a/www/closure-compiler/Makefile b/www/closure-compiler/Makefile
new file mode 100644
index 000000000000..8725ee939be5
--- /dev/null
+++ b/www/closure-compiler/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: closure-compiler
+# Date created: 2009-11-14
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= closure-compiler
+PORTVERSION= 20091113
+CATEGORIES= www java
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+DISTNAME= compiler-${PORTVERSION}
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Closure Compiler
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+SUB_FILES= closure-compiler
+SUB_LIST= JAVA="${JAVA}"
+USE_JAVA= yes
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/compiler.jar ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/closure-compiler ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/www/closure-compiler/distinfo b/www/closure-compiler/distinfo
new file mode 100644
index 000000000000..3898bc8cbbe4
--- /dev/null
+++ b/www/closure-compiler/distinfo
@@ -0,0 +1,3 @@
+MD5 (compiler-20091113.tar.gz) = 94f0807e92ef2f18b77d86942eadcbdd
+SHA256 (compiler-20091113.tar.gz) = 4a48ae46bf7828aafb7503b08e7493d8b026d04bd5803229235187b1dc6ef035
+SIZE (compiler-20091113.tar.gz) = 3763939
diff --git a/www/closure-compiler/files/closure-compiler.in b/www/closure-compiler/files/closure-compiler.in
new file mode 100644
index 000000000000..3dc34eb50263
--- /dev/null
+++ b/www/closure-compiler/files/closure-compiler.in
@@ -0,0 +1,5 @@
+#!/bin/sh -f
+
+DATADIR="%%DATADIR%%"
+
+exec %%JAVA%% -jar "${DATADIR}/compiler.jar" $*
diff --git a/www/closure-compiler/pkg-descr b/www/closure-compiler/pkg-descr
new file mode 100644
index 000000000000..33e45502c7bd
--- /dev/null
+++ b/www/closure-compiler/pkg-descr
@@ -0,0 +1,8 @@
+Closure Compiler is a JavaScript optimizing compiler. It parses your
+JavaScript, analyzes it, removes dead code and rewrites and minimizes
+what's left. It also checks syntax, variable references, and types,
+and warns about common JavaScript pitfalls. It is used in many of
+Google's JavaScript apps, including Gmail, Google Web Search, Google
+Maps, and Google Docs.
+
+WWW: http://code.google.com/closure/compiler/
diff --git a/www/closure-compiler/pkg-plist b/www/closure-compiler/pkg-plist
new file mode 100644
index 000000000000..fc86a72e344f
--- /dev/null
+++ b/www/closure-compiler/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+%%DATADIR%%/compiler.jar
+bin/closure-compiler
+@dirrmtry %%DATADIR%%