aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--chinese/iiimf-le-xcin/Makefile1
-rw-r--r--games/xfrisk/Makefile3
-rw-r--r--www/amaya/Makefile4
-rw-r--r--x11-fonts/code2000/Makefile2
-rw-r--r--x11-wm/icewm/Makefile4
5 files changed, 9 insertions, 5 deletions
diff --git a/chinese/iiimf-le-xcin/Makefile b/chinese/iiimf-le-xcin/Makefile
index 43a6c859db38..81cb43ae5a70 100644
--- a/chinese/iiimf-le-xcin/Makefile
+++ b/chinese/iiimf-le-xcin/Makefile
@@ -18,6 +18,7 @@ COMMENT= IIIMF xcin language engine, a traditional Chinese input method
EXTRACT_DEPENDS= rpm2cpio.pl:${PORTSDIR}/archivers/rpm2cpio
RUN_DEPENDS= iiimd:${PORTSDIR}/textproc/iiimf-server
+USE_XORG= x11 xproto
WRKSRC= ${WRKDIR}/iiimf-xcin
USE_BZIP2= yes
USE_GNOME= libxml2
diff --git a/games/xfrisk/Makefile b/games/xfrisk/Makefile
index 4ba26c425d42..336a5a5c8885 100644
--- a/games/xfrisk/Makefile
+++ b/games/xfrisk/Makefile
@@ -23,4 +23,7 @@ NO_INSTALL_MANPAGES= yes
WRKSRC= ${WRKDIR}/XFrisk
USE_GMAKE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
.include <bsd.port.mk>
diff --git a/www/amaya/Makefile b/www/amaya/Makefile
index d0a1bde4dbd8..1bc44868e0a2 100644
--- a/www/amaya/Makefile
+++ b/www/amaya/Makefile
@@ -7,7 +7,7 @@
PORTNAME= amaya
PORTVERSION= 9.55
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://www.w3.org/Amaya/Distribution/ \
ftp://ftp.w3.org/pub/amaya/ \
@@ -30,7 +30,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
WRKSRC= ${WRKDIR}/Amaya/obj
-USE_XORG= xft x11
+USE_XORG= xft x11 xt
USE_GMAKE= yes
USE_GNOME= gtk12 imlib
USE_ICONV= yes
diff --git a/x11-fonts/code2000/Makefile b/x11-fonts/code2000/Makefile
index ab137e53a8b1..f3fa0d28f618 100644
--- a/x11-fonts/code2000/Makefile
+++ b/x11-fonts/code2000/Makefile
@@ -11,7 +11,7 @@ PORTREVISION= 1
CATEGORIES= x11-fonts
MASTER_SITES= http://code2000.net/
DISTFILES= ${PORTNAME:U}${EXTRACT_SUFX:U}
-DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}_${PORTREVISION}
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}_0
MAINTAINER= thierry@FreeBSD.org
COMMENT= Shareware demo Unicode TrueType font
diff --git a/x11-wm/icewm/Makefile b/x11-wm/icewm/Makefile
index d0ddaaa33607..2ee48cd43d36 100644
--- a/x11-wm/icewm/Makefile
+++ b/x11-wm/icewm/Makefile
@@ -7,7 +7,7 @@
PORTNAME= icewm
PORTVERSION= 1.2.35
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-wm
MASTER_SITES= SF
@@ -15,7 +15,7 @@ MAINTAINER= alepulver@FreeBSD.org
COMMENT= Window Manager designed for speed, usability and consistency
WANT_GNOME= yes
-USE_XORG= x11 ice xinerama xext
+USE_XORG= x11 ice xinerama xext xrandr
USE_GNOME= gnometarget
USE_GMAKE= yes
GNU_CONFIGURE= yes