aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/orsa/Makefile4
-rw-r--r--audio/snd/Makefile4
-rw-r--r--benchmarks/sipp/Makefile3
-rw-r--r--biology/adun/Makefile4
-rw-r--r--cad/gmsh/Makefile3
-rw-r--r--graphics/qgis/Makefile4
-rw-r--r--mail/bogofilter/Makefile4
-rw-r--r--math/PDL/Makefile4
-rw-r--r--math/asymptote/Makefile4
-rw-r--r--math/freefem++/Makefile3
-rw-r--r--math/labplot/Makefile4
-rw-r--r--math/orpie/Makefile4
-rw-r--r--math/p5-Math-GSL/Makefile4
-rw-r--r--math/py-gsl/Makefile4
-rw-r--r--math/ruby-gsl/Makefile3
-rw-r--r--math/yacas/Makefile4
-rw-r--r--science/getdp/Makefile4
-rw-r--r--science/gnudatalanguage/Makefile4
-rw-r--r--science/kst/Makefile3
-rw-r--r--science/kst2/Makefile3
20 files changed, 40 insertions, 34 deletions
diff --git a/astro/orsa/Makefile b/astro/orsa/Makefile
index c2a01cd57b0e..a11dfb64c732 100644
--- a/astro/orsa/Makefile
+++ b/astro/orsa/Makefile
@@ -8,7 +8,7 @@
PORTNAME= orsa
PORTVERSION= 0.7.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= astro
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,7 +16,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Orbit Reconstruction, Simulation and Analysis
-LIB_DEPENDS= gsl.10:${PORTSDIR}/math/gsl \
+LIB_DEPENDS= gsl.12:${PORTSDIR}/math/gsl \
cln.4:${PORTSDIR}/math/cln \
fftw.2:${PORTSDIR}/math/fftw \
ginac-1.3.8:${PORTSDIR}/math/GiNaC
diff --git a/audio/snd/Makefile b/audio/snd/Makefile
index 5872b9bb161d..09213a7dcc9b 100644
--- a/audio/snd/Makefile
+++ b/audio/snd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= snd
PORTVERSION= 7.8
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Multitracking sound editor and utilities
-LIB_DEPENDS= gsl.10:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.12:${PORTSDIR}/math/gsl
ALL_TARGET= audinfo snd sndinfo sndplay sndrecord sndsine
CONFIGURE_ARGS= --with-float-samples \
diff --git a/benchmarks/sipp/Makefile b/benchmarks/sipp/Makefile
index f14e92c1795e..0ddcf896169e 100644
--- a/benchmarks/sipp/Makefile
+++ b/benchmarks/sipp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sipp
PORTVERSION= 3.0
+PORTREVISION= 1
CATEGORIES= benchmarks net
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-3.0.src
@@ -28,7 +29,7 @@ OPTIONS= OPENSSL "OpenSSL support (for digest auth and SIP over TLS)" on \
.include <bsd.port.pre.mk>
.if defined(WITH_GSL)
-LIB_DEPENDS+= gsl.10:${PORTSDIR}/math/gsl
+LIB_DEPENDS+= gsl.12:${PORTSDIR}/math/gsl
MAKE_ENV+= EXTRACPPFLAGS=-DHAVE_GSL \
EXTRACFLAGS=-DHAVE_GSL \
diff --git a/biology/adun/Makefile b/biology/adun/Makefile
index 823be34385da..a1a4abda0c30 100644
--- a/biology/adun/Makefile
+++ b/biology/adun/Makefile
@@ -7,7 +7,7 @@
PORTNAME= adun
PORTVERSION= 0.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= biology gnustep
MASTER_SITES= http://download.gna.org/adun/
DISTNAME= Adun${PORTVERSION}
@@ -15,7 +15,7 @@ DISTNAME= Adun${PORTVERSION}
MAINTAINER= gurkan@linuks.mine.nu
COMMENT= Molecular Simulator for GNUstep
-LIB_DEPENDS+= gsl.10:${PORTSDIR}/math/gsl
+LIB_DEPENDS+= gsl.12:${PORTSDIR}/math/gsl
USE_GNUSTEP= yes
USE_GNUSTEP_PREFIX= yes
diff --git a/cad/gmsh/Makefile b/cad/gmsh/Makefile
index abb0934c65fd..8bab0a0224fd 100644
--- a/cad/gmsh/Makefile
+++ b/cad/gmsh/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gmsh
PORTVERSION= 2.1.1
+PORTREVISION= 1
CATEGORIES= cad
MASTER_SITES= http://www.geuz.org/gmsh/src/
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
@@ -16,7 +17,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= An automatic 3D finite element mesh generator
RUN_DEPENDS= getdp:${PORTSDIR}/science/getdp
-LIB_DEPENDS= gsl.10:${PORTSDIR}/math/gsl \
+LIB_DEPENDS= gsl.12:${PORTSDIR}/math/gsl \
fltk.1:${PORTSDIR}/x11-toolkits/fltk
.if !defined(WITHOUT_TETGEN)
diff --git a/graphics/qgis/Makefile b/graphics/qgis/Makefile
index 5328b0b5c149..b86ef834ea4e 100644
--- a/graphics/qgis/Makefile
+++ b/graphics/qgis/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qgis
PORTVERSION= 0.7.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics geography
MASTER_SITES= SF
@@ -16,7 +16,7 @@ COMMENT= Geographical Information System (GIS) data viewer
LIB_DEPENDS= geos:${PORTSDIR}/graphics/geos \
proj:${PORTSDIR}/graphics/proj \
- gsl.10:${PORTSDIR}/math/gsl \
+ gsl.12:${PORTSDIR}/math/gsl \
gdal:${PORTSDIR}/graphics/gdal
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
diff --git a/mail/bogofilter/Makefile b/mail/bogofilter/Makefile
index 0ed89026c01c..bfb865cf731d 100644
--- a/mail/bogofilter/Makefile
+++ b/mail/bogofilter/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bogofilter
PORTVERSION= 1.1.6
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -40,7 +40,7 @@ USE_ICONV= yes
BF_LIBS+= -liconv
.endif
.if !defined(WITHOUT_GSL)
-LIB_DEPENDS+= gsl.10:${PORTSDIR}/math/gsl
+LIB_DEPENDS+= gsl.12:${PORTSDIR}/math/gsl
.else
CONFIGURE_ARGS+= --with-included-gsl
.endif
diff --git a/math/PDL/Makefile b/math/PDL/Makefile
index 10e38bb31d66..c60a32ff879d 100644
--- a/math/PDL/Makefile
+++ b/math/PDL/Makefile
@@ -8,7 +8,7 @@
PORTNAME= PDL
PORTVERSION= 2.4.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:S/$/:cpan/} \
${MASTER_SITE_SOURCEFORGE:S/$/:sf/}
@@ -28,7 +28,7 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/PGPLOT.pm:${PORTSDIR}/graphics/pgperl \
${SITE_PERL}/Term/ReadLine/readline.pm:${PORTSDIR}/devel/p5-ReadLine-Perl
LIB_DEPENDS= plplotd.11:${PORTSDIR}/math/plplot \
fftw.2:${PORTSDIR}/math/fftw \
- gsl.10:${PORTSDIR}/math/gsl
+ gsl.12:${PORTSDIR}/math/gsl
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_GL= yes
diff --git a/math/asymptote/Makefile b/math/asymptote/Makefile
index fc7805cf0982..06d75f12fb90 100644
--- a/math/asymptote/Makefile
+++ b/math/asymptote/Makefile
@@ -7,7 +7,7 @@
PORTNAME= asymptote
PORTVERSION= 1.42
-#PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
@@ -51,7 +51,7 @@ ALL_TARGET= asy
INSTALL_TARGET= install-asy
.if defined(WITH_GSL)
-LIB_DEPENDS+= gsl.10:${PORTSDIR}/math/gsl
+LIB_DEPENDS+= gsl.12:${PORTSDIR}/math/gsl
.endif
# Documentation
diff --git a/math/freefem++/Makefile b/math/freefem++/Makefile
index 5909e6358e47..5327388f5a51 100644
--- a/math/freefem++/Makefile
+++ b/math/freefem++/Makefile
@@ -7,6 +7,7 @@
PORTNAME= freefem++
DISTVERSION= 2.24-1
+PORTREVISION= 1
CATEGORIES= math science
MASTER_SITES= http://www.freefem.org/ff++/ftp/
@@ -17,7 +18,7 @@ LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk-threads \
fftw3.4:${PORTSDIR}/math/fftw3 \
umfpack.1:${PORTSDIR}/math/suitesparse \
arpack.1:${PORTSDIR}/math/arpack \
- gsl.10:${PORTSDIR}/math/gsl
+ gsl.12:${PORTSDIR}/math/gsl
BUILD_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick \
dvips:${PORTSDIR}/print/dvipsk-tetex \
pdflatex:${PORTSDIR}/print/teTeX-base
diff --git a/math/labplot/Makefile b/math/labplot/Makefile
index 6c776c7fdc83..8767e5a424fe 100644
--- a/math/labplot/Makefile
+++ b/math/labplot/Makefile
@@ -7,7 +7,7 @@
PORTNAME= LabPlot
PORTVERSION= 1.5.1.5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=labplot
@@ -18,7 +18,7 @@ COMMENT= LabPlot : Data analysis and visualisation
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
Magick.10:${PORTSDIR}/graphics/ImageMagick \
audiofile.0:${PORTSDIR}/audio/libaudiofile \
- gsl.10:${PORTSDIR}/math/gsl \
+ gsl.12:${PORTSDIR}/math/gsl \
jasper.4:${PORTSDIR}/graphics/jasper \
fftw3.4:${PORTSDIR}/math/fftw3 \
netcdf:${PORTSDIR}/science/netcdf \
diff --git a/math/orpie/Makefile b/math/orpie/Makefile
index d0e22ec78f1e..b6d017a7b45c 100644
--- a/math/orpie/Makefile
+++ b/math/orpie/Makefile
@@ -7,7 +7,7 @@
PORTNAME= orpie
PORTVERSION= 1.4.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES+= math
MASTER_SITES= http://www.eecs.umich.edu/~pelzlpj/orpie/
@@ -15,7 +15,7 @@ MAINTAINER= dylan@dylex.net
COMMENT= A fullscreen RPN calculator for the console
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
-LIB_DEPENDS= gsl.10:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.12:${PORTSDIR}/math/gsl
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/math/p5-Math-GSL/Makefile b/math/p5-Math-GSL/Makefile
index 9402a5c93144..8f27eda320bb 100644
--- a/math/p5-Math-GSL/Makefile
+++ b/math/p5-Math-GSL/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Math-GSL
PORTVERSION= 0.01
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Math
@@ -16,7 +16,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= A perl interface to GNU Scientific Library
-LIB_DEPENDS= gsl.10:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.12:${PORTSDIR}/math/gsl
PERL_CONFIGURE= yes
MAKE_ENV= INC="-I${LOCALBASE}/include"
diff --git a/math/py-gsl/Makefile b/math/py-gsl/Makefile
index 404bfc3e25fe..ae631dc15de6 100644
--- a/math/py-gsl/Makefile
+++ b/math/py-gsl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gsl
PORTVERSION= 0.3.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pygsl
@@ -20,7 +20,7 @@ COMMENT= Python interface to GNU Scientific Library
BUILD_DEPENDS= ${PYNUMERIC}
RUN_DEPENDS= ${PYNUMERIC}
-LIB_DEPENDS= gsl.10:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.12:${PORTSDIR}/math/gsl
PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S,^${LOCALBASE}/,,g}
USE_PYTHON= yes
diff --git a/math/ruby-gsl/Makefile b/math/ruby-gsl/Makefile
index 7972c57aabfc..2d721ed8d71a 100644
--- a/math/ruby-gsl/Makefile
+++ b/math/ruby-gsl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gsl
PORTVERSION= 1.9.2
+PORTREVISION= 1
CATEGORIES= math ruby
MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
MASTER_SITE_SUBDIR= rb-${PORTNAME}
@@ -17,7 +18,7 @@ DIST_SUBDIR= ruby
MAINTAINER= clsung@FreeBSD.org
COMMENT= A Ruby extension library for GSL (GNU Scientific Library)
-LIB_DEPENDS= gsl.10:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.12:${PORTSDIR}/math/gsl
USE_RUBY= yes
USE_RUBY_SETUP= yes
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index a6c858055ef1..5d760d0a6a74 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -8,14 +8,14 @@
PORTNAME= yacas
PORTVERSION= 1.0.61
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= http://yacas.sourceforge.net/backups/
MAINTAINER= shaun@FreeBSD.org
COMMENT= Yet Another Computer Algebra System
-LIB_DEPENDS= gsl.10:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.12:${PORTSDIR}/math/gsl
USE_AUTOTOOLS= libtool:15
USE_PERL5_BUILD= yes
diff --git a/science/getdp/Makefile b/science/getdp/Makefile
index de81b5c0d50b..b716bd018d21 100644
--- a/science/getdp/Makefile
+++ b/science/getdp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= getdp
PORTVERSION= 1.2.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= science
MASTER_SITES= http://www.geuz.org/getdp/src/
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
@@ -16,7 +16,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= A rather general finite element solver using mixed finite elements
-LIB_DEPENDS= gsl.10:${PORTSDIR}/math/gsl \
+LIB_DEPENDS= gsl.12:${PORTSDIR}/math/gsl \
lapack.4:${PORTSDIR}/math/lapack
USE_FORTRAN= yes
diff --git a/science/gnudatalanguage/Makefile b/science/gnudatalanguage/Makefile
index d394ec13c927..b01dda6c7125 100644
--- a/science/gnudatalanguage/Makefile
+++ b/science/gnudatalanguage/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnudatalanguage
DISTVERSION= 0.9pre6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -32,7 +32,7 @@ COMMENT?= GDL, a free IDL compatible incremental compiler
#---------------------------------------------------------------------------
LIB_DEPENDS+= plplotd.11:${PORTSDIR}/math/plplot \
- gsl.10:${PORTSDIR}/math/gsl \
+ gsl.12:${PORTSDIR}/math/gsl \
readline.5:${PORTSDIR}/devel/readline
USE_AUTOTOOLS= libtool:15
diff --git a/science/kst/Makefile b/science/kst/Makefile
index b81c7368941c..9e5d374a16de 100644
--- a/science/kst/Makefile
+++ b/science/kst/Makefile
@@ -6,6 +6,7 @@
PORTNAME= kst
PORTVERSION= 1.5.0
+PORTREVISION= 1
CATEGORIES= science kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/apps/KDE3.x/scientific
@@ -14,7 +15,7 @@ MAINTAINER= makc@issp.ac.ru
COMMENT= Data viewing program for KDE
LIB_DEPENDS= cfitsio.0:${PORTSDIR}/astro/cfitsio \
- gsl.10:${PORTSDIR}/math/gsl
+ gsl.12:${PORTSDIR}/math/gsl
USE_KDELIBS_VER=3
USE_GMAKE= yes
diff --git a/science/kst2/Makefile b/science/kst2/Makefile
index b81c7368941c..9e5d374a16de 100644
--- a/science/kst2/Makefile
+++ b/science/kst2/Makefile
@@ -6,6 +6,7 @@
PORTNAME= kst
PORTVERSION= 1.5.0
+PORTREVISION= 1
CATEGORIES= science kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/apps/KDE3.x/scientific
@@ -14,7 +15,7 @@ MAINTAINER= makc@issp.ac.ru
COMMENT= Data viewing program for KDE
LIB_DEPENDS= cfitsio.0:${PORTSDIR}/astro/cfitsio \
- gsl.10:${PORTSDIR}/math/gsl
+ gsl.12:${PORTSDIR}/math/gsl
USE_KDELIBS_VER=3
USE_GMAKE= yes