aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11/Makefile1
-rw-r--r--x11/xfce4-conf/Makefile40
-rw-r--r--x11/xfce4-conf/distinfo3
-rw-r--r--x11/xfce4-conf/pkg-descr3
-rw-r--r--x11/xfce4-conf/pkg-plist57
5 files changed, 104 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 95782e7a69e9..17c92bb6cfaf 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -362,6 +362,7 @@
SUBDIR += xf86rushproto
SUBDIR += xf86vidmodeproto
SUBDIR += xfce4-clipman-plugin
+ SUBDIR += xfce4-conf
SUBDIR += xfce4-quicklauncher-plugin
SUBDIR += xfce4-screenshooter-plugin
SUBDIR += xfce4-taskmanager
diff --git a/x11/xfce4-conf/Makefile b/x11/xfce4-conf/Makefile
new file mode 100644
index 000000000000..3d1599310389
--- /dev/null
+++ b/x11/xfce4-conf/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: xfce4-conf
+# Date created: 28 August 2008
+# Whom: Oliver Lehmann <oliver@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xfce4-conf
+PORTVERSION= 4.6.0
+CATEGORIES= x11 xfce
+MASTER_SITES= ${MASTER_SITE_XFCE}
+DISTNAME= xfconf-${PORTVERSION}
+DIST_SUBDIR= xfce4
+
+MAINTAINER= oliver@FreeBSD.org
+COMMENT= XFce 4 configuration mananger
+
+LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+
+USE_AUTOTOOLS= libtool:15
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GNOME= glib20 gnometarget gnomehack gtk20 intltool intlhack pkgconfig
+USE_LDCONFIG= yes
+USE_XFCE= configenv libutil
+
+OPTIONS= GTKDOC "install the library documentation" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GTKDOC)
+BUILD_DEPENDS+= gtkdocize:${PORTSDIR}/textproc/gtk-doc
+CONFIGURE_ARGS+=--enable-gtk-doc
+.else
+CONFIGURE_ARGS+=--disable-gtk-doc
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11/xfce4-conf/distinfo b/x11/xfce4-conf/distinfo
new file mode 100644
index 000000000000..3d66db3ebbc5
--- /dev/null
+++ b/x11/xfce4-conf/distinfo
@@ -0,0 +1,3 @@
+MD5 (xfce4/xfconf-4.6.0.tar.bz2) = 38595f78379eb1f456e97b393fdafd20
+SHA256 (xfce4/xfconf-4.6.0.tar.bz2) = 1d7a85e2e0058e778fbecd684bf5b236b4784b21ea35ac3cdae347012e63f69d
+SIZE (xfce4/xfconf-4.6.0.tar.bz2) = 435165
diff --git a/x11/xfce4-conf/pkg-descr b/x11/xfce4-conf/pkg-descr
new file mode 100644
index 000000000000..465c9a16c8ac
--- /dev/null
+++ b/x11/xfce4-conf/pkg-descr
@@ -0,0 +1,3 @@
+XFce 4 configuration mananger
+
+WWW: http://www.xfce.org/projects/libraries/
diff --git a/x11/xfce4-conf/pkg-plist b/x11/xfce4-conf/pkg-plist
new file mode 100644
index 000000000000..a11b9528a403
--- /dev/null
+++ b/x11/xfce4-conf/pkg-plist
@@ -0,0 +1,57 @@
+bin/xfconf-query
+include/xfce4/xfconf-0/xfconf/xfconf-binding.h
+include/xfce4/xfconf-0/xfconf/xfconf-channel.h
+include/xfce4/xfconf-0/xfconf/xfconf-errors.h
+include/xfce4/xfconf-0/xfconf/xfconf-types.h
+include/xfce4/xfconf-0/xfconf/xfconf.h
+lib/libxfconf-0.so.2
+lib/libxfconf-0.so
+lib/libxfconf-0.la
+lib/libxfconf-0.a
+libdata/pkgconfig/libxfconf-0.pc
+libexec/xfconfd
+share/dbus-1/services/org.xfce.Xfconf.service
+share/gtk-doc/html/xfconf/ch01.html
+share/gtk-doc/html/xfconf/ch02.html
+share/gtk-doc/html/xfconf/ch03.html
+share/gtk-doc/html/xfconf/home.png
+share/gtk-doc/html/xfconf/index.html
+share/gtk-doc/html/xfconf/index.sgml
+share/gtk-doc/html/xfconf/left.png
+share/gtk-doc/html/xfconf/right.png
+share/gtk-doc/html/xfconf/style.css
+share/gtk-doc/html/xfconf/up.png
+share/gtk-doc/html/xfconf/xfconf-xfconf-backend.html
+share/gtk-doc/html/xfconf/xfconf-xfconf-binding.html
+share/gtk-doc/html/xfconf/xfconf-xfconf-channel.html
+share/gtk-doc/html/xfconf/xfconf-xfconf-errors.html
+share/gtk-doc/html/xfconf/xfconf-xfconf-types.html
+share/gtk-doc/html/xfconf/xfconf-xfconf.html
+share/gtk-doc/html/xfconf/xfconf.devhelp
+share/gtk-doc/html/xfconf/xfconf.devhelp2
+share/locale/ca/LC_MESSAGES/xfconf.mo
+share/locale/cs/LC_MESSAGES/xfconf.mo
+share/locale/da/LC_MESSAGES/xfconf.mo
+share/locale/de/LC_MESSAGES/xfconf.mo
+share/locale/es/LC_MESSAGES/xfconf.mo
+share/locale/eu/LC_MESSAGES/xfconf.mo
+share/locale/fi/LC_MESSAGES/xfconf.mo
+share/locale/fr/LC_MESSAGES/xfconf.mo
+share/locale/hu/LC_MESSAGES/xfconf.mo
+share/locale/id/LC_MESSAGES/xfconf.mo
+share/locale/ja/LC_MESSAGES/xfconf.mo
+share/locale/nb/LC_MESSAGES/xfconf.mo
+share/locale/nl/LC_MESSAGES/xfconf.mo
+share/locale/pt_BR/LC_MESSAGES/xfconf.mo
+share/locale/ro/LC_MESSAGES/xfconf.mo
+share/locale/ru/LC_MESSAGES/xfconf.mo
+share/locale/sv/LC_MESSAGES/xfconf.mo
+share/locale/tr/LC_MESSAGES/xfconf.mo
+share/locale/uk/LC_MESSAGES/xfconf.mo
+share/locale/zh_CN/LC_MESSAGES/xfconf.mo
+@dirrm share/gtk-doc/html/xfconf
+@dirrmtry share/gtk-doc/html
+@dirrmtry share/gtk-doc
+@dirrm include/xfce4/xfconf-0/xfconf
+@dirrm include/xfce4/xfconf-0
+@dirrmtry include/xfce4