aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--devel/Makefile1
-rw-r--r--devel/zmq-devel/Makefile24
-rw-r--r--devel/zmq-devel/pkg-descr3
-rw-r--r--net/Makefile1
-rw-r--r--net/libzmq3/Makefile38
-rw-r--r--net/libzmq3/distinfo (renamed from devel/zmq-devel/distinfo)0
-rw-r--r--net/libzmq3/files/patch-tests__test_connect_delay.cpp (renamed from devel/zmq-devel/files/patch-tests__test_connect_delay.cpp)0
-rw-r--r--net/libzmq3/pkg-descr8
-rw-r--r--net/libzmq3/pkg-plist (renamed from devel/zmq-devel/pkg-plist)0
10 files changed, 48 insertions, 28 deletions
diff --git a/MOVED b/MOVED
index e6275674a1c4..3ffeb46c60b7 100644
--- a/MOVED
+++ b/MOVED
@@ -5268,3 +5268,4 @@ audio/mpc|audio/musicpc|2013-11-19|Renamed to avoid conflict with math/mpc
deskutils/q4wine|emulators/q4wine|2013-11-26|Move to better category
devel/p5-MooseX-ChainedAccessors||2013-11-27|Has expired: Marked as depreciated upstream
devel/py-distribute|devel/py-setuptools|2013-11-27|Replaced with setuptools
+devel/zmq-devel|net/libzmq3|2013-11-28|Rename according to upstream and move to more suitable category
diff --git a/devel/Makefile b/devel/Makefile
index fe9259681717..eabbd6d38545 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4531,7 +4531,6 @@
SUBDIR += z80asm
SUBDIR += z80ex
SUBDIR += zmq
- SUBDIR += zmq-devel
SUBDIR += zookeeper
SUBDIR += zpu-binutils
SUBDIR += zpu-gcc
diff --git a/devel/zmq-devel/Makefile b/devel/zmq-devel/Makefile
deleted file mode 100644
index cd0c0f3a8ba8..000000000000
--- a/devel/zmq-devel/Makefile
+++ /dev/null
@@ -1,24 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= zmq
-PORTVERSION= 3.2.4
-CATEGORIES= devel net
-MASTER_SITES= http://download.zeromq.org/
-PKGNAMESUFFIX= -devel
-DISTNAME= zeromq-${DISTVERSION}
-
-MAINTAINER= koobs@FreeBSD.org
-COMMENT= Lightweight messaging kernel
-
-USES= pathfix
-USE_LDCONFIG= yes
-
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-silent-rules
-
-CONFLICTS= zmq-[0-9]*
-
-regression-test:
- cd ${WRKSRC} && ${MAKE} check
-
-.include <bsd.port.mk>
diff --git a/devel/zmq-devel/pkg-descr b/devel/zmq-devel/pkg-descr
deleted file mode 100644
index 3cba75d19e81..000000000000
--- a/devel/zmq-devel/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-An open source message queue optimised for performance.
-
-WWW: http://www.zeromq.org/
diff --git a/net/Makefile b/net/Makefile
index 884a74c9184b..a870730bbf8c 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -348,6 +348,7 @@
SUBDIR += libunp
SUBDIR += libutp
SUBDIR += libvncserver
+ SUBDIR += libzmq3
SUBDIR += libzmq4
SUBDIR += liferea
SUBDIR += linc
diff --git a/net/libzmq3/Makefile b/net/libzmq3/Makefile
new file mode 100644
index 000000000000..6576a1ebfff7
--- /dev/null
+++ b/net/libzmq3/Makefile
@@ -0,0 +1,38 @@
+# $FreeBSD$
+
+PORTNAME= libzmq3
+PORTVERSION= 3.2.4
+CATEGORIES= net
+MASTER_SITES= http://download.zeromq.org/
+DISTNAME= zeromq-${DISTVERSION}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= ZeroMQ core library (Version 3)
+
+LICENSE= LGPL3
+
+USES= pathfix
+USE_LDCONFIG= yes
+
+OPTIONS_DEFINE= DEBUG PGM
+PGM_DESC= Reliable multicast transport using PGM via OpenPGM
+
+DEBUG_CONFIGURE_ON= --enable-debug
+PGM_CONFIGURE_ON= --with-system-pgm
+PGM_LIB_DEPENDS= libpgm.so:${PORTSDIR}/net/openpgm
+PGM_USES= pkgconfig
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDEBUG}
+WITH_DEBUG= yes
+.endif
+
+GNU_CONFIGURE= yes
+
+CONFLICTS= zmq-[0-9]* libzmq[^3]-[0-9]*
+
+regression-test: build
+ cd ${WRKSRC} && ${MAKE} check
+
+.include <bsd.port.mk>
diff --git a/devel/zmq-devel/distinfo b/net/libzmq3/distinfo
index cf366bafbb0e..cf366bafbb0e 100644
--- a/devel/zmq-devel/distinfo
+++ b/net/libzmq3/distinfo
diff --git a/devel/zmq-devel/files/patch-tests__test_connect_delay.cpp b/net/libzmq3/files/patch-tests__test_connect_delay.cpp
index 7143d96b8564..7143d96b8564 100644
--- a/devel/zmq-devel/files/patch-tests__test_connect_delay.cpp
+++ b/net/libzmq3/files/patch-tests__test_connect_delay.cpp
diff --git a/net/libzmq3/pkg-descr b/net/libzmq3/pkg-descr
new file mode 100644
index 000000000000..ce51410fdf40
--- /dev/null
+++ b/net/libzmq3/pkg-descr
@@ -0,0 +1,8 @@
+ZeroMQ - Distributed Computing Made Simple
+
+ * The socket library that acts as a concurrency framework.
+ * Carries messages across inproc, IPC, TCP, and multicast.
+ * Connect N-to-N via fanout, pubsub, pipeline, request-reply.
+ * Asynch I/O for scalable multicore message-passing apps.
+
+WWW: http://www.zeromq.org/
diff --git a/devel/zmq-devel/pkg-plist b/net/libzmq3/pkg-plist
index cbcdcd17a780..cbcdcd17a780 100644
--- a/devel/zmq-devel/pkg-plist
+++ b/net/libzmq3/pkg-plist