aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/oss/Makefile13
-rw-r--r--sysutils/amrstat/Makefile11
2 files changed, 13 insertions, 11 deletions
diff --git a/audio/oss/Makefile b/audio/oss/Makefile
index a1b63bb9634a..76a8b60bf148 100644
--- a/audio/oss/Makefile
+++ b/audio/oss/Makefile
@@ -55,17 +55,18 @@ PROTO_SBINDIR= ${PROTO_DIR}/usr/sbin
PROTO_MANDIR= ${PROTO_DIR}/usr/share/man
PROTO_OSSLIBDIR=${PROTO_DIR}${PREFIX}/lib/oss
-OPTIONS= VORBIS "OGG/Vorbis audio support" on
-
.if !exists(${SRC_BASE}/sys/Makefile)
IGNORE= requires kernel source to be installed
.endif
-.include <bsd.port.pre.mk>
+CONFIGURE_ENV= HOSTCC="${CC}"
+
+OPTIONS_DEFINE= VORBIS
+OPTIONS_DEFAULT=VORBIS
-CONFIGURE_ENV+= HOSTCC="${CC}"
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_VORBIS)
+.if ${PORT_OPTIONS:MVORBIS}
LIB_DEPENDS+= vorbisfile.6:${PORTSDIR}/audio/libvorbis
CONFIGURE_ENV+= OGG_SUPPORT=YES
.endif
@@ -124,4 +125,4 @@ do-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/amrstat/Makefile b/sysutils/amrstat/Makefile
index c1792bef1c71..114b98699478 100644
--- a/sysutils/amrstat/Makefile
+++ b/sysutils/amrstat/Makefile
@@ -14,14 +14,15 @@ MASTER_SITE_SUBDIR= jkim
MAINTAINER= jkim@FreeBSD.org
COMMENT= Utility for LSI Logic's MegaRAID RAID controllers
-OPTIONS= MEGARC "Also install LSI megarc binary port.." off
+OPTIONS_DEFINE= MEGARC
+MEGARC_DESC= "Install LSI megarc binary port"
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
# We may want this for periodic script and to actually be able
# to fix something in case amrstat reports degraded RAID.
-.if defined(WITH_MEGARC)
-RUN_DEPENDS= ${LOCALBASE}/sbin/megarc:${PORTSDIR}/sysutils/megarc
+.if ${PORT_OPTIONS:MMEGARC}
+RUN_DEPENDS+= ${LOCALBASE}/sbin/megarc:${PORTSDIR}/sysutils/megarc
.endif
ALL_TARGET= ${PORTNAME}
@@ -41,4 +42,4 @@ do-install:
${INSTALL_SCRIPT} -d ${PREFIX}/etc/periodic/daily
${INSTALL_SCRIPT} ${WRKDIR}/${PERIODICSCRIPT} ${PREFIX}/etc/periodic/daily
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>