aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/R-cran-htmlwidgets/Makefile20
-rw-r--r--www/R-cran-htmlwidgets/distinfo2
-rw-r--r--www/R-cran-htmlwidgets/pkg-descr5
4 files changed, 28 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index b4e739438f1c..05e86f127dd3 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -6,6 +6,7 @@
SUBDIR += MT
SUBDIR += R-cran-RgoogleMaps
SUBDIR += R-cran-Rpad
+ SUBDIR += R-cran-htmlwidgets
SUBDIR += R-cran-httpuv
SUBDIR += R-cran-httr
SUBDIR += R-cran-scrapeR
diff --git a/www/R-cran-htmlwidgets/Makefile b/www/R-cran-htmlwidgets/Makefile
new file mode 100644
index 000000000000..67ac0b964a63
--- /dev/null
+++ b/www/R-cran-htmlwidgets/Makefile
@@ -0,0 +1,20 @@
+# Created by: TAKATSU Tomonari <tota@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= htmlwidgets
+PORTVERSION= 0.5
+CATEGORIES= www
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= HTML Widgets for R
+
+LICENSE= MIT
+
+RUN_DEPENDS= R-cran-htmltools>=0.2.6:${PORTSDIR}/textproc/R-cran-htmltools \
+ R-cran-jsonlite>=0.9.16:${PORTSDIR}/converters/R-cran-jsonlite \
+ R-cran-yaml>0:${PORTSDIR}/textproc/R-cran-yaml
+
+USES= cran:auto-plist
+
+.include <bsd.port.mk>
diff --git a/www/R-cran-htmlwidgets/distinfo b/www/R-cran-htmlwidgets/distinfo
new file mode 100644
index 000000000000..3a55f130f01b
--- /dev/null
+++ b/www/R-cran-htmlwidgets/distinfo
@@ -0,0 +1,2 @@
+SHA256 (htmlwidgets_0.5.tar.gz) = 12c54d89bf7633eea5b7a1007602361f11ed4ecc4c070fb026398977e61ca8b4
+SIZE (htmlwidgets_0.5.tar.gz) = 829921
diff --git a/www/R-cran-htmlwidgets/pkg-descr b/www/R-cran-htmlwidgets/pkg-descr
new file mode 100644
index 000000000000..ca864fd9f3b8
--- /dev/null
+++ b/www/R-cran-htmlwidgets/pkg-descr
@@ -0,0 +1,5 @@
+A framework for creating HTML widgets that render in various contexts
+including the R console, 'R Markdown' documents, and 'Shiny' web
+applications.
+
+WWW: https://cran.r-project.org/web/packages/htmlwidgets/