aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/atlas-devel/Makefile5
-rw-r--r--math/atlas/Makefile5
2 files changed, 2 insertions, 8 deletions
diff --git a/math/atlas-devel/Makefile b/math/atlas-devel/Makefile
index 51d169bd0cf0..c905ee32a6a8 100644
--- a/math/atlas-devel/Makefile
+++ b/math/atlas-devel/Makefile
@@ -33,10 +33,7 @@ USE_GCC=3.4
# only affects for lapack sub project
.if defined(WITH_OPTIMIZED_FLAGS)
-FFLAGS+=-pipe -O3 -ffast-math -finline-functions -fstrength-reduce -funroll-loops -fexpensive-optimizations
-.if (${MACHINE_ARCH} == "i386" && !${MACHINE_ARCH} == "amd64" )
-FFLAGS+= -mfancy-math-387 -mpreferred-stack-boundary=3 -malign-double
-.endif # i386
+FFLAGS+=-pipe -O3 -ffast-math
.endif
post-patch:
diff --git a/math/atlas/Makefile b/math/atlas/Makefile
index 33122077e3f4..4c97b8145d77 100644
--- a/math/atlas/Makefile
+++ b/math/atlas/Makefile
@@ -32,10 +32,7 @@ USE_GCC=3.4
# only affects for lapack sub project
.if defined(WITH_OPTIMIZED_FLAGS)
-FFLAGS+=-pipe -O3 -ffast-math -finline-functions -fstrength-reduce -funroll-loops -fexpensive-optimizations
-.if (${MACHINE_ARCH} == "i386" && !${MACHINE_ARCH} == "amd64" )
-FFLAGS+= -mfancy-math-387 -mpreferred-stack-boundary=3 -malign-double
-.endif # i386
+FFLAGS+=-pipe -O3 -ffast-math
.endif
post-patch: