aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/tweak/Makefile6
-rw-r--r--editors/tweak/files/Makefile.in7
2 files changed, 11 insertions, 2 deletions
diff --git a/editors/tweak/Makefile b/editors/tweak/Makefile
index 1c37051c9625..a5deb8368189 100644
--- a/editors/tweak/Makefile
+++ b/editors/tweak/Makefile
@@ -7,13 +7,15 @@ PORTNAME= tweak
PORTVERSION= 3.01
CATEGORIES= editors
MASTER_SITES= http://www.chiark.greenend.org.uk/~sgtatham/${PORTNAME}/
-#DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= jille@quis.cx
COMMENT= An efficient hex editor
-USE_GMAKE= yes
MAN1= tweak.1
+MANCOMPRESSED= yes
PLIST_FILES= bin/tweak
+MAKEFILE= ${FILESDIR}/Makefile.in
+MAKE_ENV+= BINDIR="${LOCALBASE}/bin" MANDIR="${PREFIX}/man/man"
+
.include <bsd.port.mk>
diff --git a/editors/tweak/files/Makefile.in b/editors/tweak/files/Makefile.in
new file mode 100644
index 000000000000..1f82158c7aa4
--- /dev/null
+++ b/editors/tweak/files/Makefile.in
@@ -0,0 +1,7 @@
+# $FreeBSD$
+
+PROG= tweak
+SRCS= actions.c btree.c buffer.c curses.c keytab.c main.c rcfile.c search.c
+LDADD= -lncurses
+
+.include <bsd.prog.mk>