aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.linux-apps.mk8
-rw-r--r--Mk/bsd.linux-rpm.mk10
-rw-r--r--Mk/bsd.port.mk5
-rw-r--r--UPDATING48
-rw-r--r--emulators/linux_base-c6/pkg-message1
-rw-r--r--www/linux-seamonkey/Makefile.common2
6 files changed, 60 insertions, 14 deletions
diff --git a/Mk/bsd.linux-apps.mk b/Mk/bsd.linux-apps.mk
index 74df2bf83df9..9d48a87e4573 100644
--- a/Mk/bsd.linux-apps.mk
+++ b/Mk/bsd.linux-apps.mk
@@ -51,8 +51,8 @@ IGNORE= valid values for OVERRIDE_LINUX_NONBASE_PORTS are: \"f10\" and \
LINUX_DIST_SUFFIX= -${USE_LINUX}
. endif
. else
-# default
-LINUX_DIST_SUFFIX= -f10 # temporary default, set to -c6 soon
+# default to CentOS
+LINUX_DIST_SUFFIX= -c6
. endif
WEB_AUTH= nvu
@@ -208,9 +208,9 @@ gdkpixbuf_PORT= ${PORTSDIR}/graphics/linux${LINUX_DIST_SUFFIX}-gdk-pixbuf
gdkpixbuf2_f10_FILE=${LINUXBASE}/usr/lib/libgdk_pixbuf-2.0.so.0
gdkpixbuf2_c6_FILE= ${LINUXBASE}/usr/lib/libgdk_pixbuf-2.0.so.0
gdkpixbuf2_DETECT= ${gdkpixbuf2${LINUX_DIST_SUFFIX:S/-/_/}_FILE}
-.if ${USE_LINUX} == "f10" || ${USE_LINUX} == "yes" # temporary default, remove or clause soon
+.if ${USE_LINUX} == "f10"
gdkpixbuf2_PORT= ${PORTSDIR}/x11-toolkits/linux${LINUX_DIST_SUFFIX}-gtk2
-.else
+.else # default to CentOS 6.
gdkpixbuf2_PORT= ${PORTSDIR}/graphics/linux${LINUX_DIST_SUFFIX}-gdk-pixbuf2
.endif
diff --git a/Mk/bsd.linux-rpm.mk b/Mk/bsd.linux-rpm.mk
index 7d1989077e6e..99e4e734d654 100644
--- a/Mk/bsd.linux-rpm.mk
+++ b/Mk/bsd.linux-rpm.mk
@@ -43,13 +43,13 @@ NO_WRKSUBDIR= yes
NO_BUILD= yes
. if ${ARCH} == "amd64" || ${ARCH} == "i386"
-. if ${USE_LINUX} == "c6"
-# Do not build CentOS 6.6 ports if overridden by f10
+. if ${USE_LINUX} == "c6" || ${USE_LINUX} == "yes" # default to CentOS
+# Do not build CentOS 6 ports if overridden by f10
. if defined(OVERRIDE_LINUX_BASE_PORT) && ${OVERRIDE_LINUX_NONBASE_PORTS} == "f10"
IGNORE= This port requires CentOS ${LINUX_DIST_VER}. Please remove OVERRIDE_LINUX_NONBASE_PORTS=f10 in /etc/make.conf.
. endif
LINUX_RPM_ARCH?= i686 # ?= because of nasty c5 qt ports
-. elif ${USE_LINUX} == "f10" || ${USE_LINUX} == "yes" # temporary default, move or clause to line 46
+. elif ${USE_LINUX} == "f10"
# Do not build Fedora 10 ports unless specifically overridden.
#. if ! defined(OVERRIDE_LINUX_NONBASE_PORTS) || ${OVERRIDE_LINUX_NONBASE_PORTS} != "f10"
#IGNORE= This port requires Fedora 10, yet Fedora 10 is heavily outdated and contains many vulnerable ports. If you really need it, add OVERRIDE_LINUX_NONBASE_PORTS=f10 in /etc/make.conf.
@@ -68,11 +68,11 @@ LINUX_RPM_ARCH?= ppc
Linux_RPM_Post_Include= bsd.linux-rpm.mk
-.if ${USE_LINUX} == "f10" || ${USE_LINUX} == "yes" # temporary default, remove or clause soon
+.if ${USE_LINUX} == "f10"
USE_LINUX?= "f10"
LINUX_DIST= fedora
LINUX_DIST_VER= 10
-.else
+.else # default to CentOS
LINUX_DIST= centos
LINUX_DIST_VER= 6.6
.endif
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 529f8310ffd5..ef1839a5e795 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1779,9 +1779,8 @@ USE_LINUX= ${OVERRIDE_LINUX_BASE_PORT}
LINUX_BASE_PORT= ${LINUXBASE}/bin/sh:${PORTSDIR}/emulators/linux_base-${USE_LINUX}
. else
. if ${USE_LINUX:tl} == "yes"
-USE_LINUX= f10 # temporary default, set to c6 soon
-LINUX_BASE_PORT= ${LINUXBASE}/etc/fedora-release:${PORTSDIR}/emulators/linux_base-f10
-#LINUX_BASE_PORT= ${LINUXBASE}/etc/redhat-release:${PORTSDIR}/emulators/linux_base-c6
+USE_LINUX= c6
+LINUX_BASE_PORT= ${LINUXBASE}/etc/redhat-release:${PORTSDIR}/emulators/linux_base-c6
. else
IGNORE= cannot be built: there is no emulators/linux_base-${USE_LINUX}, perhaps wrong use of USE_LINUX or OVERRIDE_LINUX_BASE_PORT
. endif
diff --git a/UPDATING b/UPDATING
index a5a34a453f38..9db1b989056a 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,54 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20141209:
+ AFFECTS: users of emulators/linux_base-f10 and emulators/linux_base-c6
+ AUTHOR: xmj@freebsd.org
+
+ The CentOS ports infrastructure has replaced Fedora 10 as default.
+
+ 1. Please delete all remaining f10 ports/packages:
+
+ # pkg delete -f linux_base-f10 linux-f10-\*
+
+ 2. Persistently update the Linux kernel version in /etc/sysctl.conf:
+
+ compat.linux.osrelease=2.6.18
+
+ This step is necessary on all FreeBSD versions older than 10.1-RELEASE.
+
+ 3. Reinstall all software depending on Linux emulation.
+ As an example, reinstall linux-firefox:
+
+ # portmaster -r linux-firefox
+ or
+ # portupgrade -f www/linux-firefox
+ or
+ # pkg install linux-firefox
+
+ If difficulties are encountered, please follow the UPDATING entry 20140922
+ but skip step 2 (OVERRIDE_LINUX_BASE_PORT and OVERRIDE_LINUX_NONBASE_PORTS
+ in /etc/make.conf). In case these steps do not fix the issues, please submit
+ an issue report in Bugzilla and send an email to FreeBSD's emulation@ mailing
+ list.
+
+ Users who need to continue using Fedora 10 base and userland should do the
+ following instead:
+
+ 1. Add these lines to /etc/make.conf:
+
+ OVERRIDE_LINUX_BASE_PORT=f10
+ OVERRIDE_LINUX_NONBASE_PORTS=f10
+
+ 2. Downgrade the Linux kernel version in /etc/sysctl.conf on FreeBSD versions
+ newer than and including 10.1-RELEASE:
+
+ compat.linux.osrelease=2.6.16
+
+ This is all that is needed to continue using an existing Fedora 10 Linux base
+ and userland.
+
+
20141208:
AFFECTS: users of ports-mgmt/poudriere, ports-mgmt/poudriere-devel
AUTHOR: bdrewery@FreeBSD.org
diff --git a/emulators/linux_base-c6/pkg-message b/emulators/linux_base-c6/pkg-message
index d51e7595906f..ecfdbd9ceebd 100644
--- a/emulators/linux_base-c6/pkg-message
+++ b/emulators/linux_base-c6/pkg-message
@@ -9,7 +9,6 @@ variable of rc.conf(5).
----------------------
You should enable Linux mode with the linux_enable variable of rc.conf(5)
and use compat.linux.osrelease=2.6.18 in sysctl.conf(5).
-This is highly experimental!
----------------------
If you want to use shared memory in Linux applications, you need to set up
diff --git a/www/linux-seamonkey/Makefile.common b/www/linux-seamonkey/Makefile.common
index 7ca09a978b90..286ed96ad05d 100644
--- a/www/linux-seamonkey/Makefile.common
+++ b/www/linux-seamonkey/Makefile.common
@@ -1,6 +1,6 @@
# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
# $FreeBSD$
-.if defined(OVERRIDE_LINUX_NONBASE_PORTS) && \
+.if !defined(OVERRIDE_LINUX_NONBASE_PORTS) || \
${OVERRIDE_LINUX_NONBASE_PORTS} != "f10"
.undef WANT_GTK218
.endif