aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/cl-uffi-sbcl/Makefile37
-rw-r--r--devel/cl-uffi-sbcl/pkg-descr8
-rw-r--r--devel/cl-uffi-sbcl/pkg-plist9
4 files changed, 55 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index cc6e52aeb9de..369c59aa9c3f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -130,6 +130,7 @@
SUBDIR += cl-split-sequence-sbcl
SUBDIR += cl-uffi
SUBDIR += cl-uffi-cmucl
+ SUBDIR += cl-uffi-sbcl
SUBDIR += clanlib
SUBDIR += clanlib-devel
SUBDIR += clig
diff --git a/devel/cl-uffi-sbcl/Makefile b/devel/cl-uffi-sbcl/Makefile
new file mode 100644
index 000000000000..32b9b9b7df63
--- /dev/null
+++ b/devel/cl-uffi-sbcl/Makefile
@@ -0,0 +1,37 @@
+# New ports collection Makefile for: cl-uffi-sbcl
+# Date created: 19 August 2004
+# Whom: Matthew X. Economou <xenophon+fbsdports@irtnog.org>
+#
+# $FreeBSD$
+
+PORTNAME= uffi
+PORTVERSION= 1.4.37
+CATEGORIES= devel
+MASTER_SITES= http://files.b9.com/uffi/
+PKGNAMEPREFIX= cl-
+PKGNAMESUFFIX= -sbcl
+DISTFILES= # use installed sources from CL_LIBDIR
+EXTRACT_ONLY= # use installed sources from CL_LIBDIR
+
+MAINTAINER= xenophon+fbsdports@irtnog.org
+COMMENT= Universal Foreign Function Interface for Common Lisp (SBCL binaries)
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/uffi/uffi.asd:${PORTSDIR}/devel/cl-uffi \
+ ${LOCALBASE}/lib/common-lisp/asdf/sbclfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-sbcl \
+ sbcl:${PORTSDIR}/lang/sbcl
+RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/port/port.asd:${PORTSDIR}/devel/cl-port \
+ ${LOCALBASE}/lib/common-lisp/asdf/sbclfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-sbcl \
+ sbcl:${PORTSDIR}/lang/sbcl
+
+do-build:
+ WRKSRC=${WRKSRC}/ FBSD_ASDF_COMPILE_PORT=t\
+ sbcl --noinform --userinit /dev/null \
+ --eval '#.(load "${LOCALBASE}/etc/asdf-init")' \
+ --eval "(asdf:oos 'asdf:compile-op :uffi)" \
+ --eval "(quit)"
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/common-lisp/uffi/src/sbclfasl
+ ${INSTALL_DATA} ${WRKSRC}/*.fasl ${PREFIX}/lib/common-lisp/uffi/src/sbclfasl/
+
+.include <bsd.port.mk>
diff --git a/devel/cl-uffi-sbcl/pkg-descr b/devel/cl-uffi-sbcl/pkg-descr
new file mode 100644
index 000000000000..dad475575b60
--- /dev/null
+++ b/devel/cl-uffi-sbcl/pkg-descr
@@ -0,0 +1,8 @@
+UFFI provides platform-independent access to the foreign function
+interfaces of AllegroCL, Lispworks, CMUCL, SBCL, SCL, OpenMCL, and MCL.
+(A foreign function interface allows Lisp programs to call routines
+located in C libraries.)
+
+This package contains binaries compiled for SBCL.
+
+WWW: http://uffi.b9.com/
diff --git a/devel/cl-uffi-sbcl/pkg-plist b/devel/cl-uffi-sbcl/pkg-plist
new file mode 100644
index 000000000000..9a4e59aea040
--- /dev/null
+++ b/devel/cl-uffi-sbcl/pkg-plist
@@ -0,0 +1,9 @@
+lib/common-lisp/uffi/src/sbclfasl/aggregates.fasl
+lib/common-lisp/uffi/src/sbclfasl/functions.fasl
+lib/common-lisp/uffi/src/sbclfasl/libraries.fasl
+lib/common-lisp/uffi/src/sbclfasl/objects.fasl
+lib/common-lisp/uffi/src/sbclfasl/os.fasl
+lib/common-lisp/uffi/src/sbclfasl/package.fasl
+lib/common-lisp/uffi/src/sbclfasl/primitives.fasl
+lib/common-lisp/uffi/src/sbclfasl/strings.fasl
+@dirrm lib/common-lisp/uffi/src/sbclfasl