aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/firefox-sync/Makefile52
-rw-r--r--www/firefox-sync/distinfo3
-rw-r--r--www/firefox-sync/files/patch-Makefile11
-rw-r--r--www/firefox-sync/files/patch-crypto-src-Makefile130
-rw-r--r--www/firefox-sync/pkg-descr5
-rw-r--r--www/firefox-sync/pkg-plist66
-rw-r--r--www/weave/Makefile52
-rw-r--r--www/weave/distinfo3
-rw-r--r--www/weave/files/patch-Makefile11
-rw-r--r--www/weave/files/patch-crypto-src-Makefile130
-rw-r--r--www/weave/pkg-descr5
-rw-r--r--www/weave/pkg-plist66
13 files changed, 535 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 7d761ac4caa5..305404712736 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1615,6 +1615,7 @@
SUBDIR += wadcomblog
SUBDIR += wb0
SUBDIR += wcol
+ SUBDIR += weave
SUBDIR += web-traceroute
SUBDIR += web2ldap
SUBDIR += webalizer
diff --git a/www/firefox-sync/Makefile b/www/firefox-sync/Makefile
new file mode 100644
index 000000000000..83061f2549f6
--- /dev/null
+++ b/www/firefox-sync/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: weave
+# Date created: 31 Aug 2009
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= weave
+PORTVERSION= 0.7
+CATEGORIES= www
+MASTER_SITES= http://files.roorback.net/ \
+ LOCAL/glarkin
+
+MAINTAINER= magik@roorback.net
+COMMENT= Mozilla Weave extension
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/firefox3/firefox:${PORTSDIR}/www/firefox35 \
+ ${LOCALBASE}/lib/libxul/xpidl:${PORTSDIR}/www/libxul
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_BZIP2= yes
+USE_GMAKE= yes
+
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == i386
+PLATFORM= FreeBSD_x86-gcc3
+.elif ${ARCH} == amd64
+PLATFORM= FreeBSD_x86_64-gcc3
+.endif
+
+GMAKE_FLAGS= sdkdir=${PREFIX}/lib/firefox3/sdk rebuild_crypto=1 release_build=1 platform_target=${PLATFORM}
+ALL_TARGET= ${GMAKE_FLAGS} build
+INSTALL_TARGET= ${GMAKE_FLAGS} xpi
+
+XPI_ID= {340c2bbc-ce74-4362-90b5-7c26312808ef}
+XPI_DIR= ${PREFIX}/lib/xpi/${XPI_ID}
+
+PLIST_SUB+= XPI_XPIDIR="${XPI_DIR:S,^${PREFIX}/,,}" \
+ XPI_XPIID=${XPI_ID} \
+ PLATFORM=${PLATFORM}
+
+post-install:
+ ${MKDIR} ${XPI_DIR}
+ (cd ${XPI_DIR}; tar -xf ${WRKSRC}/dist/xpi/weave-${PORTVERSION}-rel.xpi)
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${XPI_DIR}/
+ ${CHMOD} -R a+rX,go-w ${XPI_DIR}/
+ ${MKDIR} ${PREFIX}/lib/firefox3/extensions
+ ${LN} -sf ${XPI_DIR} ${PREFIX}/lib/firefox3/extensions
+
+.include <bsd.port.mk>
diff --git a/www/firefox-sync/distinfo b/www/firefox-sync/distinfo
new file mode 100644
index 000000000000..9d0056de2186
--- /dev/null
+++ b/www/firefox-sync/distinfo
@@ -0,0 +1,3 @@
+MD5 (weave-0.7.tar.bz2) = 147cf606f0b14d29970f8daf414e45a9
+SHA256 (weave-0.7.tar.bz2) = 58ab733c325aa9f130dacc1ef9f1f36dd02a065bee3b3a3c8d540d7203697ef9
+SIZE (weave-0.7.tar.bz2) = 807987
diff --git a/www/firefox-sync/files/patch-Makefile b/www/firefox-sync/files/patch-Makefile
new file mode 100644
index 000000000000..03bd5cffb53a
--- /dev/null
+++ b/www/firefox-sync/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2009-10-01 01:19:33.000000000 +0000
++++ Makefile 2009-10-04 19:49:04.000000000 +0000
+@@ -64,7 +64,7 @@
+ buildid_short := $(buildid)
+ ifeq ($(buildid),)
+ date := $(shell date -u +%Y%m%d%H%M)
+- revid := $(shell hg tip --template '{node|short}')
++ revid := bc1857fb6754
+ buildid := $(date)-$(revid)
+ buildid_short := $(date)
+ endif
diff --git a/www/firefox-sync/files/patch-crypto-src-Makefile b/www/firefox-sync/files/patch-crypto-src-Makefile
new file mode 100644
index 000000000000..10ea05190ffb
--- /dev/null
+++ b/www/firefox-sync/files/patch-crypto-src-Makefile
@@ -0,0 +1,130 @@
+--- crypto/src/Makefile.orig 2009-08-27 22:08:18.000000000 +0200
++++ crypto/src/Makefile 2009-09-18 21:52:06.000000000 +0200
+@@ -45,6 +45,10 @@
+ sys := $(shell uname -s)
+ wince = $(WINCE)
+
++ifeq ($(sys), FreeBSD)
++ xpidl = $(PREFIX)/lib/libxul/xpidl -I$(PREFIX)/share/idl/firefox3/stable
++endif
++
+ ifeq ($(wince), 1)
+ os = WINNT
+ cxx = $(sdkdir)/sdk/bin/arm-wince-gcc
+@@ -66,6 +70,14 @@
+ so = so
+ cppflags += -shared
+ else
++ifeq ($(sys), FreeBSD)
++ os = FreeBSD
++ compiler = gcc3
++ cxx = c++
++ so = so
++ cppflags += -shared
++ ldflags += -L$(PREFIX)/lib/firefox3 -L$(PREFIX)/lib
++else
+ ifeq ($(sys), MINGW32_NT-6.1)
+ os = WINNT
+ compiler = msvc
+@@ -92,6 +104,7 @@
+ endif
+ endif
+ endif
++endif
+
+ # Arch detection
+
+@@ -121,6 +134,9 @@
+ ifeq ($(machine), x86_64)
+ arch = x86_64
+ else
++ifeq ($(machine), amd64)
++ arch = x86_64
++else
+ $(error: Sorry, your architecture is unknown/unsupported: $(machine))
+ endif
+ endif
+@@ -130,6 +146,7 @@
+ endif
+ endif
+ endif
++endif
+
+ # Universal binary so no need for $(arch) for Darwin
+
+@@ -188,6 +205,13 @@
+ -I$(sdkdir)/include/nspr \
+ -I$(sdkdir)/sdk/include
+
++ifeq ($(sys), FreeBSD)
++ headers += -I$(PREFIX)/include/firefox3/stable \
++ -I$(PREFIX)/include/nspr \
++ -I$(PREFIX)/include/nss \
++ -I$(PREFIX)/include/firefox3/unstable
++endif
++
+ # libraries
+ libdirs := $(sdkdir)/lib $(sdkdir)/bin
+ ifeq ($(wince),1)
+@@ -202,6 +226,10 @@
+
+ ifeq ($(os), Linux)
+ libs := xpcom_core $(libs)
++else
++ifeq ($(os), FreeBSD)
++ libs := xpcom $(libs)
++endif
+ endif
+
+ # compiler and Linker Flags
+@@ -264,6 +292,25 @@
+ $(sdkdir)/lib/libxpcomglue_s.a \
+ $(libdirs) $(libs)
+ else
++ifeq ($(os), FreeBSD)
++ libdirs := $(patsubst %,-L%,$(libdirs))
++ libs := $(patsubst %,-l%,$(libs))
++ cppflags += -pipe -O2 \
++ -fPIC -fno-rtti -fno-exceptions -fno-strict-aliasing \
++ -fno-common -pthread \
++ -Wall -Wconversion -Wpointer-arith -Woverloaded-virtual -Wsynth \
++ -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align \
++ -Wno-long-long \
++ -include xpcom-config.h $(headers) \
++ -fshort-wchar
++ ldflags += -pthread -pipe -DMOZILLA_STRICT_API \
++ -Wl,-dead_strip \
++ -Wl,-exported_symbol \
++ -Wl,-z,defs -Wl,-h,WeaveCrypto.so \
++ -Wl,-rpath-link,$(sdkdir)/bin \
++ $(sdkdir)/lib/libxpcomglue_s.a \
++ $(libdirs) $(libs)
++else
+ ifeq ($(os), SunOS)
+ libdirs := $(patsubst %,-L%,$(libdirs))
+ libs := $(patsubst %,-l%,$(libs))
+@@ -303,6 +350,7 @@
+ endif
+ endif
+ endif
++endif
+
+ ######################################################################
+
+@@ -361,6 +409,11 @@
+ $(cxx) $(cppflags) -o $@ $(cpp_sources) $(ldflags)
+ chmod +x $@
+ else
++ifeq ($(os), FreeBSD)
++ $(so_target): $(idl_headers)
++ $(cxx) $(cppflags) -o $@ $(cpp_sources) $(ldflags)
++ chmod +x $@
++else
+ ifeq ($(os), SunOS)
+ $(so_target): $(idl_headers)
+ $(cxx) $(cppflags) -o $@ $(cpp_sources) $(ldflags)
+@@ -380,3 +433,4 @@
+ endif
+ endif
+ endif
++endif
diff --git a/www/firefox-sync/pkg-descr b/www/firefox-sync/pkg-descr
new file mode 100644
index 000000000000..c465c468b869
--- /dev/null
+++ b/www/firefox-sync/pkg-descr
@@ -0,0 +1,5 @@
+Weave is a Mozilla Labs project to explore ways in which
+the browser can broker richer experiences on the Web,
+by integrating more closely with online services.
+
+WWW: http://labs.mozilla.com/weave/
diff --git a/www/firefox-sync/pkg-plist b/www/firefox-sync/pkg-plist
new file mode 100644
index 000000000000..3cabb800e2fb
--- /dev/null
+++ b/www/firefox-sync/pkg-plist
@@ -0,0 +1,66 @@
+%%XPI_XPIDIR%%/chrome/sync.jar
+%%XPI_XPIDIR%%/defaults/preferences/sync.js
+%%XPI_XPIDIR%%/components/IWeaveCrypto.xpt
+%%XPI_XPIDIR%%/components/Weave.js
+%%XPI_XPIDIR%%/modules/base_records/collection.js
+%%XPI_XPIDIR%%/modules/base_records/crypto.js
+%%XPI_XPIDIR%%/modules/base_records/keys.js
+%%XPI_XPIDIR%%/modules/base_records/wbo.js
+%%XPI_XPIDIR%%/modules/engines/themes.js
+%%XPI_XPIDIR%%/modules/engines/clientData.js
+%%XPI_XPIDIR%%/modules/engines/cookies.js
+%%XPI_XPIDIR%%/modules/engines/extensions.js
+%%XPI_XPIDIR%%/modules/engines/forms.js
+%%XPI_XPIDIR%%/modules/engines/history.js
+%%XPI_XPIDIR%%/modules/engines/input.js
+%%XPI_XPIDIR%%/modules/engines/microformats.js
+%%XPI_XPIDIR%%/modules/engines/passwords.js
+%%XPI_XPIDIR%%/modules/engines/plugins.js
+%%XPI_XPIDIR%%/modules/engines/prefs.js
+%%XPI_XPIDIR%%/modules/engines/tabs.js
+%%XPI_XPIDIR%%/modules/engines/bookmarks.js
+%%XPI_XPIDIR%%/modules/type_records/history.js
+%%XPI_XPIDIR%%/modules/type_records/clientData.js
+%%XPI_XPIDIR%%/modules/type_records/forms.js
+%%XPI_XPIDIR%%/modules/type_records/bookmark.js
+%%XPI_XPIDIR%%/modules/type_records/passwords.js
+%%XPI_XPIDIR%%/modules/type_records/prefs.js
+%%XPI_XPIDIR%%/modules/type_records/tabs.js
+%%XPI_XPIDIR%%/modules/ext/Observers.js
+%%XPI_XPIDIR%%/modules/ext/Preferences.js
+%%XPI_XPIDIR%%/modules/ext/StringBundle.js
+%%XPI_XPIDIR%%/modules/ext/Sync.js
+%%XPI_XPIDIR%%/modules/xmpp/authenticationLayer.js
+%%XPI_XPIDIR%%/modules/xmpp/readme.txt
+%%XPI_XPIDIR%%/modules/xmpp/transportLayer.js
+%%XPI_XPIDIR%%/modules/xmpp/xmppClient.js
+%%XPI_XPIDIR%%/modules/auth.js
+%%XPI_XPIDIR%%/modules/notifications.js
+%%XPI_XPIDIR%%/modules/resource.js
+%%XPI_XPIDIR%%/modules/service.js
+%%XPI_XPIDIR%%/modules/stores.js
+%%XPI_XPIDIR%%/modules/trackers.js
+%%XPI_XPIDIR%%/modules/util.js
+%%XPI_XPIDIR%%/modules/log4moz.js
+%%XPI_XPIDIR%%/modules/engines.js
+%%XPI_XPIDIR%%/modules/identity.js
+%%XPI_XPIDIR%%/modules/constants.js
+%%XPI_XPIDIR%%/platform/%%PLATFORM%%/components/WeaveCrypto.so
+%%XPI_XPIDIR%%/install.rdf
+%%XPI_XPIDIR%%/chrome.manifest
+lib/firefox3/extensions/%%XPI_XPIID%%
+@dirrm %%XPI_XPIDIR%%/platform/%%PLATFORM%%/components
+@dirrm %%XPI_XPIDIR%%/platform/%%PLATFORM%%
+@dirrm %%XPI_XPIDIR%%/platform
+@dirrm %%XPI_XPIDIR%%/modules/xmpp
+@dirrm %%XPI_XPIDIR%%/modules/ext
+@dirrm %%XPI_XPIDIR%%/modules/type_records
+@dirrm %%XPI_XPIDIR%%/modules/engines
+@dirrm %%XPI_XPIDIR%%/modules/base_records
+@dirrm %%XPI_XPIDIR%%/modules
+@dirrm %%XPI_XPIDIR%%/components
+@dirrm %%XPI_XPIDIR%%/defaults/preferences
+@dirrm %%XPI_XPIDIR%%/defaults
+@dirrm %%XPI_XPIDIR%%/chrome
+@dirrm %%XPI_XPIDIR%%
+@dirrmtry lib/xpi
diff --git a/www/weave/Makefile b/www/weave/Makefile
new file mode 100644
index 000000000000..83061f2549f6
--- /dev/null
+++ b/www/weave/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: weave
+# Date created: 31 Aug 2009
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= weave
+PORTVERSION= 0.7
+CATEGORIES= www
+MASTER_SITES= http://files.roorback.net/ \
+ LOCAL/glarkin
+
+MAINTAINER= magik@roorback.net
+COMMENT= Mozilla Weave extension
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/firefox3/firefox:${PORTSDIR}/www/firefox35 \
+ ${LOCALBASE}/lib/libxul/xpidl:${PORTSDIR}/www/libxul
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_BZIP2= yes
+USE_GMAKE= yes
+
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == i386
+PLATFORM= FreeBSD_x86-gcc3
+.elif ${ARCH} == amd64
+PLATFORM= FreeBSD_x86_64-gcc3
+.endif
+
+GMAKE_FLAGS= sdkdir=${PREFIX}/lib/firefox3/sdk rebuild_crypto=1 release_build=1 platform_target=${PLATFORM}
+ALL_TARGET= ${GMAKE_FLAGS} build
+INSTALL_TARGET= ${GMAKE_FLAGS} xpi
+
+XPI_ID= {340c2bbc-ce74-4362-90b5-7c26312808ef}
+XPI_DIR= ${PREFIX}/lib/xpi/${XPI_ID}
+
+PLIST_SUB+= XPI_XPIDIR="${XPI_DIR:S,^${PREFIX}/,,}" \
+ XPI_XPIID=${XPI_ID} \
+ PLATFORM=${PLATFORM}
+
+post-install:
+ ${MKDIR} ${XPI_DIR}
+ (cd ${XPI_DIR}; tar -xf ${WRKSRC}/dist/xpi/weave-${PORTVERSION}-rel.xpi)
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${XPI_DIR}/
+ ${CHMOD} -R a+rX,go-w ${XPI_DIR}/
+ ${MKDIR} ${PREFIX}/lib/firefox3/extensions
+ ${LN} -sf ${XPI_DIR} ${PREFIX}/lib/firefox3/extensions
+
+.include <bsd.port.mk>
diff --git a/www/weave/distinfo b/www/weave/distinfo
new file mode 100644
index 000000000000..9d0056de2186
--- /dev/null
+++ b/www/weave/distinfo
@@ -0,0 +1,3 @@
+MD5 (weave-0.7.tar.bz2) = 147cf606f0b14d29970f8daf414e45a9
+SHA256 (weave-0.7.tar.bz2) = 58ab733c325aa9f130dacc1ef9f1f36dd02a065bee3b3a3c8d540d7203697ef9
+SIZE (weave-0.7.tar.bz2) = 807987
diff --git a/www/weave/files/patch-Makefile b/www/weave/files/patch-Makefile
new file mode 100644
index 000000000000..03bd5cffb53a
--- /dev/null
+++ b/www/weave/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2009-10-01 01:19:33.000000000 +0000
++++ Makefile 2009-10-04 19:49:04.000000000 +0000
+@@ -64,7 +64,7 @@
+ buildid_short := $(buildid)
+ ifeq ($(buildid),)
+ date := $(shell date -u +%Y%m%d%H%M)
+- revid := $(shell hg tip --template '{node|short}')
++ revid := bc1857fb6754
+ buildid := $(date)-$(revid)
+ buildid_short := $(date)
+ endif
diff --git a/www/weave/files/patch-crypto-src-Makefile b/www/weave/files/patch-crypto-src-Makefile
new file mode 100644
index 000000000000..10ea05190ffb
--- /dev/null
+++ b/www/weave/files/patch-crypto-src-Makefile
@@ -0,0 +1,130 @@
+--- crypto/src/Makefile.orig 2009-08-27 22:08:18.000000000 +0200
++++ crypto/src/Makefile 2009-09-18 21:52:06.000000000 +0200
+@@ -45,6 +45,10 @@
+ sys := $(shell uname -s)
+ wince = $(WINCE)
+
++ifeq ($(sys), FreeBSD)
++ xpidl = $(PREFIX)/lib/libxul/xpidl -I$(PREFIX)/share/idl/firefox3/stable
++endif
++
+ ifeq ($(wince), 1)
+ os = WINNT
+ cxx = $(sdkdir)/sdk/bin/arm-wince-gcc
+@@ -66,6 +70,14 @@
+ so = so
+ cppflags += -shared
+ else
++ifeq ($(sys), FreeBSD)
++ os = FreeBSD
++ compiler = gcc3
++ cxx = c++
++ so = so
++ cppflags += -shared
++ ldflags += -L$(PREFIX)/lib/firefox3 -L$(PREFIX)/lib
++else
+ ifeq ($(sys), MINGW32_NT-6.1)
+ os = WINNT
+ compiler = msvc
+@@ -92,6 +104,7 @@
+ endif
+ endif
+ endif
++endif
+
+ # Arch detection
+
+@@ -121,6 +134,9 @@
+ ifeq ($(machine), x86_64)
+ arch = x86_64
+ else
++ifeq ($(machine), amd64)
++ arch = x86_64
++else
+ $(error: Sorry, your architecture is unknown/unsupported: $(machine))
+ endif
+ endif
+@@ -130,6 +146,7 @@
+ endif
+ endif
+ endif
++endif
+
+ # Universal binary so no need for $(arch) for Darwin
+
+@@ -188,6 +205,13 @@
+ -I$(sdkdir)/include/nspr \
+ -I$(sdkdir)/sdk/include
+
++ifeq ($(sys), FreeBSD)
++ headers += -I$(PREFIX)/include/firefox3/stable \
++ -I$(PREFIX)/include/nspr \
++ -I$(PREFIX)/include/nss \
++ -I$(PREFIX)/include/firefox3/unstable
++endif
++
+ # libraries
+ libdirs := $(sdkdir)/lib $(sdkdir)/bin
+ ifeq ($(wince),1)
+@@ -202,6 +226,10 @@
+
+ ifeq ($(os), Linux)
+ libs := xpcom_core $(libs)
++else
++ifeq ($(os), FreeBSD)
++ libs := xpcom $(libs)
++endif
+ endif
+
+ # compiler and Linker Flags
+@@ -264,6 +292,25 @@
+ $(sdkdir)/lib/libxpcomglue_s.a \
+ $(libdirs) $(libs)
+ else
++ifeq ($(os), FreeBSD)
++ libdirs := $(patsubst %,-L%,$(libdirs))
++ libs := $(patsubst %,-l%,$(libs))
++ cppflags += -pipe -O2 \
++ -fPIC -fno-rtti -fno-exceptions -fno-strict-aliasing \
++ -fno-common -pthread \
++ -Wall -Wconversion -Wpointer-arith -Woverloaded-virtual -Wsynth \
++ -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align \
++ -Wno-long-long \
++ -include xpcom-config.h $(headers) \
++ -fshort-wchar
++ ldflags += -pthread -pipe -DMOZILLA_STRICT_API \
++ -Wl,-dead_strip \
++ -Wl,-exported_symbol \
++ -Wl,-z,defs -Wl,-h,WeaveCrypto.so \
++ -Wl,-rpath-link,$(sdkdir)/bin \
++ $(sdkdir)/lib/libxpcomglue_s.a \
++ $(libdirs) $(libs)
++else
+ ifeq ($(os), SunOS)
+ libdirs := $(patsubst %,-L%,$(libdirs))
+ libs := $(patsubst %,-l%,$(libs))
+@@ -303,6 +350,7 @@
+ endif
+ endif
+ endif
++endif
+
+ ######################################################################
+
+@@ -361,6 +409,11 @@
+ $(cxx) $(cppflags) -o $@ $(cpp_sources) $(ldflags)
+ chmod +x $@
+ else
++ifeq ($(os), FreeBSD)
++ $(so_target): $(idl_headers)
++ $(cxx) $(cppflags) -o $@ $(cpp_sources) $(ldflags)
++ chmod +x $@
++else
+ ifeq ($(os), SunOS)
+ $(so_target): $(idl_headers)
+ $(cxx) $(cppflags) -o $@ $(cpp_sources) $(ldflags)
+@@ -380,3 +433,4 @@
+ endif
+ endif
+ endif
++endif
diff --git a/www/weave/pkg-descr b/www/weave/pkg-descr
new file mode 100644
index 000000000000..c465c468b869
--- /dev/null
+++ b/www/weave/pkg-descr
@@ -0,0 +1,5 @@
+Weave is a Mozilla Labs project to explore ways in which
+the browser can broker richer experiences on the Web,
+by integrating more closely with online services.
+
+WWW: http://labs.mozilla.com/weave/
diff --git a/www/weave/pkg-plist b/www/weave/pkg-plist
new file mode 100644
index 000000000000..3cabb800e2fb
--- /dev/null
+++ b/www/weave/pkg-plist
@@ -0,0 +1,66 @@
+%%XPI_XPIDIR%%/chrome/sync.jar
+%%XPI_XPIDIR%%/defaults/preferences/sync.js
+%%XPI_XPIDIR%%/components/IWeaveCrypto.xpt
+%%XPI_XPIDIR%%/components/Weave.js
+%%XPI_XPIDIR%%/modules/base_records/collection.js
+%%XPI_XPIDIR%%/modules/base_records/crypto.js
+%%XPI_XPIDIR%%/modules/base_records/keys.js
+%%XPI_XPIDIR%%/modules/base_records/wbo.js
+%%XPI_XPIDIR%%/modules/engines/themes.js
+%%XPI_XPIDIR%%/modules/engines/clientData.js
+%%XPI_XPIDIR%%/modules/engines/cookies.js
+%%XPI_XPIDIR%%/modules/engines/extensions.js
+%%XPI_XPIDIR%%/modules/engines/forms.js
+%%XPI_XPIDIR%%/modules/engines/history.js
+%%XPI_XPIDIR%%/modules/engines/input.js
+%%XPI_XPIDIR%%/modules/engines/microformats.js
+%%XPI_XPIDIR%%/modules/engines/passwords.js
+%%XPI_XPIDIR%%/modules/engines/plugins.js
+%%XPI_XPIDIR%%/modules/engines/prefs.js
+%%XPI_XPIDIR%%/modules/engines/tabs.js
+%%XPI_XPIDIR%%/modules/engines/bookmarks.js
+%%XPI_XPIDIR%%/modules/type_records/history.js
+%%XPI_XPIDIR%%/modules/type_records/clientData.js
+%%XPI_XPIDIR%%/modules/type_records/forms.js
+%%XPI_XPIDIR%%/modules/type_records/bookmark.js
+%%XPI_XPIDIR%%/modules/type_records/passwords.js
+%%XPI_XPIDIR%%/modules/type_records/prefs.js
+%%XPI_XPIDIR%%/modules/type_records/tabs.js
+%%XPI_XPIDIR%%/modules/ext/Observers.js
+%%XPI_XPIDIR%%/modules/ext/Preferences.js
+%%XPI_XPIDIR%%/modules/ext/StringBundle.js
+%%XPI_XPIDIR%%/modules/ext/Sync.js
+%%XPI_XPIDIR%%/modules/xmpp/authenticationLayer.js
+%%XPI_XPIDIR%%/modules/xmpp/readme.txt
+%%XPI_XPIDIR%%/modules/xmpp/transportLayer.js
+%%XPI_XPIDIR%%/modules/xmpp/xmppClient.js
+%%XPI_XPIDIR%%/modules/auth.js
+%%XPI_XPIDIR%%/modules/notifications.js
+%%XPI_XPIDIR%%/modules/resource.js
+%%XPI_XPIDIR%%/modules/service.js
+%%XPI_XPIDIR%%/modules/stores.js
+%%XPI_XPIDIR%%/modules/trackers.js
+%%XPI_XPIDIR%%/modules/util.js
+%%XPI_XPIDIR%%/modules/log4moz.js
+%%XPI_XPIDIR%%/modules/engines.js
+%%XPI_XPIDIR%%/modules/identity.js
+%%XPI_XPIDIR%%/modules/constants.js
+%%XPI_XPIDIR%%/platform/%%PLATFORM%%/components/WeaveCrypto.so
+%%XPI_XPIDIR%%/install.rdf
+%%XPI_XPIDIR%%/chrome.manifest
+lib/firefox3/extensions/%%XPI_XPIID%%
+@dirrm %%XPI_XPIDIR%%/platform/%%PLATFORM%%/components
+@dirrm %%XPI_XPIDIR%%/platform/%%PLATFORM%%
+@dirrm %%XPI_XPIDIR%%/platform
+@dirrm %%XPI_XPIDIR%%/modules/xmpp
+@dirrm %%XPI_XPIDIR%%/modules/ext
+@dirrm %%XPI_XPIDIR%%/modules/type_records
+@dirrm %%XPI_XPIDIR%%/modules/engines
+@dirrm %%XPI_XPIDIR%%/modules/base_records
+@dirrm %%XPI_XPIDIR%%/modules
+@dirrm %%XPI_XPIDIR%%/components
+@dirrm %%XPI_XPIDIR%%/defaults/preferences
+@dirrm %%XPI_XPIDIR%%/defaults
+@dirrm %%XPI_XPIDIR%%/chrome
+@dirrm %%XPI_XPIDIR%%
+@dirrmtry lib/xpi