aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/Makefile1
-rw-r--r--astro/viking/Makefile45
-rw-r--r--astro/viking/distinfo3
-rw-r--r--astro/viking/pkg-descr10
-rw-r--r--astro/viking/pkg-plist9
5 files changed, 68 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 38f53535f279..f7a0214b0b17 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -71,6 +71,7 @@
SUBDIR += sunclock
SUBDIR += tclgeomap
SUBDIR += tkgeomap
+ SUBDIR += viking
SUBDIR += weatherget
SUBDIR += weatherspect
SUBDIR += wmglobe
diff --git a/astro/viking/Makefile b/astro/viking/Makefile
new file mode 100644
index 000000000000..070bdbd02da3
--- /dev/null
+++ b/astro/viking/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: viking
+# Date created: 29 April 2008
+# Whom: David Le Brun <david@trucs.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= viking
+PORTVERSION= 0.9.4
+CATEGORIES= astro
+MASTER_SITES= SF
+
+MAINTAINER= david@trucs.org
+COMMENT= Program to manage GPS data (tracks, waypoints, etc)
+
+LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl \
+ expat.6:${PORTSDIR}/textproc/expat2
+RUN_DEPENDS= gpsbabel:${PORTSDIR}/astro/gpsbabel
+
+USE_PERL5_RUN= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20 libglade2
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+OPTIONS= GPSD "Enable realtime GPS tracking" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GPSD)
+LIB_DEPENDS+= gps.17:${PORTSDIR}/astro/gpsd
+.else
+CONFIGURE_ARGS+= --disable-realtime-gps-tracking
+.endif
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/astro/viking/distinfo b/astro/viking/distinfo
new file mode 100644
index 000000000000..dbdc06a877ad
--- /dev/null
+++ b/astro/viking/distinfo
@@ -0,0 +1,3 @@
+MD5 (viking-0.9.4.tar.gz) = 2bbd80435535a4be897ac56c8bf5f8ae
+SHA256 (viking-0.9.4.tar.gz) = 14b65e33eb0b02ce05962f516a4b5c96ff078e646ba4f482e30975dc3b33e3e3
+SIZE (viking-0.9.4.tar.gz) = 585989
diff --git a/astro/viking/pkg-descr b/astro/viking/pkg-descr
new file mode 100644
index 000000000000..a2187e38317e
--- /dev/null
+++ b/astro/viking/pkg-descr
@@ -0,0 +1,10 @@
+viking is a free/open source program to manage GPS data.
+
+You can import and plot tracks and waypoints, show Google maps and/or
+Terraserver maps under it, download geocaches for an area on the map, make new
+tracks and waypoints, see real-time GPS position, etc.
+
+It is written in C with the GTK+ 2 toolkit, available for Linux, other POSIX
+operating systems, and Windows, and is licensed under the GNU GPL.
+
+WWW: http://viking.sourceforge.net
diff --git a/astro/viking/pkg-plist b/astro/viking/pkg-plist
new file mode 100644
index 000000000000..96d525faad02
--- /dev/null
+++ b/astro/viking/pkg-plist
@@ -0,0 +1,9 @@
+bin/viking
+bin/viking-remote
+%%NLS%%share/locale/cs/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/da/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/de/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/es/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/viking.mo