aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/hs-c2hs/Makefile2
-rw-r--r--devel/hs-tclhaskell-ghc/Makefile2
-rw-r--r--lang/ghc/Makefile18
-rw-r--r--lang/ghc/distinfo12
-rw-r--r--lang/ghc6-doc/Makefile4
-rw-r--r--lang/ghc6-doc/distinfo32
-rw-r--r--lang/ghc6-doc/pkg-plist6
-rw-r--r--x11-toolkits/hs-gtk+hs/Makefile2
-rw-r--r--x11-toolkits/hs-gtk2hs/Makefile4
9 files changed, 39 insertions, 43 deletions
diff --git a/devel/hs-c2hs/Makefile b/devel/hs-c2hs/Makefile
index d793c6043d93..b8bdc2e52174 100644
--- a/devel/hs-c2hs/Makefile
+++ b/devel/hs-c2hs/Makefile
@@ -23,7 +23,7 @@ GHC= ghc-5.04.3
GHCDEP= ghc5
GHCMAJOR= 5
.else
-GHC= ghc-6.2.1
+GHC= ghc-6.2.2
GHCDEP= ghc
GHCMAJOR= 6
.endif
diff --git a/devel/hs-tclhaskell-ghc/Makefile b/devel/hs-tclhaskell-ghc/Makefile
index 073522c32712..99a7a7cedeaa 100644
--- a/devel/hs-tclhaskell-ghc/Makefile
+++ b/devel/hs-tclhaskell-ghc/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= ${GHC}:${PORTSDIR}/lang/${GHCDEP}
GHC= ghc-5.04.3
GHCDEP= ghc5
.else
-GHC= ghc-6.2.1
+GHC= ghc-6.2.2
GHCDEP= ghc
.endif
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index bf3154cb2ba5..ed7bb07f3ea0 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= ghc
-PORTVERSION= 6.2.1
+PORTVERSION= 6.2.2
CATEGORIES= lang haskell
MASTER_SITES= http://www.haskell.org/ghc/dist/${PORTVERSION}/:source \
http://www.haskell.org/ghc/dist/${PORTVERSION}/FreeBSD/:boot
@@ -19,10 +19,6 @@ BOOT_DIST5= ghc-${PORTVERSION}-i386-unknown-freebsd5-boot${EXTRACT_SUFX}:boot
USE_BZIP2= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
DISTFILES= ${SRC_DIST}
.if ${OSVERSION} < 500000
@@ -41,7 +37,7 @@ USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-PLIST_SUB= GHC_VERSION=${PORTVERSION}
+PLIST_SUB= GHC_VERSION=${PORTVERSION}
.if defined(WITHOUT_PROFILE)
PLIST_SUB+= PROFILE="@comment "
.else
@@ -53,7 +49,7 @@ PLIST_SUB+= PROFILE=""
BOOT_DIR= ${WRKDIR}/ghc-${PORTVERSION}-boot
BOOT_GHC= ${BOOT_DIR}/bin/i386-unknown-freebsd/ghc-${PORTVERSION}
-CONFIGURE_ARGS= --with-ghc=${BOOT_GHC} --with-gcc=${CC}
+CONFIGURE_ARGS= --with-ghc=${BOOT_GHC} --with-gcc=${CC}
# specifying CONFIGURE_TARGET doesn't work for some reason.
CONFIGURE_TARGET=
# libgmp:
@@ -61,18 +57,18 @@ CONFIGURE_ENV+= CFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
# override TMPDIR because /tmp often doesn't have enough space
# to build some of the larger libraries.
-TMPDIR = ${WRKSRC}/tmp
-MAKE_ENV += TMPDIR=${TMPDIR}
+TMPDIR= ${WRKSRC}/tmp
+MAKE_ENV+= TMPDIR=${TMPDIR}
# Just do a stage1 build
-ALL_TARGET = stage1
+ALL_TARGET= stage1
MAKE_ENV += stage=1
pre-everything::
.if !defined(WITHOUT_PROFILE)
@${ECHO_CMD} "To build GHC without profiling libraries,"
@${ECHO_CMD} "hit Ctrl-C now and restart with 'make"
- @$(ECHO_CMD) "WITHOUT_PROFILE=YES'."
+ @${ECHO_CMD} "WITHOUT_PROFILE=YES'."
.else
@${ECHO_CMD} "Building GHC without profiling libraries."
.endif
diff --git a/lang/ghc/distinfo b/lang/ghc/distinfo
index 0357e7809c21..560799430b38 100644
--- a/lang/ghc/distinfo
+++ b/lang/ghc/distinfo
@@ -1,6 +1,6 @@
-MD5 (ghc-6.2.1-src.tar.bz2) = fa9f90fd6b8852679c5fc16509e94d7a
-SIZE (ghc-6.2.1-src.tar.bz2) = 5367409
-MD5 (ghc-6.2.1-i386-unknown-freebsd-boot.tar.bz2) = 8414f11ac59c2b8b4bd19c363a5f6f41
-SIZE (ghc-6.2.1-i386-unknown-freebsd-boot.tar.bz2) = 5647007
-MD5 (ghc-6.2.1-i386-unknown-freebsd5-boot.tar.bz2) = dc3538e580c08a0b3619a18e1f146a71
-SIZE (ghc-6.2.1-i386-unknown-freebsd5-boot.tar.bz2) = 5690738
+MD5 (ghc-6.2.2-src.tar.bz2) = 8dc5ab2137ef9593f52180b0b2423d7f
+SIZE (ghc-6.2.2-src.tar.bz2) = 5407409
+MD5 (ghc-6.2.2-i386-unknown-freebsd-boot.tar.bz2) = e9a83bc75c946d3d03f508a5cb972bee
+SIZE (ghc-6.2.2-i386-unknown-freebsd-boot.tar.bz2) = 5655704
+MD5 (ghc-6.2.2-i386-unknown-freebsd5-boot.tar.bz2) = ce8c37454fe298b2a1da89093302521e
+SIZE (ghc-6.2.2-i386-unknown-freebsd5-boot.tar.bz2) = 5627556
diff --git a/lang/ghc6-doc/Makefile b/lang/ghc6-doc/Makefile
index 4d1c73ae01d0..895b448def0a 100644
--- a/lang/ghc6-doc/Makefile
+++ b/lang/ghc6-doc/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= ghc6-doc
-PORTVERSION= 6.2.1
+PORTVERSION= 6.2.2
CATEGORIES= lang haskell
MASTER_SITES= http://www.haskell.org/ghc/docs/${PORTVERSION}/ \
http://www.haskell.org/ghc/docs/${PORTVERSION}/html/
-DISTFILES= building.html.tar.gz building.ps.gz hslibs.html.tar.gz \
+DISTFILES= building.ps.gz building.html.tar.gz hslibs.html.tar.gz \
hslibs.ps.gz libraries.html.tar.gz users_guide.html.tar.gz \
users_guide.ps.gz index.html
DIST_SUBDIR= ghc-${PORTVERSION}
diff --git a/lang/ghc6-doc/distinfo b/lang/ghc6-doc/distinfo
index d55056cd17c3..883bc8f1d202 100644
--- a/lang/ghc6-doc/distinfo
+++ b/lang/ghc6-doc/distinfo
@@ -1,16 +1,16 @@
-MD5 (ghc-6.2.1/building.html.tar.gz) = 211cb7de99a6db064ed6b1a7b78a3783
-SIZE (ghc-6.2.1/building.html.tar.gz) = 55933
-MD5 (ghc-6.2.1/building.ps.gz) = 55be42d34c1ff37614647bea8fb500dc
-SIZE (ghc-6.2.1/building.ps.gz) = 73196
-MD5 (ghc-6.2.1/hslibs.html.tar.gz) = 112d8947c6456544bd7e83033767b7b0
-SIZE (ghc-6.2.1/hslibs.html.tar.gz) = 36458
-MD5 (ghc-6.2.1/hslibs.ps.gz) = 0096649a399feaedfb942573f50cede1
-SIZE (ghc-6.2.1/hslibs.ps.gz) = 45819
-MD5 (ghc-6.2.1/libraries.html.tar.gz) = 37f8881eb687c4583734d27eeff356bd
-SIZE (ghc-6.2.1/libraries.html.tar.gz) = 518568
-MD5 (ghc-6.2.1/users_guide.html.tar.gz) = 049c0e100433a51ec3b3a58f24b780a5
-SIZE (ghc-6.2.1/users_guide.html.tar.gz) = 196164
-MD5 (ghc-6.2.1/users_guide.ps.gz) = e3fdf4ffd256876368f02bdadc637438
-SIZE (ghc-6.2.1/users_guide.ps.gz) = 273565
-MD5 (ghc-6.2.1/index.html) = 48cdf8e85945ef5735d38b841ae6f87a
-SIZE (ghc-6.2.1/index.html) = 1954
+MD5 (ghc-6.2.2/building.ps.gz) = 62fa6140315b59817178c0c734490fbe
+SIZE (ghc-6.2.2/building.ps.gz) = 73195
+MD5 (ghc-6.2.2/building.html.tar.gz) = 468e92908c9fb74a530d4b6ad28199c2
+SIZE (ghc-6.2.2/building.html.tar.gz) = 55934
+MD5 (ghc-6.2.2/hslibs.html.tar.gz) = 5239d6ebd1a9a1e875db503921c55caf
+SIZE (ghc-6.2.2/hslibs.html.tar.gz) = 36457
+MD5 (ghc-6.2.2/hslibs.ps.gz) = 0f2a86dc29157902a9735122bb1f6c54
+SIZE (ghc-6.2.2/hslibs.ps.gz) = 45819
+MD5 (ghc-6.2.2/libraries.html.tar.gz) = e81174308a2782ab83b23ef009ce44f2
+SIZE (ghc-6.2.2/libraries.html.tar.gz) = 524182
+MD5 (ghc-6.2.2/users_guide.html.tar.gz) = 5475d32b4e26c5d67850808ff3032558
+SIZE (ghc-6.2.2/users_guide.html.tar.gz) = 197576
+MD5 (ghc-6.2.2/users_guide.ps.gz) = ca8a9e70c3846283229c28cf628142ae
+SIZE (ghc-6.2.2/users_guide.ps.gz) = 275545
+MD5 (ghc-6.2.2/index.html) = 48cdf8e85945ef5735d38b841ae6f87a
+SIZE (ghc-6.2.2/index.html) = 1954
diff --git a/lang/ghc6-doc/pkg-plist b/lang/ghc6-doc/pkg-plist
index 3b8e9bbde711..4189352ba16c 100644
--- a/lang/ghc6-doc/pkg-plist
+++ b/lang/ghc6-doc/pkg-plist
@@ -467,9 +467,9 @@ share/doc/ghc6/users_guide/win32.html
share/doc/ghc6/users_guide/wrong-compilee.html
share/doc/ghc6/users_guide/wrong.html
share/doc/ghc6/users_guide/x1075.html
-share/doc/ghc6/users_guide/x11075.html
-share/doc/ghc6/users_guide/x11083.html
-share/doc/ghc6/users_guide/x11094.html
+share/doc/ghc6/users_guide/x11124.html
+share/doc/ghc6/users_guide/x11132.html
+share/doc/ghc6/users_guide/x11143.html
share/doc/ghc6/users_guide/x1712.html
share/doc/ghc6/users_guide/x956.html
@dirrm share/doc/ghc6/users_guide/stylesheet-images
diff --git a/x11-toolkits/hs-gtk+hs/Makefile b/x11-toolkits/hs-gtk+hs/Makefile
index 7b58422de1f2..98ce2810fedd 100644
--- a/x11-toolkits/hs-gtk+hs/Makefile
+++ b/x11-toolkits/hs-gtk+hs/Makefile
@@ -28,7 +28,7 @@ GHC= ghc-5.04.3
GHCDEP= ghc5
GHCMAJOR= 5
.else
-GHC= ghc-6.2.1
+GHC= ghc-6.2.2
GHCDEP= ghc
GHCMAJOR= 6
.endif
diff --git a/x11-toolkits/hs-gtk2hs/Makefile b/x11-toolkits/hs-gtk2hs/Makefile
index 9e874fe04869..1a5dbf657c35 100644
--- a/x11-toolkits/hs-gtk2hs/Makefile
+++ b/x11-toolkits/hs-gtk2hs/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= hs-
MAINTAINER= haskell@FreeBSD.org
COMMENT= A GTK2 Binding for Haskell
-BUILD_DEPENDS= ghc-6.2.1:${PORTSDIR}/lang/ghc
-RUN_DEPENDS= ghc-6.2.1:${PORTSDIR}/lang/ghc
+BUILD_DEPENDS= ghc-6.2.2:${PORTSDIR}/lang/ghc
+RUN_DEPENDS= ghc-6.2.2:${PORTSDIR}/lang/ghc
USE_GNOME= gtk20 libglade gtksourceview
HAS_CONFIGURE= yes